aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-11-13 12:44:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-11-13 12:44:13 +0000
commite5e45eab29b03d1e60862ac7d35c77d3356fb197 (patch)
tree31c2e2afdbe0c31372d29c057b08e86104b7fb8f /cad
parent97f8268e2c09131c16ef81729f8508d9ee1efe67 (diff)
downloadports-e5e45eab29b03d1e60862ac7d35c77d3356fb197.tar.gz
ports-e5e45eab29b03d1e60862ac7d35c77d3356fb197.zip
Upgrade Code_Aster to 12.0.6-4.
This brings french/eficas to 2016.0.1, cad/astk-serveur and astk-client to 1.13.8.2, french/med to 3.2.0 (built against hdf5-18), bump PORTREVSION to math/metis-edf and fix soname, and french/homard to 11.7-1.
Notes
Notes: svn path=/head/; revision=426042
Diffstat (limited to 'cad')
-rw-r--r--cad/astk-serveur/Makefile32
-rw-r--r--cad/astk-serveur/files.client/patch-bin_astk11
-rw-r--r--cad/astk-serveur/files/patch-etc_profile.csh14
-rw-r--r--cad/astk-serveur/pkg-plist25
4 files changed, 46 insertions, 36 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index fa8705a03a51..788c029d0244 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= astk
-DISTVERSION= 1.13.5-1
+DISTVERSION= 1.13.8-2
CATEGORIES= cad
.if !defined(CLIENT_SEUL)
PKGNAMESUFFIX= -serveur
@@ -40,6 +40,7 @@ REINPLACE_ARGS= -i ""
EXTRACT_WRKSRC= ${WRKDIR}/aster-${DISTVERSIONPREFIX}${ASTER_DISTVERSION:S/-/./:R}/SRC
+NO_ARCH= yes
SUB_FILES= pkg-message
SUB_LIST= inst_dir=${inst_dir} tools_dir=${tools_dir}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -47,8 +48,7 @@ LINSTDIR= aster/ASTK
inst_dir= ${PREFIX}/${LINSTDIR}
aster_dir= ${LOCALBASE}/aster/${vaster}
S_SCRIPTS= bin/as_run bin/parallel_cp asrun/installation.py \
- share/codeaster/asrun/data/mpirun_template \
- etc/profile.csh
+ share/codeaster/asrun/data/mpirun_template
S_PYLIBS= share/codeaster/asrun/examples/alamain.py \
unittest/datafiles/config_serveurs unittest/010_misc.py \
unittest/015_package.py unittest/run_test.py
@@ -58,13 +58,14 @@ conf_dir= ${WRKSRC}/etc/astkrc
.include <bsd.port.pre.mk>
+WRKCONF= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/configuration
.if !defined(CLIENT_SEUL)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/ASTK_SERV
PATCHDIR= ${MASTERDIR}/files
-PLIST_SUB= ASTKDIR=${LINSTDIR}/ASTK_SERV SERV="" CLIENT="@comment " \
+PLIST_SUB= ASTKDIR=${LINSTDIR}/ASTK_SERV SERV="" CLIENT="@comment "\
vaster=${vaster}
-PATCH2RM= bin/as_run bin/parallel_cp etc/asrun etc/profile.csh etc/profile.sh \
- asrun/config.py asrun/installation.py asrun/system.py \
+PATCH2RM= bin/as_run bin/parallel_cp etc/asrun etc/profile.sh \
+ asrun/config.py asrun/installation.py asrun/system.py \
asrun/common/sysutils.py asrun/system_command.py
. if exists(${LOCALBASE}/sbin/pbs_server)
WITH_PBS= yes
@@ -121,6 +122,9 @@ SHIA= zsh
.endif
SHIADEP= ${SHIA}
BASH2RC= asrun/calcul.py share/codeaster/asrun/data/mpirun_template
+BASH2RC2= lib/tkselecteur.tcl
+BASH2RC3= deprecated_outils.sh extract_info.py deprecated_client.sh \
+ deprecated_server.sh
.if !defined(WITH_ED)
. if exists(${LOCALBASE}/bin/nedit)
@@ -132,9 +136,6 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:editors/vim
. elif exists(${LOCALBASE}/bin/emacs)
WITH_ED= emacs
RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:editors/emacs
-. elif exists(${LOCALBASE}/bin/xemacs)
-WITH_ED= xemacs
-RUN_DEPENDS+= ${LOCALBASE}/bin/xemacs:editors/xemacs
. elif exists(${LOCALBASE}/bin/gedit)
WITH_ED= gedit
RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:editors/gedit
@@ -197,16 +198,14 @@ do-configure:
-e "s|LOCALBASE|${LOCALBASE}|" \
${WRKSRC}/etc/${sc}
. endfor
-. for sh in sh csh
${REINPLACE_CMD} -e "s|?ASTER_ROOT?|${LOCALBASE}/aster|" \
-e 's|?HOME_PYTHON?|${PYTHONBASE}|' \
-e 's|?ASRUN_SITE_PKG?|${PREFIX}/${LINSTDIR}/ASTK_SERV|' \
-e 's|?PYTHON_EXE?|${PYTHON_CMD}|' \
-e 's|?HOME_MED?|${LOCALBASE}|' \
-e 's|?HOME_HDF?|${LOCALBASE}|' \
- -e "s|?WISH_EXE?|${WISH}|" \
- ${WRKSRC}/etc/profile.${sh}
-. endfor
+ -e "s|?WISH_EXE?|${WISH}|" \
+ ${WRKSRC}/etc/profile.sh
. for libs in ${S_PYLIBS}
${REINPLACE_CMD} -e "s|/opt/aster/NEW9|${aster_dir}|" \
-e "s|/opt/aster/NEW10|${aster_dir}|" \
@@ -262,7 +261,13 @@ do-configure:
${WRKSRC}/lib/tkselecteur.tcl
${REINPLACE_CMD} -e "s|%%unamesm%%|${unamesm}|" \
${WRKSRC}/lib/init.tcl
+. for sh in ${BASH2RC2}
+ ${REINPLACE_CMD} -e 's|/bin/bash|${SHELL_INSTALL_ASTER}|' ${WRKSRC}/${sh}
+. endfor
.endif
+.for sh in ${BASH2RC3}
+ ${REINPLACE_CMD} -e 's|/bin/bash|${SHELL_INSTALL_ASTER}|' ${WRKCONF}/${sh}
+.endfor
do-install:
${MKDIR} ${STAGEDIR}${inst_dir}
@@ -278,6 +283,7 @@ do-install:
(cd ${STAGEDIR}${PREFIX} \
&& ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
-d ${PREFIX} -f aster)
+ ${MV} ${STAGEDIR}${ETCDIR}/profile.sh ${STAGEDIR}${ETCDIR}/profile_astk.sh
. if defined(WITH_MPI)
${ECHO_CMD} "localhost" > ${STAGEDIR}${PREFIX}/aster/aster-mpihosts
. endif
diff --git a/cad/astk-serveur/files.client/patch-bin_astk b/cad/astk-serveur/files.client/patch-bin_astk
index d28765d365b3..bb9215fe8d34 100644
--- a/cad/astk-serveur/files.client/patch-bin_astk
+++ b/cad/astk-serveur/files.client/patch-bin_astk
@@ -1,5 +1,5 @@
---- bin/astk.orig 2011-12-20 13:33:00.000000000 +0100
-+++ bin/astk 2012-05-08 12:31:09.000000000 +0200
+--- bin/astk.orig 2015-08-05 15:37:44 UTC
++++ bin/astk
@@ -17,15 +17,9 @@
# 1 AVENUE DU GENERAL DE GAULLE, 92141 CLAMART CEDEX, FRANCE.
# ==============================================================================
@@ -9,19 +9,18 @@
- local bin=`dirname $this`
- prefix=`dirname $bin`
-}
+-
+-set_prefix $0
+prefix=%%inst_dir%%/ASTK_CLIENT
--set_prefix $0
--
-ASTER_ROOT=$prefix
+ASTER_ROOT=?ASTER_ROOT?
ASTER_ETC=$ASTER_ROOT/etc
if [ "$ASTER_ROOT" = "/usr" ]; then
ASTER_ETC=/etc
-@@ -43,5 +37,5 @@
+@@ -43,4 +37,4 @@ if [ -z "$WISHEXECUTABLE" ]; then
WISHEXECUTABLE=wish
fi
-$WISHEXECUTABLE $ASTER_ROOT/lib/astk/astk.tcl -- $* &
+$WISHEXECUTABLE $prefix/lib/astk.tcl -- $* &
-
diff --git a/cad/astk-serveur/files/patch-etc_profile.csh b/cad/astk-serveur/files/patch-etc_profile.csh
deleted file mode 100644
index 001a0065937e..000000000000
--- a/cad/astk-serveur/files/patch-etc_profile.csh
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./etc/profile.csh.orig 2009-12-23 15:53:06.000000000 +0100
-+++ ./etc/profile.csh 2010-01-10 21:45:50.000000000 +0100
-@@ -38,6 +38,11 @@
- # this should not be usefull...
- #setenv PYTHONHOME ?HOME_PYTHON?
-
-+# Might be useful to fix errors on 64 bits platforms
-+# See <http://www.code-aster.org/forum/read.php?f=11&i=1603&t=1574>
-+setenv HOME_MED ?HOME_MED?
-+setenv HOME_HDF ?HOME_HDF?
-+
- setenv WISHEXECUTABLE ?WISH_EXE?
-
-
diff --git a/cad/astk-serveur/pkg-plist b/cad/astk-serveur/pkg-plist
index 96e652fc0f43..5e3fb8de4897 100644
--- a/cad/astk-serveur/pkg-plist
+++ b/cad/astk-serveur/pkg-plist
@@ -372,6 +372,9 @@
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.pyo
+%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.py
+%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.pyc
+%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.pyo
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.pyo
@@ -381,6 +384,9 @@
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.pyo
+%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.py
+%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.pyc
+%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.pyo
%%SERV%%%%ASTKDIR%%/asrun/profil.py
%%SERV%%%%ASTKDIR%%/asrun/profil.pyc
%%SERV%%%%ASTKDIR%%/asrun/profil.pyo
@@ -399,6 +405,9 @@
%%SERV%%%%ASTKDIR%%/asrun/run.py
%%SERV%%%%ASTKDIR%%/asrun/run.pyc
%%SERV%%%%ASTKDIR%%/asrun/run.pyo
+%%SERV%%%%ASTKDIR%%/asrun/runner.py
+%%SERV%%%%ASTKDIR%%/asrun/runner.pyc
+%%SERV%%%%ASTKDIR%%/asrun/runner.pyo
%%SERV%%%%ASTKDIR%%/asrun/schema.py
%%SERV%%%%ASTKDIR%%/asrun/schema.pyc
%%SERV%%%%ASTKDIR%%/asrun/schema.pyo
@@ -448,13 +457,18 @@
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.py
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.pyo
+%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.py
+%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.pyc
+%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.pyo
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.py
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.pyo
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.py
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.pyo
-%%SERV%%%%ASTKDIR%%/etc/profile.csh
+%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.py
+%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.pyc
+%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.pyo
%%SERV%%%%ASTKDIR%%/etc/profile.sh
%%SERV%%%%ASTKDIR%%/i18n/Makefile
%%SERV%%%%ASTKDIR%%/i18n/asrun.fr.mo
@@ -579,11 +593,16 @@
%%SERV%%%%ETCDIR%%/plugins/aster5.py
%%SERV%%%%ETCDIR%%/plugins/aster5.pyc
%%SERV%%%%ETCDIR%%/plugins/aster5.pyo
+%%SERV%%%%ETCDIR%%/plugins/athosdev.py
+%%SERV%%%%ETCDIR%%/plugins/athosdev.pyc
+%%SERV%%%%ETCDIR%%/plugins/athosdev.pyo
%%SERV%%%%ETCDIR%%/plugins/ivanoe.py
%%SERV%%%%ETCDIR%%/plugins/ivanoe.pyc
%%SERV%%%%ETCDIR%%/plugins/ivanoe.pyo
%%SERV%%%%ETCDIR%%/plugins/sge_pe.py
%%SERV%%%%ETCDIR%%/plugins/sge_pe.pyc
%%SERV%%%%ETCDIR%%/plugins/sge_pe.pyo
-%%SERV%%%%ETCDIR%%/profile.csh
-%%SERV%%%%ETCDIR%%/profile.sh
+%%SERV%%%%ETCDIR%%/plugins/tail_slurm.py
+%%SERV%%%%ETCDIR%%/plugins/tail_slurm.pyc
+%%SERV%%%%ETCDIR%%/plugins/tail_slurm.pyo
+%%SERV%%%%ETCDIR%%/profile_astk.sh