aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:43:42 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:43:42 +0000
commitf1f118cc9e6e903092c2a37407714f282e5a77ac (patch)
tree030817d04336b5e29d17e24344ef0e99a4be6c11 /cad
parenta2311f88b7dc560c0083a08c47de7dffeb2212c6 (diff)
downloadports-f1f118cc9e6e903092c2a37407714f282e5a77ac.tar.gz
ports-f1f118cc9e6e903092c2a37407714f282e5a77ac.zip
[NEW PORT] cad/py-ezdxf: Create and modify DXF drawings
A Python package to create and modify DXF drawings, independent from the DXF version. You can open/save every DXF file without losing any content (except comments), Unknown tags in the DXF file will be ignored but preserved for saving. With this behavior it is possible to open also DXF drawings that contains data from 3rd party applications. PR: 248203 Submitted by: Neal Nelson Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D25890
Notes
Notes: svn path=/head/; revision=543825
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/py-ezdxf/Makefile33
-rw-r--r--cad/py-ezdxf/distinfo3
-rw-r--r--cad/py-ezdxf/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 7ca58e960b7b..faf247216107 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -90,6 +90,7 @@
SUBDIR += p5-Verilog-Perl
SUBDIR += pcb
SUBDIR += pdnmesh
+ SUBDIR += py-ezdxf
SUBDIR += py-gdspy
SUBDIR += py-lcapy
SUBDIR += py-phidl
diff --git a/cad/py-ezdxf/Makefile b/cad/py-ezdxf/Makefile
new file mode 100644
index 000000000000..50ccf7a25137
--- /dev/null
+++ b/cad/py-ezdxf/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= ezdxf
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.13.1
+CATEGORIES= cad
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= Create and modify DXF drawings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}geomdl>0:graphics/py-geomdl@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}geomdl>0:graphics/py-geomdl@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= concurrent distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= mozman
+GH_PROJECT= ezdxf
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/cad/py-ezdxf/distinfo b/cad/py-ezdxf/distinfo
new file mode 100644
index 000000000000..b85c1a08d459
--- /dev/null
+++ b/cad/py-ezdxf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595510623
+SHA256 (mozman-ezdxf-v0.13.1_GH0.tar.gz) = 403e931d029047f72e5f445f352849856e2cbede4eb253bcf3d089bd0321be71
+SIZE (mozman-ezdxf-v0.13.1_GH0.tar.gz) = 10762617
diff --git a/cad/py-ezdxf/pkg-descr b/cad/py-ezdxf/pkg-descr
new file mode 100644
index 000000000000..5d224993b094
--- /dev/null
+++ b/cad/py-ezdxf/pkg-descr
@@ -0,0 +1,7 @@
+A Python package to create and modify DXF drawings, independent from the DXF
+version. You can open/save every DXF file without losing any content (except
+comments), Unknown tags in the DXF file will be ignored but preserved for
+saving. With this behavior it is possible to open also DXF drawings that
+contains data from 3rd party applications.
+
+WWW: https://ezdxf.mozman.at/