aboutsummaryrefslogtreecommitdiff
path: root/chinese/autoconvert
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-16 08:41:33 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-16 08:41:33 +0000
commit63bf19aff0b0116634fd65cb7dc100a3a275184a (patch)
tree34ce40c39187c987f43b5196f321b99228abc34e /chinese/autoconvert
parentdc35e9f9c41fca8d5b362cac954967c525a3d25b (diff)
downloadports-63bf19aff0b0116634fd65cb7dc100a3a275184a.tar.gz
ports-63bf19aff0b0116634fd65cb7dc100a3a275184a.zip
- Fix build on -current
PR: 58084 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=91410
Diffstat (limited to 'chinese/autoconvert')
-rw-r--r--chinese/autoconvert/Makefile2
-rw-r--r--chinese/autoconvert/files/patch-autogb.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index 56f1bc9d1dfa..3d16744c36ff 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -15,7 +15,7 @@ COMMENT= Intelligent Chinese encoding converter
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-CFLAGS+= "${CPPFLAGS}"
+CFLAGS+= ${CPPFLAGS}
MAKE_ENV= CFLAG="${CPPFLAGS}" LIBS="${LDFLAGS}"
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/chinese/autoconvert/files/patch-autogb.c b/chinese/autoconvert/files/patch-autogb.c
new file mode 100644
index 000000000000..737d666510bc
--- /dev/null
+++ b/chinese/autoconvert/files/patch-autogb.c
@@ -0,0 +1,26 @@
+--- autogb.c.orig Mon Apr 23 22:18:06 2001
++++ autogb.c Wed Oct 15 17:28:48 2003
+@@ -34,15 +34,14 @@
+ void print_help(char* filename){
+ printf("\nUsage: %s [-OPTION] < input > output\n", filename);
+ puts(
+-"Now autoconvert can only judge gb/big5/hz encoding, so if you want to
+-do other conversion, you must set the option --input. Without --input,
+-the program will guess the encoding of the input.
+-OPTION is one of (case insensitive):
+- -i encoding, --input encoding: Set the input encoding
+- -o encoding, --output encoding: Set the output encoding
+-
+- The encoding should be gb, big5, hz, uni, utf7 or utf8.
+- ");
++"Now autoconvert can only judge gb/big5/hz encoding, so if you want to "
++"do other conversion, you must set the option --input. Without --input,"
++"the program will guess the encoding of the input."
++"OPTION is one of (case insensitive):"
++" -i encoding, --input encoding: Set the input encoding"
++" -o encoding, --output encoding: Set the output encoding"
++" The encoding should be gb, big5, hz, uni, utf7 or utf8."
++" ");
+
+ exit(0);
+ }