aboutsummaryrefslogtreecommitdiff
path: root/chinese/cce
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 02:08:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 02:08:16 +0000
commitead3c9a643d2764145eb972356a7c0cee3894601 (patch)
tree00fb0aaa1a76d1cab5e80dc4e8b241313df0c680 /chinese/cce
parentb7cb61dc4fbb315d6e8fa3fea75b13d0e13b8107 (diff)
downloadports-ead3c9a643d2764145eb972356a7c0cee3894601.tar.gz
ports-ead3c9a643d2764145eb972356a7c0cee3894601.zip
fix -current build error
PR: ports/45709 Submitted by: Statue <statue@freebsd.sinica.edu.tw>
Notes
Notes: svn path=/head/; revision=72323
Diffstat (limited to 'chinese/cce')
-rw-r--r--chinese/cce/Makefile6
-rw-r--r--chinese/cce/files/patch-inputs::hzinput.h11
2 files changed, 16 insertions, 1 deletions
diff --git a/chinese/cce/Makefile b/chinese/cce/Makefile
index 4a475bd7c2ff..eaff3128fc0f 100644
--- a/chinese/cce/Makefile
+++ b/chinese/cce/Makefile
@@ -20,6 +20,7 @@ MAINTAINER= statue@freebsd.sinica.edu.tw
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_REINPLACE= yes
+REINPLACE_ARGS= # empty
MAN1= cce.1
@@ -29,6 +30,9 @@ pre-configure:
.include <bsd.port.pre.mk>
post-patch:
.if ${OSVERSION} > 500012
- @${FIND} ${WRKSRC}/src/ -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e 's,machine/console.h>,sys/consio.h>\n#include <sys/fbio.h>\n#include <sys/kbio.h>\n,'
+.for i in src/key.c src/main.c src/term.c src/vc.c src/vga.c
+ ${REINPLACE_CMD} "s,machine/console.h>,sys/consio.h>@#include <sys/fbio.h>@#include <sys/kbio.h>@," ${WRKSRC}/${i}| tr '@' '\n' > ${WRKSRC}/${i}.bakk && \
+ ${MV} ${WRKSRC}/${i}.bakk ${WRKSRC}/${i}
+.endfor
.endif
.include <bsd.port.post.mk>
diff --git a/chinese/cce/files/patch-inputs::hzinput.h b/chinese/cce/files/patch-inputs::hzinput.h
new file mode 100644
index 000000000000..734eaec27c4d
--- /dev/null
+++ b/chinese/cce/files/patch-inputs::hzinput.h
@@ -0,0 +1,11 @@
+--- inputs/hzinput.h.orig Mon Nov 25 18:00:10 2002
++++ inputs/hzinput.h Mon Nov 25 17:59:37 2002
+@@ -86,7 +86,7 @@
+ } hz_input_table;
+
+ /************ private functions *******************/
+-void InputAreaOutput(int x, u_char *string, int fg, int bg);
++/*void InputAreaOutput(int x, u_char *string, int fg, int bg);*/
+ void FindMatchKey(void);
+ void FillMatchChars(int j);
+ void FillAssociateChars(int index);