aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 15:11:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 15:11:54 +0000
commit2d95915f0dbfa1deebfb958b74e5a0de3c43327a (patch)
tree5171bc558f465f244c14f96af725ea289500db5f /chinese/fcitx/Makefile
parent244a0f963411277284543e7da9616c8919ed8129 (diff)
downloadports-2d95915f0dbfa1deebfb958b74e5a0de3c43327a.tar.gz
ports-2d95915f0dbfa1deebfb958b74e5a0de3c43327a.zip
chinece/fcitx: remove QT4 option (Qt4 deprecation)
Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=495880
Diffstat (limited to 'chinese/fcitx/Makefile')
-rw-r--r--chinese/fcitx/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 45c66808a404..62f580e8fc6c 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fcitx
PORTVERSION= 4.2.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese x11
MASTER_SITES= http://download.fcitx-im.org/fcitx/:fcitx \
http://download.fcitx-im.org/data/:data
@@ -48,7 +48,7 @@ USES= compiler:c++11-lang gnome qt:4 tar:xz cmake:noninja desktop-file-utils \
kde:5 pkgconfig shared-mime-info compiler:c++14-lang
INSTALLS_ICONS= yes
-OPTIONS_DEFINE= GTK2 GTK3 QT4 OPENCC TPUNC DOCS
+OPTIONS_DEFINE= GTK2 GTK3 OPENCC TPUNC DOCS
OPTIONS_DEFAULT=GTK2 GTK3
OPTIONS_SUB= yes
@@ -60,7 +60,6 @@ GTK3_DESC= Enable Gtk3 IM module
GTK3_USE= GNOME=gtk30
GTK3_CMAKE_ON= -DENABLE_GTK3_IM_MODULE=ON
-QT4_DESC= Enable Qt4 IM module
OPENCC_DESC= Enable OpenCC for Chinese Transform
TPUNC_DESC= Use traditional quotation marks
@@ -74,7 +73,7 @@ CMAKE_ARGS+= -DENABLE_XDGAUTOSTART=OFF -DFORCE_ENCHANT=ON \
-DGOBJECT_INTROSPECTION_TYPELIBDIR=${PREFIX}/lib/girepository-1.0 \
-DMANPREFIX=${MANPREFIX} \
-DPREFIX=${PREFIX} \
- -DQT_PLUGINS_DIR=${PREFIX}/lib/qt4/plugins
+ -DENABLE_QT=OFF -DENABLE_QT_IM_MODULE=OFF -DENABLE_QT_GUI=OFF
.if ${PORT_OPTIONS:MGTK2}
SUB_LIST+= GTK2_IM=fcitx
@@ -90,18 +89,6 @@ PLIST_SUB+= GTK3="@comment "
SUB_LIST+= GTK3_IM=xim
.endif
-.if ${PORT_OPTIONS:MQT4}
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-USES+= qt:4
-USE_QT+= qmake_build moc_build rcc_build uic_build dbus gui inputmethods corelib
-USE_LDCONFIG+= ${PREFIX}/lib/fcitx/qt
-PLIST_SUB+= QT4=""
-.else
-CMAKE_ARGS+= -DENABLE_QT=OFF -DENABLE_QT_IM_MODULE=OFF -DENABLE_QT_GUI=OFF
-PLIST_SUB+= QT4="@comment "
-.endif
-
.if ${PORT_OPTIONS:MOPENCC}
LIB_DEPENDS+= libopencc.so:chinese/opencc
.else