aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-table-other/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 17:58:42 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 17:58:42 +0000
commitf6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d (patch)
tree8091568f2e9424814d1cf7be2d55fda2e6f28aa0 /chinese/fcitx5-table-other/Makefile
parentbe43f10a6c1f249db56cea11bfa9090305e3f23e (diff)
downloadports-f6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d.tar.gz
ports-f6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d.zip
Add extra languages and schemas supports to Fcitx IME framework
New ports added: - korean/fcitx5-hangul - chinese/libime - textproc/fcitx5-lua - chinese/fcitx5-chinese-addons - chinese/fcitx5-table-extra - chinese/fcitx5-table-other - chinese/libime-jyutping Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27796
Notes
Notes: svn path=/head/; revision=559598
Diffstat (limited to 'chinese/fcitx5-table-other/Makefile')
-rw-r--r--chinese/fcitx5-table-other/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/chinese/fcitx5-table-other/Makefile b/chinese/fcitx5-table-other/Makefile
new file mode 100644
index 000000000000..d6637c260fa3
--- /dev/null
+++ b/chinese/fcitx5-table-other/Makefile
@@ -0,0 +1,30 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-table-other
+DISTVERSION= 5.0.1
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Other table support for Fcitx5
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libIMETable.so:chinese/libime \
+ libFcitx5Core.so:textproc/fcitx5
+
+USES= gettext-tools cmake kde:5
+
+OPTIONS_DEFINE= DEPRECATED
+
+DEPRECATED_DESC= Deprecated tables
+DEPRECATED_CMAKE_BOOL= ENABLE_DEPRECATED
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+INSTALL_TARGET= install
+
+.include <bsd.port.mk>