aboutsummaryrefslogtreecommitdiff
path: root/chinese/ntuttf
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-05-13 01:34:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-05-13 01:34:31 +0000
commit72a1165afd1be6dea8697ffce3bf8c2bfeb58f76 (patch)
tree3340ca9f018b5d6bc7bd95a4273dd6c10124ddb5 /chinese/ntuttf
parent36b51565fd334bf323bed0c6c4ec82f13cd695a7 (diff)
downloadports-72a1165afd1be6dea8697ffce3bf8c2bfeb58f76.tar.gz
ports-72a1165afd1be6dea8697ffce3bf8c2bfeb58f76.zip
Add ntuttf 1.0, seven Chinese Big5 TrueType fonts made by NTU.
PR: 50820 Submitted by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
Notes
Notes: svn path=/head/; revision=80867
Diffstat (limited to 'chinese/ntuttf')
-rw-r--r--chinese/ntuttf/Makefile71
-rw-r--r--chinese/ntuttf/distinfo7
-rw-r--r--chinese/ntuttf/pkg-deinstall24
-rw-r--r--chinese/ntuttf/pkg-descr20
-rw-r--r--chinese/ntuttf/pkg-install39
-rw-r--r--chinese/ntuttf/pkg-plist9
6 files changed, 170 insertions, 0 deletions
diff --git a/chinese/ntuttf/Makefile b/chinese/ntuttf/Makefile
new file mode 100644
index 000000000000..cf500892c3e7
--- /dev/null
+++ b/chinese/ntuttf/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: NTU Chinese TrueType fonts
+# Date created: 11 April 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntuttf
+PORTVERSION= 1.0
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= ftp://cle.linux.org.tw/pub/fonts/ttf/unicode/ntu/ \
+ ftp://freebsd.sinica.edu.tw/pub/statue/ntuttf/
+DISTFILES= NTU_FS_M.TTF NTU_KAI.TTF NTU_LI_M.TTF NTU_MB.TTF \
+ NTU_MM.TTF NTU_MR.TTF NTU_TW.TTF
+EXTRACT_ONLY= # empty
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= Seven Chinese Big5 TrueType fonts made by NTU
+
+RUN_DEPENDS= ttfm.sh:${PORTSDIR}/chinese/ttfm
+
+NO_BUILD= yes
+SHAREMODE= 644
+USE_XLIB= yes
+FONTDIR= ${PREFIX}/share/fonts/TrueType
+XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
+INSTALL_ENV= PKG_PREFIX=${PREFIX} XFREE86_VERSION=${XFREE86_VERSION} \
+ WANT_CJK=${WANT_CJK} WANT_GS=${WANT_GS} \
+ WITHOUT_X=${WITHOUT_X}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WANT_CJK)
+RUN_DEPENDS+= bg5latex:${PORTSDIR}/chinese/CJK
+.endif
+.if defined(WANT_GS)
+RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
+.endif
+.if ${XFREE86_VERSION} == 3 && !defined(WITHOUT_X)
+RUN_DEPENDS+= mkfontdir.pl:${PORTSDIR}/x11-servers/XttXF86srv-common
+.endif
+
+pre-fetch:
+.if defined(WANT_CJK)
+ @${ECHO} "CJK support will be added."
+.endif
+.if defined(WANT_GS)
+ @${ECHO} "Ghostscript support will be added."
+.endif
+.if defined(WITHOUT_X)
+ @${ECHO} "X Window support will NOT be added."
+.endif
+.if !defined(WANT_CJK) && !defined(WANT_GS) && !defined(WITHOUT_X)
+ @${ECHO} --
+ @${ECHO} "Type \"make WANT_CJK=yes\" if you want CJK support."
+ @${ECHO} "Type \"make WANT_GS=yes\" if you want Ghostscript support."
+ @${ECHO} "Type \"make WITHOUT_X=yes\" if you DONT want X Window support."
+ @${ECHO} "You can use them in combinations."
+ @${ECHO} --
+.endif
+
+do-install:
+.if !exists(${FONTDIR})
+ @${MKDIR} ${FONTDIR}
+.endif
+.for i in ${DISTFILES}
+ @${INSTALL_DATA} ${DISTDIR}/${i} ${FONTDIR}
+.endfor
+ @${SETENV} ${INSTALL_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/chinese/ntuttf/distinfo b/chinese/ntuttf/distinfo
new file mode 100644
index 000000000000..1639c9b781cd
--- /dev/null
+++ b/chinese/ntuttf/distinfo
@@ -0,0 +1,7 @@
+MD5 (NTU_FS_M.TTF) = dc2a25c8825423a37f36da1c158a32fd
+MD5 (NTU_KAI.TTF) = d208682e5c0a6f347d8e1e14962a4887
+MD5 (NTU_LI_M.TTF) = 8dc43f6b02e22a7b4f3d083c16c92e80
+MD5 (NTU_MB.TTF) = e82abcb9de37bbf39a7faa32368d09e3
+MD5 (NTU_MM.TTF) = a2f7fe50c75b222cc16a8f766b787317
+MD5 (NTU_MR.TTF) = b772aea4bc3c340604a0ad98696c766a
+MD5 (NTU_TW.TTF) = 68f21e60a8eac47089b612a93e14a04c
diff --git a/chinese/ntuttf/pkg-deinstall b/chinese/ntuttf/pkg-deinstall
new file mode 100644
index 000000000000..a4fed9c5274a
--- /dev/null
+++ b/chinese/ntuttf/pkg-deinstall
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if [ "$2" != "DEINSTALL" ]; then
+ exit 0
+fi
+
+PKGNAME=$1
+PREFIX=${PKG_PREFIX}
+TTFM=${PKG_PREFIX}/bin/ttfm.sh
+
+FONTDIR=${PREFIX}/share/fonts/TrueType
+FONTS="NTU_FS_M.TTF NTU_KAI.TTF NTU_LI_M.TTF NTU_MB.TTF NTU_MM.TTF NTU_MR.TTF NTU_TW.TTF"
+
+if [ -r $FONTDIR/$PKGNAME ]; then
+ for i in `cat $FONTDIR/$PKGNAME`; do
+ for f in $FONTS; do
+ $TTFM --remove $i $f
+ done
+ done
+fi
+
+rm -f $FONTDIR/$PKGNAME
+
+exit 0
diff --git a/chinese/ntuttf/pkg-descr b/chinese/ntuttf/pkg-descr
new file mode 100644
index 000000000000..a386b72fe665
--- /dev/null
+++ b/chinese/ntuttf/pkg-descr
@@ -0,0 +1,20 @@
+Date: Thu, 17 Mar 94 14:18:18 CST
+From: Lin YawJen <f1506015@csman.csie.ntu.edu.tw>
+
+HISTORY======
+I had written a program to convert fonts from large bitmap into TrueTypefor
+MS-Windows. For Mac, see ifcss.org:/software/fonts/mac/ the bitmaps came
+from DYNAFONT (Hua2 Kang1) and ETen..
+This is the critical point of this product.
+
+
+COPYRIGHT=========
+These fonts are created by Mr. Lin Yaw-JenAll Right reserved.
+These fonts must not be used for any commercial activities.
+
+Lab of OA Network
+Home: 4F, No. 12-2 Alley 2 Lane 250 Sec 5 Nanking East Rd.
+Department of Computer Science and Information Engineering
+Taipei Taiwan R.O.C National Taiwan University
+Tel: 886-2-7641236 Taipei Taiwan R.O.C
+Fax: 886-2-760184 Email: f1506015@csman.csie.ntu.edu.tw
diff --git a/chinese/ntuttf/pkg-install b/chinese/ntuttf/pkg-install
new file mode 100644
index 000000000000..e6caa640b670
--- /dev/null
+++ b/chinese/ntuttf/pkg-install
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+if [ "$2" = "PRE-INSTALL" ]; then
+ exit 0
+fi
+
+PKGNAME=$1
+PREFIX=${PKG_PREFIX}
+TTFM=${PREFIX}/bin/ttfm.sh
+
+FONTDIR=${PREFIX}/share/fonts/TrueType
+FONTS="NTU_FS_M.TTF NTU_KAI.TTF NTU_LI_M.TTF NTU_MB.TTF NTU_MM.TTF NTU_MR.TTF NTU_TW.TTF"
+
+if [ ! -x $TTFM ]; then
+ echo "$TTFM not found!"
+ exit 1
+fi
+
+rm -f $FONTDIR/$PKGNAME
+
+if [ "X$WANT_CJK" != "X" ]; then
+ # There's no CJK module now.
+fi
+
+if [ "X$WANT_GS" != "X" ]; then
+ for f in $FONTS; do
+ $TTFM --add gscjk $FONTDIR/$f
+ done
+ echo "gscjk" >> $FONTDIR/$PKGNAME
+fi
+
+if [ "X$WITHOUT_X" = "X" ]; then
+ for f in $FONTS; do
+ $TTFM --add xttfm $FONTDIR/$f
+ done
+ echo "xttfm" >> $FONTDIR/$PKGNAME
+fi
+
+exit 0
diff --git a/chinese/ntuttf/pkg-plist b/chinese/ntuttf/pkg-plist
new file mode 100644
index 000000000000..cc28593dd5c3
--- /dev/null
+++ b/chinese/ntuttf/pkg-plist
@@ -0,0 +1,9 @@
+share/fonts/TrueType/NTU_FS_M.TTF
+share/fonts/TrueType/NTU_KAI.TTF
+share/fonts/TrueType/NTU_LI_M.TTF
+share/fonts/TrueType/NTU_MB.TTF
+share/fonts/TrueType/NTU_MM.TTF
+share/fonts/TrueType/NTU_MR.TTF
+share/fonts/TrueType/NTU_TW.TTF
+@unexec rmdir %D/share/fonts/TrueType 2>/dev/null || true
+@unexec rmdir %D/share/fonts 2>/dev/null || true