aboutsummaryrefslogtreecommitdiff
path: root/chinese/rime-cangjie
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-17 10:47:28 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-17 10:47:28 +0000
commit5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b (patch)
tree54faa7db045057bbb39ef2ba59dab48084f173c3 /chinese/rime-cangjie
parent0d56e935721190a97decfe2077ab142269c09fe8 (diff)
downloadports-5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b.tar.gz
ports-5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b.zip
Add chinese/rime-data and its dependencies
A new metaport that provides an essential set of configuration ports and a preset of IME schema ports for the Rime IME framework. This is a metaport which depends on the following essential ports: chinese/rime-essay chinese/rime-prelude This also depends on the following ports to form a preset of IME schemas available: chinese/rime-stroke chinese/rime-cangjie chinese/rime-bopomofo chinese/rime-luna-pinyin chinese/rime-terra-pinyin Besides the above essential + preset IME schema ports, chinese/rime-cantonese is also added as a IME schema port for Cantonese users. Submitted by: Ka Ho Ng <khng300@gmail.com> Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27652
Notes
Notes: svn path=/head/; revision=558280
Diffstat (limited to 'chinese/rime-cangjie')
-rw-r--r--chinese/rime-cangjie/Makefile57
-rw-r--r--chinese/rime-cangjie/distinfo3
-rw-r--r--chinese/rime-cangjie/pkg-descr3
-rw-r--r--chinese/rime-cangjie/pkg-plist10
4 files changed, 73 insertions, 0 deletions
diff --git a/chinese/rime-cangjie/Makefile b/chinese/rime-cangjie/Makefile
new file mode 100644
index 000000000000..43c8249ea101
--- /dev/null
+++ b/chinese/rime-cangjie/Makefile
@@ -0,0 +1,57 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-cangjie
+DISTVERSION= g20201030
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Cangjie v5 schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= d0f6f521ec049166ada29085434126be175f6439
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= cangjie5.schema.yaml cangjie5_express.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-cangjie/distinfo b/chinese/rime-cangjie/distinfo
new file mode 100644
index 000000000000..d0c6fa9c84d5
--- /dev/null
+++ b/chinese/rime-cangjie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608103989
+SHA256 (rime-rime-cangjie-g20201030-d0f6f521ec049166ada29085434126be175f6439_GH0.tar.gz) = 50803c76b1865690cf692ce98335c8a1139f0f5fa2e553875b293939f05a02b4
+SIZE (rime-rime-cangjie-g20201030-d0f6f521ec049166ada29085434126be175f6439_GH0.tar.gz) = 392830
diff --git a/chinese/rime-cangjie/pkg-descr b/chinese/rime-cangjie/pkg-descr
new file mode 100644
index 000000000000..06cc2fc80c1d
--- /dev/null
+++ b/chinese/rime-cangjie/pkg-descr
@@ -0,0 +1,3 @@
+Rime Cangjie v5 schema input support.
+
+WWW: https://github.com/rime/rime-cangjie
diff --git a/chinese/rime-cangjie/pkg-plist b/chinese/rime-cangjie/pkg-plist
new file mode 100644
index 000000000000..625e2d73221d
--- /dev/null
+++ b/chinese/rime-cangjie/pkg-plist
@@ -0,0 +1,10 @@
+share/rime-data/build/cangjie5.prism.bin
+share/rime-data/build/cangjie5.reverse.bin
+share/rime-data/build/cangjie5.schema.yaml
+share/rime-data/build/cangjie5.table.bin
+share/rime-data/build/cangjie5.table.txt
+share/rime-data/build/cangjie5_express.prism.bin
+share/rime-data/build/cangjie5_express.schema.yaml
+share/rime-data/cangjie5.dict.yaml
+share/rime-data/cangjie5.schema.yaml
+share/rime-data/cangjie5_express.schema.yaml