aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-12-09 05:46:51 +0000
committerClive Lin <clive@FreeBSD.org>2004-12-09 05:46:51 +0000
commit6f9f428439b320099db0b70b48e9e7703646a91b (patch)
tree496f868d6a6535ff66c4b0e28567681a8caf0a49 /chinese
parentcdc0d3f1b0bea63a083f42e81647835bc0152a4b (diff)
downloadports-6f9f428439b320099db0b70b48e9e7703646a91b.tar.gz
ports-6f9f428439b320099db0b70b48e9e7703646a91b.zip
Add reciteword, an education software to help people to study English.
PR: ports/73687 Submitted by: hamigua <hamigua at cuc.cn>
Notes
Notes: svn path=/head/; revision=123534
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/reciteword/Makefile49
-rw-r--r--chinese/reciteword/distinfo6
-rw-r--r--chinese/reciteword/files/patch-src_Makefile.in16
-rw-r--r--chinese/reciteword/pkg-descr5
-rw-r--r--chinese/reciteword/pkg-install43
-rw-r--r--chinese/reciteword/pkg-plist6
7 files changed, 126 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 42f4632666ae..54d96e9bd562 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -103,6 +103,7 @@
SUBDIR += pyDict
SUBDIR += qe
SUBDIR += qterm
+ SUBDIR += reciteword
SUBDIR += scim-chinese
SUBDIR += scim-tables
SUBDIR += srecite
diff --git a/chinese/reciteword/Makefile b/chinese/reciteword/Makefile
new file mode 100644
index 000000000000..ae393052ff08
--- /dev/null
+++ b/chinese/reciteword/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: reciteword
+# Date created: 1 November 2004
+# Whom: hamigua <hamigua@cuc.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reciteword
+PORTVERSION= 0.8.2
+CATEGORIES= chinese
+MASTER_SITES= http://reciteword.cosoft.org.cn/yaoguang/myapps/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2 \
+ ${PORTNAME}-books-${PORTVERSION}.tar.bz2 \
+ ${PORTNAME}-dicts-${PORTVERSION}.tar.bz2
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.bz2 \
+ ${PORTNAME}-books-${PORTVERSION}.tar.bz2 \
+ ${PORTNAME}-dicts-${PORTVERSION}.tar.bz2
+
+MAINTAINER= hamigua@cuc.cn
+COMMENT= Education software to help people to study English
+
+USE_ICONV= yes
+NO_PACKAGE= bsdtar can not handle utf-8 path name correctly under certain circumstance
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_GCC= 3.4
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_REINPLACE= yes
+
+RECITE_DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
+
+post-install:
+ ((cd ${WRKDIR}; ${TAR} -cf - books) | \
+ ${TAR} --exclude CVS -xf - -C ${RECITE_DATADIR} ; \
+ ${MV} ${RECITE_DATADIR}/books ${RECITE_DATADIR}/books.EUC-CN)
+ (cd ${WRKDIR}; ${TAR} -cf - dicts) | \
+ ${TAR} --exclude CVS -xf - -C ${RECITE_DATADIR}
+ ${SETENV} PKG_PREFIX=${PREFIX} RECITE_DATADIR=${RECITE_DATADIR} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${FIND} ${RECITE_DATADIR} -not -type d | \
+ ${SED} -e 's,^${PREFIX}/,,g' >> ${TMPPLIST}
+ @${FIND} ${RECITE_DATADIR} -type d | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,g' | ${SORT} -r >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/chinese/reciteword/distinfo b/chinese/reciteword/distinfo
new file mode 100644
index 000000000000..fde7b35a5e98
--- /dev/null
+++ b/chinese/reciteword/distinfo
@@ -0,0 +1,6 @@
+MD5 (reciteword-0.8.2.tar.bz2) = 12d1709f520479ec7a59fcdaf702e427
+SIZE (reciteword-0.8.2.tar.bz2) = 7677202
+MD5 (reciteword-dicts-0.8.2.tar.bz2) = f41d9dd162c4360924cfedb5cce3e5af
+SIZE (reciteword-dicts-0.8.2.tar.bz2) = 2430470
+MD5 (reciteword-books-0.8.2.tar.bz2) = e98870cebe8df49ee7c603316c41e073
+SIZE (reciteword-books-0.8.2.tar.bz2) = 5193821
diff --git a/chinese/reciteword/files/patch-src_Makefile.in b/chinese/reciteword/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..9a6ba1489bf7
--- /dev/null
+++ b/chinese/reciteword/files/patch-src_Makefile.in
@@ -0,0 +1,16 @@
+--- src/Makefile.in.orig Mon Nov 1 22:12:49 2004
++++ src/Makefile.in Mon Nov 1 22:15:37 2004
+@@ -118,12 +118,7 @@
+ INCLUDES = \
+ $(RECITEWORD_CFLAGS) \
+ -DRECITEWORD_DATA_DIR=\""$(datadir)/reciteword"\" \
+- -DRECITEWORD_LOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+- -DG_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+- -DGDK_PIXBUF_DISABLE_DEPRECATED \
+- -DGNOME_DISABLE_DEPRECATED
++ -DRECITEWORD_LOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
+
+
+ reciteword_LDFLAGS =
diff --git a/chinese/reciteword/pkg-descr b/chinese/reciteword/pkg-descr
new file mode 100644
index 000000000000..939092c9a984
--- /dev/null
+++ b/chinese/reciteword/pkg-descr
@@ -0,0 +1,5 @@
+Reciteword is a education software to help people to study English,
+reciting english words.It have very beautiful interface,make reciting
+word being a interesting things.
+
+WWW: http://reciteword.cosoft.org.cn/reciteword/index.html
diff --git a/chinese/reciteword/pkg-install b/chinese/reciteword/pkg-install
new file mode 100644
index 000000000000..7d247e0e805c
--- /dev/null
+++ b/chinese/reciteword/pkg-install
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+cvitem()
+{
+ (echo ${PWD_OLD} | ${GREP} -i "$*" 2>&1 > /dev/zero) && exit 0
+ BUF=$(${DIRNAME} "$*")/$(${BASENAME} "$*" | ${ICONV} -f EUC-CN -t utf-8 )
+ [ "$*" != "${BUF}" ] && {
+ ${MV} "$*" "${BUF}"
+ }
+}
+
+cvdir()
+{
+ for SUBITEM in "$*"/* ; do
+ if [ -d "${SUBITEM}" ] ; then
+ cvdir ${SUBITEM}
+ else
+ cvitem ${SUBITEM}
+ fi
+ done
+ cvitem $*
+}
+
+[ "$2" = "PRE-INSTALL" ] && exit 0
+
+PREFIX=${PKG_PREFIX}
+RECITE_DATADIR=${PREFIX}/share/gnome/reciteword
+WORKDIR=${RECITE_DATADIR}/books
+GREP=/usr/bin/grep
+DIRNAME=/usr/bin/dirname
+BASENAME=/usr/bin/basename
+MV=/bin/mv
+CP=/bin/cp
+ICONV=/usr/local/bin/iconv
+${CP} -rf ${WORKDIR}.EUC-CN ${WORKDIR}
+PWD_OLD=`cd ${WORKDIR} && echo ${PWD}`/
+for ITEM in ${WORKDIR} ; do
+ if [ -d ${ITEM} ] ; then
+ cvdir ${ITEM}
+ else
+ cvitem ${ITEM}
+ fi
+done
diff --git a/chinese/reciteword/pkg-plist b/chinese/reciteword/pkg-plist
new file mode 100644
index 000000000000..228ea11df6ea
--- /dev/null
+++ b/chinese/reciteword/pkg-plist
@@ -0,0 +1,6 @@
+bin/reciteword
+share/gnome/applications/reciteword.desktop
+share/gnome/applications/rwdict.desktop
+share/locale/zh_CN/LC_MESSAGES/reciteword.mo
+share/gnome/pixmaps/reciteword.png
+share/gnome/pixmaps/rwdict.png