aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-10-15 08:08:01 +0000
committerClive Lin <clive@FreeBSD.org>2004-10-15 08:08:01 +0000
commit9e507dddc3d578e65e82a6ddf341cd07f880905d (patch)
treeb88e307988a96b7b275f49f1665351f0cf8e0a79 /chinese
parentf35f71ef8c701bf2def36012f4063be844ecec0e (diff)
downloadports-9e507dddc3d578e65e82a6ddf341cd07f880905d.tar.gz
ports-9e507dddc3d578e65e82a6ddf341cd07f880905d.zip
Apply 64 bits cleanup so that it works on fantastic hardware.
PR: ports/72371 Submitted by: davidxu Approved by: MAINTAINER
Notes
Notes: svn path=/head/; revision=119487
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fcitx/Makefile2
-rw-r--r--chinese/fcitx/files/patch-InputWindow.c20
-rw-r--r--chinese/fcitx/files/patch-ui.c38
-rw-r--r--chinese/fcitx/files/patch-xim.c11
4 files changed, 70 insertions, 1 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 416ae681745a..088a09a9057b 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fcitx
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese x11
MASTER_SITES= http://www.fcitx.org/download/
EXTRACT_SUFX= .tar.bz2
diff --git a/chinese/fcitx/files/patch-InputWindow.c b/chinese/fcitx/files/patch-InputWindow.c
new file mode 100644
index 000000000000..04c45adbb13d
--- /dev/null
+++ b/chinese/fcitx/files/patch-InputWindow.c
@@ -0,0 +1,20 @@
+--- InputWindow.c.orig Tue Dec 30 15:54:47 2003
++++ InputWindow.c Thu Oct 14 23:18:49 2004
+@@ -110,7 +110,7 @@
+ char str1[] = "Ay中";
+ char str2[10];
+ char *ps1, *ps2;
+- int l1, l2;
++ size_t l1, l2;
+
+ if (!xftFont)
+ return;
+@@ -120,7 +120,7 @@
+ ps2 = str2;
+ ps1 = str1;
+
+- l1 = iconv (convUTF8, (char **) &ps1, &l1, &ps2, &l2);
++ l1 = iconv (convUTF8, (const char **) &ps1, &l1, &ps2, &l2);
+
+ XftTextExtentsUtf8 (dpy, xftFont, str2, strlen (str2), &extents);
+ iInputWindowHeight = extents.height * 2 + extents.height / 2 + 8;
diff --git a/chinese/fcitx/files/patch-ui.c b/chinese/fcitx/files/patch-ui.c
new file mode 100644
index 000000000000..71f7933490e1
--- /dev/null
+++ b/chinese/fcitx/files/patch-ui.c
@@ -0,0 +1,38 @@
+--- ui.c.orig Sun Jan 4 15:42:01 2004
++++ ui.c Thu Oct 14 23:20:27 2004
+@@ -284,7 +284,7 @@
+ XGlyphInfo extents;
+ char str1[100];
+ char *ps, *ps1;
+- int l1, l2;
++ size_t l1, l2;
+
+ if (!xftFont)
+ return 0;
+@@ -294,7 +294,7 @@
+ ps = str1;
+ ps1 = str;
+
+- l1 = iconv (convUTF8, (char **) &str, &l1, &ps, &l2);
++ l1 = iconv (convUTF8, (const char **) &str, &l1, &ps, &l2);
+ *ps = '\0';
+ XftTextExtentsUtf8 (dpy, xftFont, str1, strlen (str1), &extents);
+ return extents.width;
+@@ -323,7 +323,7 @@
+ void OutputString (Window window, char *str, int x, int y, XColor color)
+ {
+ char strOutput[100] = ""; //该长度应该够用了
+- int l1, l2;
++ size_t l1, l2;
+ char *ps;
+ XftColor xftColor;
+ XRenderColor renderColor;
+@@ -339,7 +339,7 @@
+ l2 = 99;
+ ps = strOutput;
+
+- l1 = iconv (convUTF8, (char **) (&str), &l1, &ps, &l2);
++ l1 = iconv (convUTF8, (const char **) (&str), &l1, &ps, &l2);
+
+ renderColor.red = color.red;
+ renderColor.green = color.green;
diff --git a/chinese/fcitx/files/patch-xim.c b/chinese/fcitx/files/patch-xim.c
new file mode 100644
index 000000000000..a4bc1c4b1a3b
--- /dev/null
+++ b/chinese/fcitx/files/patch-xim.c
@@ -0,0 +1,11 @@
+--- xim.c.orig Tue Jan 6 14:12:11 2004
++++ xim.c Thu Oct 14 23:21:07 2004
+@@ -336,7 +336,7 @@
+ char *ps;
+
+ if (bIsUtf8) {
+- int l1, l2;
++ size_t l1, l2;
+
+ ps = strOutput;
+ l1 = strlen (strHZ);