aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-08-21 09:47:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-08-21 09:47:42 +0000
commitd6df0818361549d68ae4a62cf5c4ee9478aa958b (patch)
tree0866fb85e0703e1a8ab9f29310880a78a6294ad5 /chinese
parent8faa2eac9cf71347cca74d3380befb5a37eb2073 (diff)
downloadports-d6df0818361549d68ae4a62cf5c4ee9478aa958b.tar.gz
ports-d6df0818361549d68ae4a62cf5c4ee9478aa958b.zip
Applied this patch to ensure build smoothly on
some environment/compiler. PR: 41535 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=64747
Diffstat (limited to 'chinese')
-rw-r--r--chinese/xcin25/Makefile4
-rw-r--r--chinese/xcin25/files/patch-chewing::sort_word.c10
2 files changed, 13 insertions, 1 deletions
diff --git a/chinese/xcin25/Makefile b/chinese/xcin25/Makefile
index 1fc442b4549a..7bfe2334364b 100644
--- a/chinese/xcin25/Makefile
+++ b/chinese/xcin25/Makefile
@@ -58,8 +58,10 @@ pre-fetch:
@${ECHO} --
.endif
+post-extract:
+ ${MV} ${WRKDIR}/chewing ${WRKSRC}/src/Cinput
+
post-patch:
- @mv ${WRKDIR}/chewing ${WRKSRC}/src/Cinput
@cd ${WRKSRC}/src/Cinput/chewing; ${SH} ./patch_chewing
post-install:
diff --git a/chinese/xcin25/files/patch-chewing::sort_word.c b/chinese/xcin25/files/patch-chewing::sort_word.c
new file mode 100644
index 000000000000..933d29f960c6
--- /dev/null
+++ b/chinese/xcin25/files/patch-chewing::sort_word.c
@@ -0,0 +1,10 @@
+--- src/Cinput/chewing/sort_word.c.orig Sun Aug 11 12:32:03 2002
++++ src/Cinput/chewing/sort_word.c Sun Aug 11 12:32:20 2002
+@@ -40,6 +40,7 @@
+ Key2Pho(phoneBuf, keyBuf, KB_DEFAULT, 1) ;
+ word_data[nWord].num = PhoneBg2Uint(phoneBuf) ;
+ nWord++ ;
++ return 0;
+ }
+
+ void Output()