aboutsummaryrefslogtreecommitdiff
path: root/comms/acfax
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-08 04:53:25 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-08 04:53:25 +0000
commitd882b3b791bfc7edfb14ea67464bf08393121fd5 (patch)
tree92a2f00dc8b50573fbf869096f4f19d563aaa686 /comms/acfax
parent1f79d984a399caf6081868650fa919cb88d12ee4 (diff)
downloadports-d882b3b791bfc7edfb14ea67464bf08393121fd5.tar.gz
ports-d882b3b791bfc7edfb14ea67464bf08393121fd5.zip
Add acfax 0.981011, recieve faxes using sound card and radio.
PR: 34792 Submitted by: Darren <igla@batterybackups.net>
Notes
Notes: svn path=/head/; revision=60832
Diffstat (limited to 'comms/acfax')
-rw-r--r--comms/acfax/Makefile35
-rw-r--r--comms/acfax/distinfo1
-rw-r--r--comms/acfax/files/patch-RegExp.c12
-rw-r--r--comms/acfax/files/patch-fax_funcs.c13
-rw-r--r--comms/acfax/files/patch-mod_demod.c13
-rw-r--r--comms/acfax/pkg-comment1
-rw-r--r--comms/acfax/pkg-descr2
-rw-r--r--comms/acfax/pkg-plist1
8 files changed, 78 insertions, 0 deletions
diff --git a/comms/acfax/Makefile b/comms/acfax/Makefile
new file mode 100644
index 000000000000..758f5e2e2bd6
--- /dev/null
+++ b/comms/acfax/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: acfax
+# Date created: 20 February 2002
+# Whom: Darren <igla@batterybackups.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acfax
+PORTVERSION= 0.981011
+CATEGORIES= comms
+MASTER_SITES= ftp://ftp.funet.fi/pub/ham/unix/Linux/misc/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
+
+MAINTAINER= igla@batterybackups.net
+
+BUILD_DEPENDS= ${X11BASE}/lib/libXaw3d.a:${PORTSDIR}/x11-toolkits/Xaw3d
+RUN_DEPENDS= ${X11BASE}/lib/libXaw3d.a:${PORTSDIR}/x11-toolkits/Xaw3d
+
+WRKSRC= ${WRKDIR}/acfax
+USE_IMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e 's|setup_fax\(120, 288|setup_fax(120, 576|' \
+ ${WRKSRC}/acfax.c
+ @${PERL} -pi -e 's|ixoc = 288|ixoc = 576|' ${WRKSRC}/fax_funcs.c
+ @${PERL} -pi -e 's|regex.h|gnuregex.h|' ${WRKSRC}/RegExp.h
+ @${PERL} -pi -e 's|-lm|-lm -lgnuregex|' ${WRKSRC}/Imakefile
+
+post-configure:
+ ${TOUCH} ${WRKSRC}/acfax.man
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/acfax ${X11BASE}/bin
+
+.include <bsd.port.mk>
diff --git a/comms/acfax/distinfo b/comms/acfax/distinfo
new file mode 100644
index 000000000000..5bcf6f310a17
--- /dev/null
+++ b/comms/acfax/distinfo
@@ -0,0 +1 @@
+MD5 (acfax-981011.tar.gz) = 60702f222272166fb4a1145820a80e2f
diff --git a/comms/acfax/files/patch-RegExp.c b/comms/acfax/files/patch-RegExp.c
new file mode 100644
index 000000000000..d9669a6dd1ac
--- /dev/null
+++ b/comms/acfax/files/patch-RegExp.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- RegExp.c.old Sun Feb 10 05:33:07 2002
++++ RegExp.c Sun Feb 10 05:33:24 2002
+@@ -23,7 +23,6 @@
+ */
+
+ #include "RegExp.h"
+-#include <regex.h>
+
+ void RegExpCompile(regexp,fsm_ptr)
+ char *regexp;
diff --git a/comms/acfax/files/patch-fax_funcs.c b/comms/acfax/files/patch-fax_funcs.c
new file mode 100644
index 000000000000..c478ed5a938a
--- /dev/null
+++ b/comms/acfax/files/patch-fax_funcs.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- fax_funcs.c.orig Sat Jun 8 00:39:02 2002
++++ fax_funcs.c Sat Jun 8 00:39:08 2002
+@@ -37,6 +37,8 @@
+ #include "widgets.h"
+ #include "fax_funcs.h"
+
++#define PI M_PI
++
+ /* some variables that are allowed to be global */
+ int lpm; /* lines per minute */
+ int ixoc; /* number of pixels of one scan-line / PI */
diff --git a/comms/acfax/files/patch-mod_demod.c b/comms/acfax/files/patch-mod_demod.c
new file mode 100644
index 000000000000..c76cb8152ba8
--- /dev/null
+++ b/comms/acfax/files/patch-mod_demod.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- mod_demod.c.orig Sat Jun 8 00:38:29 2002
++++ mod_demod.c Sat Jun 8 00:38:41 2002
+@@ -29,6 +29,8 @@
+ #include <unistd.h>
+ #include "mod_demod.h"
+
++#define PI M_PI
++
+ SHORT int firwide[] = { 6, 20, 7, -42, -74, -12, 159, 353, 440 };
+ SHORT int firmiddle[] = { 0, -18, -38, -39, 0, 83, 191, 284, 320 };
+ SHORT int firnarrow[] = { -7, -18, -15, 11, 56, 116, 177, 223, 240 };
diff --git a/comms/acfax/pkg-comment b/comms/acfax/pkg-comment
new file mode 100644
index 000000000000..5be3fedd41fc
--- /dev/null
+++ b/comms/acfax/pkg-comment
@@ -0,0 +1 @@
+Recieve faxes using sound card and radio
diff --git a/comms/acfax/pkg-descr b/comms/acfax/pkg-descr
new file mode 100644
index 000000000000..54ca5720ec5f
--- /dev/null
+++ b/comms/acfax/pkg-descr
@@ -0,0 +1,2 @@
+acfax is a program to decode faxes off a radio. It features on-the-fly
+image adjustments and control over a wide array of receiving options.
diff --git a/comms/acfax/pkg-plist b/comms/acfax/pkg-plist
new file mode 100644
index 000000000000..cdb5e4c87ae8
--- /dev/null
+++ b/comms/acfax/pkg-plist
@@ -0,0 +1 @@
+bin/acfax