aboutsummaryrefslogtreecommitdiff
path: root/comms/anyremote
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-14 20:49:21 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-14 20:49:21 +0000
commit546d295d5c423e7025a1902bf1d71ad5160880d6 (patch)
treecf99d7036107921c7778cca50a5b1671b816792d /comms/anyremote
parentd1a23c1e5db786011e4af030dfa70aaa2e123fb9 (diff)
downloadports-546d295d5c423e7025a1902bf1d71ad5160880d6.tar.gz
ports-546d295d5c423e7025a1902bf1d71ad5160880d6.zip
- update to 6.3.2
- remove patches already in the tree PR: 186772 Submitted by: Alex Samorukov <samm@os2.kiev.ua> (maintainer)
Notes
Notes: svn path=/head/; revision=344315
Diffstat (limited to 'comms/anyremote')
-rw-r--r--comms/anyremote/Makefile2
-rw-r--r--comms/anyremote/distinfo4
-rw-r--r--comms/anyremote/files/patch-src_pr_web.c46
-rw-r--r--comms/anyremote/files/patch-src_sys_util.c17
4 files changed, 3 insertions, 66 deletions
diff --git a/comms/anyremote/Makefile b/comms/anyremote/Makefile
index e9ce1890eaa3..e97b16102a1d 100644
--- a/comms/anyremote/Makefile
+++ b/comms/anyremote/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= anyremote
-PORTVERSION= 6.3.1
+PORTVERSION= 6.3.2
CATEGORIES= comms
MASTER_SITES= SF
diff --git a/comms/anyremote/distinfo b/comms/anyremote/distinfo
index 80f11f9c2d55..82681aea1c70 100644
--- a/comms/anyremote/distinfo
+++ b/comms/anyremote/distinfo
@@ -1,2 +1,2 @@
-SHA256 (anyremote-6.3.1.tar.gz) = 0d0a99c12630d462186b4468288a1ba2adef1e70c95bdd35f3165116cb8f4dd6
-SIZE (anyremote-6.3.1.tar.gz) = 2423381
+SHA256 (anyremote-6.3.2.tar.gz) = ab878677e3581ac716ce77bf601a10bfb199a136e605ca02a729428ed6341620
+SIZE (anyremote-6.3.2.tar.gz) = 2424004
diff --git a/comms/anyremote/files/patch-src_pr_web.c b/comms/anyremote/files/patch-src_pr_web.c
deleted file mode 100644
index ea8b02f9f5e7..000000000000
--- a/comms/anyremote/files/patch-src_pr_web.c
+++ /dev/null
@@ -1,46 +0,0 @@
---- src/pr_web.c 2013-07-10 11:07:03.922188287 +0200
-+++ src/pr_web.c 2013-07-10 11:27:16.319193955 +0200
-@@ -33,7 +33,11 @@
- #include <netinet/in.h>
- #include <netdb.h>
- #include <unistd.h>
-+#ifdef __FreeBSD__
-+#include <sys/uio.h>
-+#else
- #include <sys/sendfile.h>
-+#endif
-
- #define SERVER "webserver/1.1"
- #define PROTOCOL "HTTP/1.1"
-@@ -272,7 +276,7 @@
- static void sendFile(_WebClientConnection* cc, char *path, struct stat *statbuf)
- {
- int fd = cc->connDescriptor;
-- int bytes_sent;
-+ ssize_t bytes_sent;
-
- INFO2("[WS]: sendFile %s",path);
-
-@@ -293,8 +297,12 @@
- int length = S_ISREG(statbuf->st_mode) ? statbuf->st_size : -1;
- sendHeaders(cc, 200, "OK", NULL, get_mime_type(path), length, statbuf->st_mtime);
-
-+#ifdef __FreeBSD__
-+ int err = sendfile(fdout, fd, 0, length, NULL, &bytes_sent, 0);
-+#else
- bytes_sent = sendfile(fd,fdout,NULL,length);
--
-+ int err = 0;
-+#endif
- /*while ((n = fread(data, 1, sizeof(data), file)) > 0) {
- //INFO2("read %d bytes from file",n);
-
-@@ -305,7 +313,7 @@
- }
- }*/
-
-- if (length != bytes_sent) {
-+ if (err || length != bytes_sent) {
- ERROR2("[WS]: Error on send file %s", path);
- }
-
diff --git a/comms/anyremote/files/patch-src_sys_util.c b/comms/anyremote/files/patch-src_sys_util.c
deleted file mode 100644
index 01add27d515c..000000000000
--- a/comms/anyremote/files/patch-src_sys_util.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/sys_util.c 2013-07-10 14:49:42.461289772 +0200
-+++ src/sys_util.c 2013-07-10 14:49:02.000000000 +0200
-@@ -24,13 +24,13 @@
- #include <dirent.h>
- #include <errno.h>
- #include <fcntl.h>
--#include <net/if.h>
- #include <netinet/in.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
-+#include <net/if.h>
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <sys/wait.h>