aboutsummaryrefslogtreecommitdiff
path: root/comms/dabstick-radio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-08-23 13:58:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-08-23 13:58:06 +0000
commitddcd01c3911daa113936216d7758daeacebed130 (patch)
treed7e4bb9afa5cf3d4a317c34cb2def15670c6693d /comms/dabstick-radio
parentfd9c06a37617f9fab616e57f80d1e680fdc41d24 (diff)
downloadports-ddcd01c3911daa113936216d7758daeacebed130.tar.gz
ports-ddcd01c3911daa113936216d7758daeacebed130.zip
Consistently spell out ONLY_FOR_ARCHS_REASON due to SSE (and other SIMD
instructions) use. Particularly, saying "SSE extensions" is superfluous, as SSE abbreviation itself means "Streaming SIMD Extensions". Correct way to refer to particular (CPU-agnostic) technology is "SIMD instruction set", which is not limited to MMX, SSE family, AVX, NEON, etc. Since "instruction set" looks a bit too formal in the option description, use more casual and shorter word "instructions".
Notes
Notes: svn path=/head/; revision=395091
Diffstat (limited to 'comms/dabstick-radio')
-rw-r--r--comms/dabstick-radio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index 95d49a809484..ad6d8d223754 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -28,13 +28,13 @@ PORTDOCS= *
PLIST_FILES+= bin/dabreceiver bin/fmreceiver bin/spectrum-viewer
ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= uses MMX and SSE2
+ONLY_FOR_ARCHS_REASON= uses MMX and SSE2 instructions
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if (${OSVERSION} >= 901000) && exists(${DESTDIR}/usr/bin/clang)
+.if (${OSVERSION} >= 900014) && exists(${DESTDIR}/usr/bin/clang)
CC= clang
CXX= clang++
CPP= clang-cpp