aboutsummaryrefslogtreecommitdiff
path: root/comms/dsd
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-30 03:03:07 +0000
committerSteve Wills <swills@FreeBSD.org>2019-05-30 03:03:07 +0000
commitcb00c17d25d673b727d166f12a368e19c3e3f27f (patch)
tree80d6404bf888954599941fa27261ad1b679038ef /comms/dsd
parentc5f606d3c37b470a4aa2d90117e1f44e99dd0c09 (diff)
downloadports-cb00c17d25d673b727d166f12a368e19c3e3f27f.tar.gz
ports-cb00c17d25d673b727d166f12a368e19c3e3f27f.zip
comms/dsd: create port
DSD is able to decode several digital voice formats from discriminator tap audio and synthesize the decoded speech. WWW: https://github.com/szechyjs/dsd PR: 236633 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=503029
Diffstat (limited to 'comms/dsd')
-rw-r--r--comms/dsd/Makefile34
-rw-r--r--comms/dsd/distinfo3
-rw-r--r--comms/dsd/pkg-descr4
3 files changed, 41 insertions, 0 deletions
diff --git a/comms/dsd/Makefile b/comms/dsd/Makefile
new file mode 100644
index 000000000000..ba19c1553361
--- /dev/null
+++ b/comms/dsd/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= dsd
+PORTVERSION= 1.6.0
+CATEGORIES= comms hamradio
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Decode several digital voice formats
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libmbe.so:comms/mbelib
+
+USE_GITHUB= yes
+GH_ACCOUNT= szechyjs
+GH_TAGNAME= v${PORTVERSION}
+
+USE_LDCONFIG= yes
+PLIST_FILES= "@(,uucp,4555) bin/dsd"
+MAKE_ARGS= DEST_BASE=${STAGEDIR}${PREFIX}
+
+post-patch:
+ ${REINPLACE_CMD} 's|${PREFIX}|${LOCALBASE}|g;\
+ s|install|${INSTALL_PROGRAM}|g;\
+ s|gcc|${CC}|g'\
+ ${WRKSRC}/Makefile
+.for i in dsd.h dsd_file.c dsd_mbe.c
+ ${REINPLACE_CMD} 's|2250|2450|' ${WRKSRC}/${i}
+.endfor
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/comms/dsd/distinfo b/comms/dsd/distinfo
new file mode 100644
index 000000000000..7d85b7750b82
--- /dev/null
+++ b/comms/dsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486712916
+SHA256 (szechyjs-dsd-1.6.0-v1.6.0_GH0.tar.gz) = 44fa3ae108d2c11b4b67388d37fc6a63e8b44fc72fdd5db7b57d9eb045a9df58
+SIZE (szechyjs-dsd-1.6.0-v1.6.0_GH0.tar.gz) = 40959
diff --git a/comms/dsd/pkg-descr b/comms/dsd/pkg-descr
new file mode 100644
index 000000000000..029dfe79240f
--- /dev/null
+++ b/comms/dsd/pkg-descr
@@ -0,0 +1,4 @@
+DSD is able to decode several digital voice formats from discriminator
+tap audio and synthesize the decoded speech.
+
+WWW: https://github.com/szechyjs/dsd