aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-03-11 11:20:12 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-03-11 11:20:12 +0000
commit8a49a24a2c495105859e337e9a76269360f02c89 (patch)
tree66d572f76806ab91bcbfdf5829fec6326086a101 /comms/gammu
parent657736865445093c6d023fdca4fd0844903520c5 (diff)
downloadports-8a49a24a2c495105859e337e9a76269360f02c89.tar.gz
ports-8a49a24a2c495105859e337e9a76269360f02c89.zip
. mark BROKEN at 6.x -- does not compile; [1]
. reintroduce NOPORTDOCS with upstream patches; [2] . no changes to default packages -- do not bump PORTREVISION. Pointed out by: pointyhat [1] QAT [2]
Notes
Notes: svn path=/head/; revision=229872
Diffstat (limited to 'comms/gammu')
-rw-r--r--comms/gammu/Makefile12
-rw-r--r--comms/gammu/files/patch-CMakeLists.txt37
2 files changed, 44 insertions, 5 deletions
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 66c00a143ea2..758d59a9ab99 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -28,12 +28,18 @@ PLIST_SUB= WITH_PYTHON_GAMMU=""
PLIST_SUB= WITH_PYTHON_GAMMU="@comment "
.endif
+PORTDOCS= *
+
+.if defined(NOPORTDOCS)
+CMAKE_ARGS+= -DINSTALL_DOC=OFF -DINSTALL_PHP_EXAMPLES=OFF -DINSTALL_MEDIA=OFF \
+ -DINSTALL_GNAPPLET=OFF
+.else
MAN1= gammu.1 gammu-config.1 jadmaker.1 gammu-smsd.1 gammu-smsd-inject.1 \
gammu-smsd-monitor.1
MAN5= gammu-smsdrc.5 gammurc.5
MAN7= gammu-smsd-files.7 gammu-smsd-mysql.7 gammu-smsd-pgsql.7 \
gammu-smsd-dbi.7 gammu-smsd-tables.7
-PORTDOCS= *
+.endif
.include <bsd.port.pre.mk>
@@ -43,4 +49,8 @@ post-patch:
@${REINPLACE_CMD} -e 's@ -Wno-pointer-sign@@g' ${WRKSRC}/CMakeLists.txt
.endif
+.if ${OSVERSION} < 700000
+BROKEN= does not build at 6.x
+.endif
+
.include <bsd.port.post.mk>
diff --git a/comms/gammu/files/patch-CMakeLists.txt b/comms/gammu/files/patch-CMakeLists.txt
index ff650b5530a6..0291659a6532 100644
--- a/comms/gammu/files/patch-CMakeLists.txt
+++ b/comms/gammu/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2007-08-08 16:30:55.000000000 +0400
-+++ CMakeLists.txt 2007-08-21 00:18:05.000000000 +0400
-@@ -601,7 +604,7 @@
+--- CMakeLists.txt.orig 2009-02-25 19:46:07.000000000 +0300
++++ CMakeLists.txt 2009-03-11 13:04:48.000000000 +0300
+@@ -547,7 +547,7 @@
set (INSTALL_DOC_DIR "share/doc/gammu" CACHE STRING "Path for documentation installation")
mark_as_advanced (INSTALL_DOC_DIR)
@@ -8,4 +8,33 @@
+set (INSTALL_MAN_DIR "man" CACHE STRING "Path for man pages installation")
mark_as_advanced (INSTALL_MAN_DIR)
- # Generate pkgconfig file
+ # Phone and protocol configuration
+@@ -698,11 +698,13 @@
+ COMPONENT "pkgconfig"
+ )
+
++if(INSTALL_DOC)
+ install (
+ FILES ${DOCS}
+ DESTINATION "${INSTALL_DOC_DIR}"
+ COMPONENT "docs"
+ )
++endif(INSTALL_DOC)
+
+ # We want some tests. Even when cross compiling for Windows tests can be
+ # done in Wine. This is better than nothing, even though Wine is a bit
+@@ -860,10 +860,14 @@
+
+ add_subdirectory(utils)
+
++option(INSTALL_DOC "Install documentation" ON)
++
++if(INSTALL_DOC)
+ add_subdirectory(docs/config)
+ add_subdirectory(docs/develop)
+ add_subdirectory(docs/sql)
+ add_subdirectory(docs/user)
++endif(WITH_DOC)
+
+ add_subdirectory(contrib)
+