aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2016-11-13 03:13:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2016-11-13 03:13:18 +0000
commitfbeeb99886d271e93b0639b5e05310150789608b (patch)
treeb15e58ef2bc69a6e0a0657a9c030e6cf4fafa436 /comms/gammu
parentf8db46edcca8b8e121d093c0de8f035414d970be (diff)
downloadports-fbeeb99886d271e93b0639b5e05310150789608b.tar.gz
ports-fbeeb99886d271e93b0639b5e05310150789608b.zip
Update to 1.37.91.
Notes
Notes: svn path=/head/; revision=426004
Diffstat (limited to 'comms/gammu')
-rw-r--r--comms/gammu/Makefile2
-rw-r--r--comms/gammu/distinfo6
-rw-r--r--comms/gammu/files/patch-libgammu__device__bluetooth__blue_bsd.c11
-rw-r--r--comms/gammu/files/patch-libgammu_device_bluetoth_bluez.c66
-rw-r--r--comms/gammu/files/patch-libgammu_device_devfunc.c11
-rw-r--r--comms/gammu/pkg-plist8
6 files changed, 19 insertions, 85 deletions
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index d973a1f047fb..1a273bfa794d 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gammu
-PORTVERSION= 1.37.3
+PORTVERSION= 1.37.91
CATEGORIES= comms
MASTER_SITES= http://dl.cihar.com/gammu/releases/
diff --git a/comms/gammu/distinfo b/comms/gammu/distinfo
index 0ca50c4a6ab4..18b7957b3e49 100644
--- a/comms/gammu/distinfo
+++ b/comms/gammu/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464169663
-SHA256 (gammu-1.37.3.tar.xz) = 63fcb78e94e1c8cff199cada3f64c694f49c1e9fe2c3f17495dc01a5e8e03a84
-SIZE (gammu-1.37.3.tar.xz) = 1665088
+TIMESTAMP = 1478878437
+SHA256 (gammu-1.37.91.tar.xz) = fb353ed465b1ae408485e55c97f3a9e910af2c271b03a5bf3aab61bb4225fe00
+SIZE (gammu-1.37.91.tar.xz) = 1675144
diff --git a/comms/gammu/files/patch-libgammu__device__bluetooth__blue_bsd.c b/comms/gammu/files/patch-libgammu__device__bluetooth__blue_bsd.c
new file mode 100644
index 000000000000..0b1efaa9b723
--- /dev/null
+++ b/comms/gammu/files/patch-libgammu__device__bluetooth__blue_bsd.c
@@ -0,0 +1,11 @@
+--- libgammu/device/bluetooth/blue_bsd.c.orig 2016-11-12 10:13:02.619065000 +0800
++++ libgammu/device/bluetooth/blue_bsd.c 2016-11-12 10:13:27.768173000 +0800
+@@ -10,6 +10,8 @@
+ #ifdef GSM_ENABLE_BLUETOOTHDEVICE
+ #ifdef BSD_BLUE_FOUND
+
++#define L2CAP_SOCKET_CHECKED 1
++
+ #include <sys/socket.h>
+ #include <sys/time.h>
+
diff --git a/comms/gammu/files/patch-libgammu_device_bluetoth_bluez.c b/comms/gammu/files/patch-libgammu_device_bluetoth_bluez.c
deleted file mode 100644
index ae17d6cd568b..000000000000
--- a/comms/gammu/files/patch-libgammu_device_bluetoth_bluez.c
+++ /dev/null
@@ -1,66 +0,0 @@
---- libgammu/device/bluetoth/bluez.c.orig 2015-12-08 10:38:12 UTC
-+++ libgammu/device/bluetoth/bluez.c
-@@ -23,6 +23,8 @@
- #ifdef GSM_ENABLE_BLUETOOTHDEVICE
- #ifdef BLUEZ_FOUND
-
-+#define BDADDR_ANY NG_HCI_BDADDR_ANY
-+
- #include <stdlib.h>
- #include <stdio.h>
- #include <fcntl.h>
-@@ -31,11 +33,7 @@
- #include <sys/socket.h>
- #include <sys/time.h>
- #include <unistd.h>
--#include <bluetooth/bluetooth.h>
--#include <bluetooth/rfcomm.h>
--#include <bluetooth/sdp.h>
--#include <bluetooth/sdp_lib.h>
--#include <bluetooth/hci_lib.h>
-+#include <bluetooth.h>
-
- #include "../../gsmcomon.h"
- #include "../devfunc.h"
-@@ -48,7 +46,7 @@ GSM_Error bluetooth_connect(GSM_StateMac
- /* Some phones need time till they are accessible after SDP browsing */
- for (tries = 0; tries < 5; tries++) {
- GSM_Device_BlueToothData *d = &s->Device.Data.BlueTooth;
-- struct sockaddr_rc laddr, raddr;
-+ struct sockaddr_rfcomm laddr, raddr;
- bdaddr_t bdaddr;
- int fd;
-
-@@ -61,15 +59,15 @@ GSM_Error bluetooth_connect(GSM_StateMac
-
- smprintf(s, "Connecting to RF channel %i\n", port);
-
-- fd = socket(PF_BLUETOOTH, SOCK_STREAM, BTPROTO_RFCOMM);
-+ fd = socket(PF_BLUETOOTH, SOCK_STREAM, BLUETOOTH_PROTO_RFCOMM);
- if (fd < 0) {
- smprintf(s, "Can't create socket\n");
- continue;
- }
-
-- bacpy(&laddr.rc_bdaddr, BDADDR_ANY);
-- laddr.rc_family = AF_BLUETOOTH;
-- laddr.rc_channel = 0;
-+ bacpy(&laddr.rfcomm_bdaddr, BDADDR_ANY);
-+ laddr.rfcomm_family = AF_BLUETOOTH;
-+ laddr.rfcomm_channel = 0;
-
- if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
- smprintf(s, "Can't bind socket (%d, %s)\n", errno, strerror(errno));
-@@ -78,9 +76,9 @@ GSM_Error bluetooth_connect(GSM_StateMac
- }
-
- str2ba(device, &bdaddr);
-- bacpy(&raddr.rc_bdaddr, &bdaddr);
-- raddr.rc_family = AF_BLUETOOTH;
-- raddr.rc_channel = port;
-+ bacpy(&raddr.rfcomm_bdaddr, &bdaddr);
-+ raddr.rfcomm_family = AF_BLUETOOTH;
-+ raddr.rfcomm_channel = port;
-
- if (connect(fd, (struct sockaddr *)&raddr, sizeof(raddr)) < 0) {
- smprintf(s, "Can't connect (%d, %s)\n", errno, strerror(errno));
diff --git a/comms/gammu/files/patch-libgammu_device_devfunc.c b/comms/gammu/files/patch-libgammu_device_devfunc.c
deleted file mode 100644
index 8d99010a7049..000000000000
--- a/comms/gammu/files/patch-libgammu_device_devfunc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgammu/device/devfunc.c.orig 2015-12-08 10:38:12 UTC
-+++ libgammu/device/devfunc.c
-@@ -15,6 +15,8 @@
- #include <string.h>
- #include <fcntl.h>
- #include <stdlib.h>
-+#include <sys/stat.h>
-+#include <sys/socket.h>
- #ifdef WIN32
- # include <winsock2.h>
- # include <io.h>
diff --git a/comms/gammu/pkg-plist b/comms/gammu/pkg-plist
index 44d5814f5389..a738aab7d1c1 100644
--- a/comms/gammu/pkg-plist
+++ b/comms/gammu/pkg-plist
@@ -35,11 +35,11 @@ include/gammu/gammu-types.h
include/gammu/gammu-unicode.h
include/gammu/gammu-wap.h
lib/libGammu.so
-lib/libGammu.so.7
-lib/libGammu.so.7.%%VERSION%%
+lib/libGammu.so.8
+lib/libGammu.so.8.%%VERSION%%
lib/libgsmsd.so
-lib/libgsmsd.so.7
-lib/libgsmsd.so.7.%%VERSION%%
+lib/libgsmsd.so.8
+lib/libgsmsd.so.8.%%VERSION%%
libdata/pkgconfig/gammu.pc
libdata/pkgconfig/gammu-smsd.pc
man/man1/gammu.1.gz