aboutsummaryrefslogtreecommitdiff
path: root/comms/hamlib
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-02-27 03:13:28 +0000
committerDiane Bruce <db@FreeBSD.org>2019-02-27 03:13:28 +0000
commit9a8230e5d464daa50e22a902cbccceb3d3198da6 (patch)
tree253ef036785097466f1aee9afe479df9a2889d5a /comms/hamlib
parent0a48939332d2473f610a91954017621bc846ba75 (diff)
downloadports-9a8230e5d464daa50e22a902cbccceb3d3198da6.tar.gz
ports-9a8230e5d464daa50e22a902cbccceb3d3198da6.zip
Update to hamlib 3.3
* New models, R&S xk2100, TRXMAnager, Meade LX200 * HTML manual is now generated at 'make dist' so users don't need GNU Info tools installed. TNX Greg, N1DAM for the suggestion.
Notes
Notes: svn path=/head/; revision=494011
Diffstat (limited to 'comms/hamlib')
-rw-r--r--comms/hamlib/Makefile15
-rw-r--r--comms/hamlib/distinfo6
-rw-r--r--comms/hamlib/files/patch-bindings_Makefile.am11
-rw-r--r--comms/hamlib/files/patch-dummy_netrigctl.c177
-rw-r--r--comms/hamlib/files/patch-src_network.c29
-rw-r--r--comms/hamlib/pkg-plist15
6 files changed, 21 insertions, 232 deletions
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 23457ff18bab..d42b11c1c588 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hamlib
-PORTVERSION= 3.1
-PORTREVISION= 2
+PORTVERSION= 3.3
CATEGORIES= comms hamradio
MASTER_SITES= SF
@@ -15,32 +14,32 @@ LICENSE= LGPL20
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libltdl.so:devel/libltdl
-INFO= hamlib
-USES= autoreconf libtool:keepla pathfix perl5 pathfix pkgconfig python shebangfix tcl
+USES= autoreconf libtool:keepla pathfix perl5 pathfix pkgconfig python readline shebangfix tcl
USE_PYTHON= py3kplist
-SHEBANG_FILES= bindings/perltest.pl
USE_PERL5= build run
USE_GNOME= libxml2
USE_LDCONFIG= yes
+
# $TCL_INCLUDE_SPEC
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+SHEBANG_FILES= bindings/perltest.pl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-perl-binding \
--with-tcl-binding --with-tcl=${TCL_LIBDIR} \
+ --with-libusb \
--with-python-binding --without-rigmatrix
+CONFIGURE_ENV= LIBUSB_LIBS="-lusb"
PLIST_SUB= VER=${PORTVERSION} TCL_VER=${TCL_VER}
INSTALL_TARGET= install-strip
BINARY_ALIAS= swig=swig3.0
+INFO= hamlib
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
- -e 's|%%TCL_LIBDIR%%|${TCL_LIBDIR}|g' \
${WRKSRC}/bindings/Makefile.am
- @${REINPLACE_CMD} -e 's|%%TCLSH%%|${TCLSH}|g' \
- ${WRKSRC}/bindings/tcltest.tcl
post-build:
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' \
${STAGEDIR}${WRKSRC}/bindings/Hamlib-pl.mk
diff --git a/comms/hamlib/distinfo b/comms/hamlib/distinfo
index a5ee7aa444a0..e2a13649d1d6 100644
--- a/comms/hamlib/distinfo
+++ b/comms/hamlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490445019
-SHA256 (hamlib-3.1.tar.gz) = 682304c3e88ff6ccfd6a5fc28b33bcc95d2d0a54321973fef015ff62570c994e
-SIZE (hamlib-3.1.tar.gz) = 2130615
+TIMESTAMP = 1551232323
+SHA256 (hamlib-3.3.tar.gz) = c90b53949c767f049733b442cd6e0a48648b55d99d4df5ef3f852d985f45e880
+SIZE (hamlib-3.3.tar.gz) = 2192119
diff --git a/comms/hamlib/files/patch-bindings_Makefile.am b/comms/hamlib/files/patch-bindings_Makefile.am
deleted file mode 100644
index 8cd6ebd79d1f..000000000000
--- a/comms/hamlib/files/patch-bindings_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- bindings/Makefile.am.orig 2017-03-25 12:45:27 UTC
-+++ bindings/Makefile.am
-@@ -120,7 +120,7 @@ MOSTLYCLEANFILES+= hamlibtcl_wrap.c pkgI
-
- tcl_ltlib = hamlibtcl.la
-
--tcldir = $(libdir)/tcl/Hamlib
-+tcldir = /usr/local/lib/tcl8.6/Hamlib
-
- PKG_VER=@ABI_VERSION@.@ABI_REVISION@
- DLL=hamlibtcl-$(PKG_VER)@TCL_SHLIB_SUFFIX@
diff --git a/comms/hamlib/files/patch-dummy_netrigctl.c b/comms/hamlib/files/patch-dummy_netrigctl.c
deleted file mode 100644
index a75f3b4ee373..000000000000
--- a/comms/hamlib/files/patch-dummy_netrigctl.c
+++ /dev/null
@@ -1,177 +0,0 @@
---- dummy/netrigctl.c.orig 2017-04-16 02:56:42 UTC
-+++ dummy/netrigctl.c
-@@ -54,7 +54,7 @@ static int netrigctl_transaction(RIG *ri
- if (ret != RIG_OK)
- return ret;
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret < 0)
- return ret;
-
-@@ -87,18 +87,18 @@ static int netrigctl_open(RIG *rig)
- if (prot_ver < RIGCTLD_PROT_VER)
- return -RIG_EPROTO;
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->itu_region = atoi(buf);
-
- for (i=0; i<FRQRANGESIZ; i++) {
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -117,7 +117,7 @@ static int netrigctl_open(RIG *rig)
- break;
- }
- for (i=0; i<FRQRANGESIZ; i++) {
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -136,7 +136,7 @@ static int netrigctl_open(RIG *rig)
- break;
- }
- for (i=0; i<TSLSTSIZ; i++) {
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -150,7 +150,7 @@ static int netrigctl_open(RIG *rig)
- }
-
- for (i=0; i<FLTLSTSIZ; i++) {
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -168,31 +168,31 @@ static int netrigctl_open(RIG *rig)
- chan_t chan_list[CHANLSTSIZ]; /*!< Channel list, zero ended */
- #endif
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->max_rit = atol(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->max_xit = atol(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->max_ifshift = atol(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->announces = atoi(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -205,7 +205,7 @@ chan_t chan_list[CHANLSTSIZ]; /*!< Chann
- ret = 0;
- rs->preamp[ret] = RIG_DBLST_END;
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -218,37 +218,37 @@ chan_t chan_list[CHANLSTSIZ]; /*!< Chann
- ret = 0;
- rs->attenuator[ret] = RIG_DBLST_END;
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->has_get_func = strtol(buf, NULL, 0);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->has_set_func = strtol(buf, NULL, 0);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->has_get_level = strtol(buf, NULL, 0);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->has_set_level = strtol(buf, NULL, 0);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
- rs->has_get_parm = strtol(buf, NULL, 0);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -354,7 +354,7 @@ static int netrigctl_get_mode(RIG *rig,
- if (ret > 0 && buf[ret-1]=='\n') buf[ret-1] = '\0'; /* chomp */
- *mode = rig_parse_mode(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -761,7 +761,7 @@ static int netrigctl_get_split_mode(RIG
- if (ret > 0 && buf[ret-1]=='\n') buf[ret-1] = '\0'; /* chomp */
- *tx_mode = rig_parse_mode(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
-@@ -804,7 +804,7 @@ static int netrigctl_get_split_vfo(RIG *
-
- *split = atoi(buf);
-
-- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n"));
-+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1);
- if (ret <= 0)
- return (ret < 0) ? ret : -RIG_EPROTO;
-
diff --git a/comms/hamlib/files/patch-src_network.c b/comms/hamlib/files/patch-src_network.c
deleted file mode 100644
index dc6b46a502b7..000000000000
--- a/comms/hamlib/files/patch-src_network.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/network.c.orig 2016-12-31 20:01:25 UTC
-+++ src/network.c
-@@ -48,6 +48,7 @@
-
- #ifdef HAVE_NETINET_IN_H
- #include <netinet/in.h>
-+#include <netinet/tcp.h>
- #endif
- #if HAVE_NETDB_H
- #include <netdb.h>
-@@ -117,6 +118,7 @@ int network_open(hamlib_port_t *rp, int
- {
- int fd; /* File descriptor for the port */
- int status;
-+ int flag;
- struct addrinfo hints, *res, *saved_res;
- char *hoststr = NULL, *portstr = NULL, *bracketstr1, *bracketstr2;
- char hostname[FILPATHLEN];
-@@ -202,6 +204,10 @@ int network_open(hamlib_port_t *rp, int
- return -RIG_EIO;
- }
-
-+ /* Disable Nagle */
-+ flag = 1;
-+ setsockopt(fd, IPPROTO_TCP, TCP_NODELAY, &flag, sizeof(flag));
-+
- if ((status = connect(fd, res->ai_addr, res->ai_addrlen)) == 0)
- {
- break;
diff --git a/comms/hamlib/pkg-plist b/comms/hamlib/pkg-plist
index dee4bb96d8ad..0ca73ac493fe 100644
--- a/comms/hamlib/pkg-plist
+++ b/comms/hamlib/pkg-plist
@@ -16,8 +16,8 @@ lib/libhamlib++.a
lib/libhamlib++.la
lib/libhamlib++.so
lib/libhamlib++.so.2
-lib/libhamlib++.so.2.1.1
-lib/libhamlib.so.2.1.1
+lib/libhamlib++.so.2.1.3
+lib/libhamlib.so.2.1.3
lib/libhamlib.a
lib/libhamlib.la
lib/libhamlib.so
@@ -48,10 +48,14 @@ share/aclocal/hamlib.m4
%%PORTDOCS%%%%DOCSDIR%%/PLAN
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.betatester
+%%PORTDOCS%%%%DOCSDIR%%/README.developer
%%PORTDOCS%%%%DOCSDIR%%/README.win32
%%PORTDOCS%%%%DOCSDIR%%/THANKS
-%%PORTDOCS%%%%DOCSDIR%%/Hamlib_design.png
-%%PORTDOCS%%%%DOCSDIR%%/hamlib.html
+%%PORTDOCS%%%%DOCSDIR%%/examples/pytest.py
+%%PORTDOCS%%%%DOCSDIR%%/examples/perltest.pl
+%%PORTDOCS%%%%DOCSDIR%%/examples/tcltest.tcl
+%%PORTDOCS%%%%DOCSDIR%%/html/Hamlib_design.png
+%%PORTDOCS%%%%DOCSDIR%%/html/hamlib.html
man/man1/rigctl.1.gz
man/man1/rigctld.1.gz
man/man1/rigmem.1.gz
@@ -59,3 +63,6 @@ man/man1/rigsmtr.1.gz
man/man1/rigswr.1.gz
man/man1/rotctl.1.gz
man/man1/rotctld.1.gz
+man/man7/hamlib-primer.7.gz
+man/man7/hamlib-utilities.7.gz
+man/man7/hamlib.7.gz