aboutsummaryrefslogtreecommitdiff
path: root/comms/hso-kmod/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:10:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:10:20 +0000
commitc92c5e1dd4d29142f48a62ee2793992a4be78907 (patch)
treef0ebdce813f539fb901f243350e87784ea20090f /comms/hso-kmod/files
parent98151737ee8a8858a64c1b16084a45846982fdf4 (diff)
downloadports-c92c5e1dd4d29142f48a62ee2793992a4be78907.tar.gz
ports-c92c5e1dd4d29142f48a62ee2793992a4be78907.zip
- Update to 20081023
Note: - now builds against the new MPSAFE TTY layer (and still builds against the old one) - new product IDs added (0x7011 and 0x7501) - hsoctl now forks into background after a successful connection (use -d to disconnect, -n to get the old behavior) PR: 128422 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer)
Notes
Notes: svn path=/head/; revision=222295
Diffstat (limited to 'comms/hso-kmod/files')
-rw-r--r--comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile9
-rw-r--r--comms/hso-kmod/files/option-icon.conf.sample2
-rw-r--r--comms/hso-kmod/files/patch-if_hso.c20
3 files changed, 6 insertions, 25 deletions
diff --git a/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile b/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile
index c1a8b8fab908..c87686f43e44 100644
--- a/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile
+++ b/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile
@@ -1,9 +1,10 @@
---- Makefile.orig 2008-05-14 14:18:53.751411172 +0200
-+++ Makefile 2008-05-14 14:19:01.497294028 +0200
-@@ -1,5 +1,5 @@
+--- Makefile.orig 2008-10-23 15:45:28.158855941 +0200
++++ Makefile 2008-10-23 15:45:53.171672654 +0200
+@@ -1,6 +1,6 @@
SRCS= hsoctl.c
PROG= hsoctl
-CFLAGS+= -g
+#CFLAGS+= -g
+ LDFLAGS+= -lutil
+ DESTDIR?= /usr/local
- .include <bsd.prog.mk>
diff --git a/comms/hso-kmod/files/option-icon.conf.sample b/comms/hso-kmod/files/option-icon.conf.sample
index a133356969bf..d32ba783b7ac 100644
--- a/comms/hso-kmod/files/option-icon.conf.sample
+++ b/comms/hso-kmod/files/option-icon.conf.sample
@@ -1,7 +1,7 @@
attach 100 {
match "device-name" "umass[0-9]+";
match "vendor" "0x0af0";
-match "product" "0x6911|0x6971|0x7251|0x7401";
+match "product" "0x6911|0x6971|0x7251|0x7401|0x7011|0x7501";
match "devclass" "0x00";
action "sleep 1; /sbin/camcontrol cmd `/sbin/camcontrol devlist | /usr/bin/grep ZCOPTION | /usr/bin/awk '{match($11, /pass[0-9]+/); print substr($11, RSTART, RLENGTH) }'` -c '01 00 00 00 00 00' -i 1 i1 > /dev/null";
};
diff --git a/comms/hso-kmod/files/patch-if_hso.c b/comms/hso-kmod/files/patch-if_hso.c
deleted file mode 100644
index 253d3085c40d..000000000000
--- a/comms/hso-kmod/files/patch-if_hso.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- if_hso.c.orig 2008-05-18 15:16:15.402471749 +0200
-+++ if_hso.c 2008-05-18 15:16:54.689656014 +0200
-@@ -831,7 +831,7 @@
-
- ht = tp->t_sc;
- if (cnt > ht->ht_obufsz) {
-- DPRINTF(1, "too many bytes %d, reducing to %d\n",
-+ DPRINTF(1, "too many bytes %d, reducing to %zd\n",
- cnt, ht->ht_obufsz);
- cnt = ht->ht_obufsz;
- }
-@@ -1005,7 +1005,7 @@
- len = m->m_pkthdr.len - ETHER_HDR_LEN;
- m_copydata(m, ETHER_HDR_LEN, len, ib->ib_buf);
-
-- DPRINTF(5, "hso_if_start: mlen=%d, len=%d\n",
-+ DPRINTF(5, "hso_if_start: mlen=%d, len=%zd\n",
- m->m_pkthdr.len, len);
-
- m_freem(m);