aboutsummaryrefslogtreecommitdiff
path: root/comms/lirc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-02 16:45:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-02 16:45:55 +0000
commit9269f83f66159f7bd11583b70fa1e54129534d4f (patch)
treef7b37a892b879ac97e8a060ae78a1bc1d9a15996 /comms/lirc
parent7339c67db826deca5e0bd1c1f50328b9ac7df8a2 (diff)
downloadports-9269f83f66159f7bd11583b70fa1e54129534d4f.tar.gz
ports-9269f83f66159f7bd11583b70fa1e54129534d4f.zip
- Switch to USES=localbase
- Pet portlint - Switch to options helpers - Fix plist for MINIMAL case - Properly optionize svgalib dependency handling
Notes
Notes: svn path=/head/; revision=460716
Diffstat (limited to 'comms/lirc')
-rw-r--r--comms/lirc/Makefile52
1 files changed, 27 insertions, 25 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 163b67d1fc00..9d9df02f4b11 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.9.0
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/LIRC/${PORTVERSION}
@@ -13,43 +13,40 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= v4l_compat>=1.0.20110603:multimedia/v4l_compat
-INSTALL_TARGET= install-strip
-USES= alias autoreconf gmake libtool python tar:bzip2
-USE_XORG= sm x11
+USES= alias autoreconf gmake libtool localbase python tar:bzip2
+USE_XORG= sm x11 ice
USE_CSTD= gnu89
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
--sysconfdir=${PREFIX}/etc
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
-OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
-
-MINIMAL_DESC= Build with minmal dependencies
-UARTLIRC_DESC= Install serial LIRC driver
USE_RC_SUBR= lircd
PORTDOCS= html images irxevent.keys lirc.css lirc.hwdb
PORTEXAMPLES= remotes
SUB_FILES= pkg-message lircd.conf
-.if exists(${LOCALBASE}/lib/libvga.so.1)
-LIB_DEPENDS+= libvga.so:graphics/svgalib
-PLIST_SUB+= SMODE2=
-.else
-PLIST_SUB+= SMODE2="@comment "
-.endif
+OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
+OPTIONS_DEFINE_i386= SMODE2 # requires svgalib which is...
+OPTIONS_DEFINE_amd64= SMODE2 # ...only available on x86
+OPTIONS_SUB= yes
+
+MINIMAL_DESC= Build with minimal dependencies
+UARTLIRC_DESC= Install serial LIRC driver
+SMODE2_DESC= Build smode2 (shows signal waveform), requires svgalib
-MINIMAL_LIB_DEPENDS_OFF= libftdi.so:devel/libftdi \
+MINIMAL_LIB_DEPENDS_OFF=libftdi.so:devel/libftdi \
libirman.so:comms/libirman
MINIMAL_CONFIGURE_OFF= --with-driver=userspace
MINIMAL_CONFIGURE_ON= --with-driver=dvico
DEBUG_CONFIGURE_ENABLE= debug
-UARTLIRC_RUN_DEPENDS= uartlirc>=0.3:comms/uartlirc
+SMODE2_LIB_DEPENDS= libvga.so:graphics/svgalib
+
+UARTLIRC_RUN_DEPENDS= uartlirc>=0.3:comms/uartlirc
post-patch:
@${REINPLACE_CMD} \
@@ -57,14 +54,19 @@ post-patch:
-e 's/`$${LIBUSB_CONFIG} --cflags`//' \
${WRKSRC}/configure.ac
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/lircd.conf ${STAGEDIR}${PREFIX}/etc/lircd.conf.sample
+ @${MKDIR} ${STAGEDIR}/var/run/lirc
+
+post-install-MINIMAL-on:
+ # bacause --with-driver is specified, it installs remotes/dvico/lircd.conf.fusionHDTV to etc/lircd/
+ # remove to not break the plist, but remote configs handling should probably be fixed...
+ @${RM} -r ${STAGEDIR}${PREFIX}/etc/lirc
+
post-install-DOCS-on:
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}/)
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} images ${STAGEDIR}${DOCSDIR}/)
- @(cd ${WRKSRC}/doc && ${INSTALL_DATA} irxevent.keys lirc.css lirc.hwdb ${STAGEDIR}${DOCSDIR}/)
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "html images irxevent.keys lirc.css lirc.hwdb" ${STAGEDIR}${DOCSDIR}/)
+
post-install-EXAMPLES-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} remotes ${STAGEDIR}${EXAMPLESDIR}/)
-post-install:
- @${INSTALL_DATA} ${WRKDIR}/lircd.conf ${STAGEDIR}${PREFIX}/etc/lircd.conf.sample
- @${MKDIR} ${STAGEDIR}/var/run/lirc
.include <bsd.port.mk>