aboutsummaryrefslogtreecommitdiff
path: root/comms/qpage
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2008-10-18 18:45:19 +0000
committerStefan Walter <stefan@FreeBSD.org>2008-10-18 18:45:19 +0000
commit45abddec34c7bbc536844edbb9ee33961c382be0 (patch)
tree0e2cd93c6d8a054a18a30d9b6cd533b293bb0462 /comms/qpage
parent08f403812c10d9461ddbcc04d5d099ae546f9151 (diff)
downloadports-45abddec34c7bbc536844edbb9ee33961c382be0.tar.gz
ports-45abddec34c7bbc536844edbb9ee33961c382be0.zip
- Fix segmentation faults on SIGHUP.
- Assign maintainership to submitter. PR: 127075, 127827 Submitted by: Jeffrey Blank <jfb@mr-happy.com>
Notes
Notes: svn path=/head/; revision=221742
Diffstat (limited to 'comms/qpage')
-rw-r--r--comms/qpage/Makefile4
-rw-r--r--comms/qpage/files/patch-config.c12
2 files changed, 14 insertions, 2 deletions
diff --git a/comms/qpage/Makefile b/comms/qpage/Makefile
index bdee17fab9bc..3d47844fce45 100644
--- a/comms/qpage/Makefile
+++ b/comms/qpage/Makefile
@@ -7,12 +7,12 @@
PORTNAME= qpage
PORTVERSION= 3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms
MASTER_SITES= http://www.qpage.org/download/
EXTRACT_SUFX= .tar.Z
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jfb@mr-happy.com
COMMENT= SNPP client/server for sending messages to an alphanumeric pager
GNU_CONFIGURE= yes
diff --git a/comms/qpage/files/patch-config.c b/comms/qpage/files/patch-config.c
new file mode 100644
index 000000000000..69049371640a
--- /dev/null
+++ b/comms/qpage/files/patch-config.c
@@ -0,0 +1,12 @@
+--- config.c.orig Fri Jan 1 22:14:50 1999
++++ config.c Wed May 4 16:28:49 2005
+@@ -1407,7 +1407,6 @@
+ my_free(list->name);
+ my_free(list->text);
+ my_free(list->pagerid);
+- my_free(list->service);
+ free(list);
+ }
+ }
+
+