aboutsummaryrefslogtreecommitdiff
path: root/comms/quisk
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2019-06-18 23:48:19 +0000
committerStephen Hurd <shurd@FreeBSD.org>2019-06-18 23:48:19 +0000
commit4785ca7513fb6432ec13f7a37c2d8b95e3fd6b0b (patch)
treea7c8bcbc5b01d667b26b74a60abc7abfce899080 /comms/quisk
parent9579a58810e315bd0f7653e6c85c6adf9c071ede (diff)
downloadports-4785ca7513fb6432ec13f7a37c2d8b95e3fd6b0b.tar.gz
ports-4785ca7513fb6432ec13f7a37c2d8b95e3fd6b0b.zip
Re-add unicode fix lost in r502312
Notes
Notes: svn path=/head/; revision=504508
Diffstat (limited to 'comms/quisk')
-rw-r--r--comms/quisk/Makefile2
-rw-r--r--comms/quisk/files/patch-quisk.py16
2 files changed, 17 insertions, 1 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 6fb5d6b249b1..734e4b1d20be 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quisk
DISTVERSION= 4.1.40
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= CHEESESHOP
diff --git a/comms/quisk/files/patch-quisk.py b/comms/quisk/files/patch-quisk.py
new file mode 100644
index 000000000000..528a179c413e
--- /dev/null
+++ b/comms/quisk/files/patch-quisk.py
@@ -0,0 +1,16 @@
+--- quisk.py.orig 2019-06-18 23:38:53 UTC
++++ quisk.py
+@@ -23,6 +23,13 @@ os.chdir(os.path.normpath(os.path.dirnam
+ if sys.path[0] != "'.'": # Make sure the current working directory is on path
+ sys.path.insert(0, '.')
+
++# Hack to ensure unicode is available.
++import locale
++locale.setlocale(locale.LC_ALL, '')
++cloc = locale.getdefaultlocale()
++if locale.nl_langinfo(locale.CODESET) != 'UTF-8':
++ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))
++
+ import wx, wx.html, wx.lib.stattext, wx.lib.colourdb, wx.grid, wx.richtext
+ import math, cmath, time, traceback, string, select, subprocess
+ import threading, pickle, webbrowser