aboutsummaryrefslogtreecommitdiff
path: root/comms/quisk
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2016-12-22 22:57:07 +0000
committerDiane Bruce <db@FreeBSD.org>2016-12-22 22:57:07 +0000
commit54f3c7f10897a4c96a1795fc167e012746ab3db4 (patch)
tree80bbdaae643c9ac39504fc2e0a4ab0fda1bb2453 /comms/quisk
parentd242816bf651e239a72abb0fb48efacf10dd729d (diff)
downloadports-54f3c7f10897a4c96a1795fc167e012746ab3db4.tar.gz
ports-54f3c7f10897a4c96a1795fc167e012746ab3db4.zip
Update to 4.1.3
Fix portaudio build link in setup.py there is no more portaudio2 Reported by: @portscout
Notes
Notes: svn path=/head/; revision=429198
Diffstat (limited to 'comms/quisk')
-rw-r--r--comms/quisk/Makefile4
-rw-r--r--comms/quisk/distinfo5
-rw-r--r--comms/quisk/files/patch-microphone.c4
-rw-r--r--comms/quisk/files/patch-setup.py6
4 files changed, 10 insertions, 9 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 1d4332454194..49d023d830f6 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= quisk
-PORTVERSION= 4.0.5
+PORTVERSION= 4.1.3
CATEGORIES= comms hamradio
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
- LOCAL/shurd
+ LOCAL/db
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Software Defined Radio (SDR)
diff --git a/comms/quisk/distinfo b/comms/quisk/distinfo
index 0f46e203d3ac..dbad59cbf53d 100644
--- a/comms/quisk/distinfo
+++ b/comms/quisk/distinfo
@@ -1,2 +1,3 @@
-SHA256 (quisk-4.0.5.tar.gz) = fc0a45012f5e47fa86ce11e8a55acecc4d2534e829c965face12f68fd8fc9992
-SIZE (quisk-4.0.5.tar.gz) = 2072511
+TIMESTAMP = 1482446629
+SHA256 (quisk-4.1.3.tar.gz) = 3bb41e3d5dd7feb4c949a6086fe4d2adad12048d5eccb6499ced85b2b46f5999
+SIZE (quisk-4.1.3.tar.gz) = 2093660
diff --git a/comms/quisk/files/patch-microphone.c b/comms/quisk/files/patch-microphone.c
index a08ad2fafb31..789227287fbe 100644
--- a/comms/quisk/files/patch-microphone.c
+++ b/comms/quisk/files/patch-microphone.c
@@ -1,4 +1,4 @@
---- microphone.c.orig 2015-11-27 20:43:24 UTC
+--- microphone.c.orig 2016-10-25 20:57:54 UTC
+++ microphone.c
@@ -56,7 +56,7 @@ static int timeVOX = 2000; // VOX han
@@ -8,4 +8,4 @@
+static complex double TxCorrectDc;
// Used for the Hermes protocol
- #define HERMES_TX_BUF_SAMPLES 4800
+ #define HERMES_TX_BUF_SAMPLES 4800 // buffer size in I/Q samples (two shorts)
diff --git a/comms/quisk/files/patch-setup.py b/comms/quisk/files/patch-setup.py
index 41ffae448221..635a8cec93cd 100644
--- a/comms/quisk/files/patch-setup.py
+++ b/comms/quisk/files/patch-setup.py
@@ -1,4 +1,4 @@
---- setup.py.orig 2016-02-16 20:10:44 UTC
+--- setup.py.orig 2016-12-08 22:14:02 UTC
+++ setup.py
@@ -12,8 +12,8 @@ fp.write("#Quisk version %s\n" % Version
fp.close()
@@ -6,8 +6,8 @@
module1 = Extension ('quisk._quisk',
- #include_dirs = ['.'],
- #library_dirs = ['.'],
-+ include_dirs = ['%%LOCALBASE%%/include/portaudio2', '%%LOCALBASE%%/include'],
-+ library_dirs = ['%%LOCALBASE%%/lib/portaudio2', '%%LOCALBASE%%/lib'],
++ include_dirs = ['%%LOCALBASE%%/include'],
++ library_dirs = ['%%LOCALBASE%%/lib'],
libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
'is_key_down.c', 'microphone.c', 'utility.c',