aboutsummaryrefslogtreecommitdiff
path: root/comms/ruby-serialport/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-20 16:07:53 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-20 16:07:53 +0000
commit269cfff0e2e85138f95ffdef736ff8291c292b39 (patch)
treec3587a4299c9b96a4b4838d175142147d62af020 /comms/ruby-serialport/Makefile
parent995bd9e729a2cb3d517deb3f5d3a99e806184072 (diff)
downloadports-269cfff0e2e85138f95ffdef736ff8291c292b39.tar.gz
ports-269cfff0e2e85138f95ffdef736ff8291c292b39.zip
Add ruby-serialport, a Ruby library to communicate via the RS232 port.
Notes
Notes: svn path=/head/; revision=75945
Diffstat (limited to 'comms/ruby-serialport/Makefile')
-rw-r--r--comms/ruby-serialport/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
new file mode 100644
index 000000000000..8148d30bdac2
--- /dev/null
+++ b/comms/ruby-serialport/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/SerialPort
+# Date created: 21 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serialport
+PORTVERSION= 0.6
+CATEGORIES= comms ruby
+MASTER_SITES= http://davedd.free.fr/ruby-serialport/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby library to communicate via the RS232 port
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= CHANGELOG README
+EXAMPLES= test/*.rb
+
+post-patch:
+.for f in ${EXAMPLES}
+ ${RUBY} -i -pe 'sub!(%r"\.\./serialport", "serialport")' ${WRKSRC}/${f}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>