aboutsummaryrefslogtreecommitdiff
path: root/comms/smstools
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-04-25 11:35:33 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-04-25 11:35:33 +0000
commita5ae652049a42a7553c2b71d5ba17740e30ca5a9 (patch)
tree85195f111c69cb1060fc4f7833e4b5de646f1c97 /comms/smstools
parent0ff723d4ef02fa77da29fa45ab121ef6eee436e9 (diff)
downloadports-a5ae652049a42a7553c2b71d5ba17740e30ca5a9.tar.gz
ports-a5ae652049a42a7553c2b71d5ba17740e30ca5a9.zip
Update to 2.0.7
PR: 96256 Submitted by: Fredrik Lindberg <fli@shapeshifter.se> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=160428
Diffstat (limited to 'comms/smstools')
-rw-r--r--comms/smstools/Makefile26
-rw-r--r--comms/smstools/distinfo6
-rw-r--r--comms/smstools/files/patch-Makefile31
-rw-r--r--comms/smstools/files/patch-examples_smsd.conf.easy12
-rw-r--r--comms/smstools/files/patch-examples_smsd.conf.full53
-rw-r--r--comms/smstools/files/patch-install.sh75
-rw-r--r--comms/smstools/files/patch-src_smsd_cfg.c12
-rw-r--r--comms/smstools/files/smsd.sh.in32
-rw-r--r--comms/smstools/pkg-plist113
9 files changed, 219 insertions, 141 deletions
diff --git a/comms/smstools/Makefile b/comms/smstools/Makefile
index ec419afe7bec..6038a836e8ca 100644
--- a/comms/smstools/Makefile
+++ b/comms/smstools/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= smstools
-PORTVERSION= 1.14.11
+PORTVERSION= 2.0.7
CATEGORIES= comms
-MASTER_SITES= http://mirrors.catpipe.net/smstools/
+MASTER_SITES= http://www.meinemullemaus.de/software/smstools/packages/
MAINTAINER= bennyk@wax.dk
COMMENT= Tools to handle Short Message Service
@@ -17,24 +17,20 @@ LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
WRKSRC= ${WRKDIR}/smstools
USE_GMAKE= yes
-USE_REINPLACE= yes
+USE_RC_SUBR= smsd.sh
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} \
+ EXAMPLESDIR=${EXAMPLESDIR}
post-patch:
- echo "${EXAMPLESDIR}"
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/smsd.sh.in > ${WRKDIR}/smsd.sh
+ @${REINPLACE_CMD} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/src/smsd_cfg.c \
- ${WRKSRC}/install.sub \
- ${WRKSRC}/Makefile \
+ ${WRKSRC}/install.sh \
${WRKSRC}/examples/smsd.conf.easy \
- ${WRKSRC}/examples/smsd.conf.full \
- ${WRKSRC}/bin/sms
- @${REINPLACE_CMD} -e "s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|g" \
- ${WRKSRC}/install.sub
+ ${WRKSRC}/examples/smsd.conf.full
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${CP} -Rfv ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKDIR}/smsd.sh ${PREFIX}/etc/rc.d/smsd.sh
.include <bsd.port.mk>
diff --git a/comms/smstools/distinfo b/comms/smstools/distinfo
index dd7a8abef375..448a0e2d4d9c 100644
--- a/comms/smstools/distinfo
+++ b/comms/smstools/distinfo
@@ -1,3 +1,3 @@
-MD5 (smstools-1.14.11.tar.gz) = 3c68b1c8b367fbee7bf1435f05b7dbb5
-SHA256 (smstools-1.14.11.tar.gz) = f20014e74cec15a3646b928df9dedcc8ec4de6c0b4ae6f161b05c14631035084
-SIZE (smstools-1.14.11.tar.gz) = 315527
+MD5 (smstools-2.0.7.tar.gz) = 580c17d9093542d8d1e9dbec5b508faa
+SHA256 (smstools-2.0.7.tar.gz) = 34345bec44fb1ff4cd136119622e184a1145682d96bc0e960527224f193c53a9
+SIZE (smstools-2.0.7.tar.gz) = 43792
diff --git a/comms/smstools/files/patch-Makefile b/comms/smstools/files/patch-Makefile
index 473ea07d0cb7..54caab8624e9 100644
--- a/comms/smstools/files/patch-Makefile
+++ b/comms/smstools/files/patch-Makefile
@@ -1,14 +1,27 @@
---- Makefile.orig Sat Nov 6 16:09:09 2004
-+++ Makefile Sat Nov 6 16:09:24 2004
-@@ -1,9 +1,8 @@
+--- Makefile Fri Apr 21 11:25:01 2006
++++ Makefile Fri Apr 21 13:23:24 2006
+@@ -1,18 +1,18 @@
# Makefile
-VERSION=$(shell grep package_version src/version.h | cut -f2)
--
-+all: compile
- compile:
++VERSION=2.0.7
+
+-compile:
- cd src && $(MAKE) -$(MAKEFLAGS)
-+ cd src && $(MAKE)
++all:
++ cd src && $(MAKE) $(MAKEFLAGS)
+
+-install: compile
+- ./install.sh
++install:
++ @$(SH) ./install.sh
+
+ uninstall:
+ ./uninstall.sh
+
+ clean:
+- cd src && $(MAKE) -$(MAKEFLAGS) clean
++ cd src && $(MAKE) $(MAKEFLAGS) clean
- install: compile
- ./install.sub
+ package: compile clean
+ ./package.sh
diff --git a/comms/smstools/files/patch-examples_smsd.conf.easy b/comms/smstools/files/patch-examples_smsd.conf.easy
index cb82dacca66d..3d4a66fddb96 100644
--- a/comms/smstools/files/patch-examples_smsd.conf.easy
+++ b/comms/smstools/files/patch-examples_smsd.conf.easy
@@ -1,13 +1,11 @@
---- examples/smsd.conf.easy.orig Sat Nov 6 16:10:46 2004
-+++ examples/smsd.conf.easy Sat Nov 6 16:12:34 2004
-@@ -7,8 +7,8 @@
+--- examples/smsd.conf.easy Fri Apr 21 11:25:01 2006
++++ examples/smsd.conf.easy Fri Apr 21 12:32:59 2006
+@@ -5,6 +5,7 @@
loglevel = 7
[GSM1]
--# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0
-device = /dev/ttyS0
-+# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0, FreeBSD5: /dev/cuaa0
-+device = /dev/cuaa0
++device = /dev/cuad0
incoming = yes
- cs_convert = yes
++#baudrate = 9600
#pin = 1111
diff --git a/comms/smstools/files/patch-examples_smsd.conf.full b/comms/smstools/files/patch-examples_smsd.conf.full
index edcfc63ded57..c7b8e2755ba7 100644
--- a/comms/smstools/files/patch-examples_smsd.conf.full
+++ b/comms/smstools/files/patch-examples_smsd.conf.full
@@ -1,24 +1,63 @@
---- examples/smsd.conf.full.orig Sat Nov 6 16:11:35 2004
-+++ examples/smsd.conf.full Sat Nov 6 16:16:54 2004
+--- examples/smsd.conf.full Fri Apr 21 11:25:01 2006
++++ examples/smsd.conf.full Fri Apr 21 15:00:32 2006
+@@ -6,20 +6,20 @@
+ #failed = /var/spool/sms/failed
+ incoming = /var/spool/sms/incoming
+ #sent = /var/spool/sms/sent
+-mypath = /usr/local/bin
+-#logfile = /var/log/smsd.log
++mypath = %%PREFIX%%/bin
++logfile = /var/log/smsd.log
+ loglevel = 7
+-#alarmhandler = /usr/local/bin/alarmevent
++#alarmhandler = %%PREFIX%%/bin/alarmevent
+ alarmlevel = 4
+ delaytime = 10
+ errorsleeptime = 10
+ blocktime = 3600
+-#eventhandler = /usr/local/bin/smsevent
++#eventhandler = %%PREFIX%%/bin/smsevent
+ #stats = /var/log/smsd_stats
+ #stats_interval = 3600
+-#blacklist = /etc/smsd.black
+-#whitelist = /etc/smsd.white
+-#checkhandler = /usr/local/bin/smscheck
++#blacklist = %%PREFIX%%/etc/smsd.black
++#whitelist = %%PREFIX%%/etc/smsd.white
++#checkhandler = %%PREFIX%%/bin/smscheck
+ receive_before_send = no
+ number_parts = yes
+
@@ -45,8 +45,8 @@
[GSM1]
init = ATE0+CPMS="SM"+CNMI=2,0,0,2,1
-# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0
-device = /dev/ttyS0
-+# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0, FreeBSD5: /dev/cuaa0
-+device = /dev/cuaa0
++# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0, FreeBSD /dev/cuad0
++device = /dev/cuad0
incoming = yes
queues = OTHER
#You don't need a PIN for mobile phones
-@@ -61,8 +61,8 @@
+@@ -58,12 +58,12 @@
+ cs_convert = yes
+ report = no
+ memory_start = 1
+-#eventhandler = /usr/local/bin/smsevent
++#eventhandler = %%PREFIX%%/bin/smsevent
[GSM2]
init = ATE0
-# Windows: /dev/com2, Solaris: /dev/cua/b, Linux /dev/ttyS1
-device = /dev/ttyS1
-+# Windows: /dev/com2, Solaris: /dev/cua/b, Linux /dev/ttyS1, FreeBSD5: /dev/cuaa1
-+device = /dev/cuaa1
++# Windows: /dev/com2, Solaris: /dev/cua/b, Linux /dev/ttyS1, FreeBSD /dev/cuad1
++device = /dev/cuad1
incoming = yes
queues = OTHER
#You don't need a PIN for mobile phones
+@@ -75,4 +75,4 @@
+ cs_convert = yes
+ report = no
+ memory_start = 1
+-#eventhandler = /usr/local/bin/smsevent
++#eventhandler = %%PREFIX%%/bin/smsevent
diff --git a/comms/smstools/files/patch-install.sh b/comms/smstools/files/patch-install.sh
new file mode 100644
index 000000000000..2ff6dd535b82
--- /dev/null
+++ b/comms/smstools/files/patch-install.sh
@@ -0,0 +1,75 @@
+--- install.sh Fri Apr 21 11:25:01 2006
++++ install.sh Fri Apr 21 14:59:22 2006
+@@ -40,32 +40,42 @@
+ fi
+ }
+
+-echo ""
+ if [ ! -f src/smsd ] && [ ! -f src/smsd.exe ]; then
+ echo 'Please run "make -s install" instead.'
+ exit 1
+ fi
+
+ echo "Installing binary program files"
+-makedir /usr/local
+-makedir /usr/local/bin
+ if [ -f src/smsd.exe ]; then
+- forcecopy src/smsd.exe /usr/local/bin/smsd.exe
++ forcecopy src/smsd.exe %%PREFIX%%/bin/smsd.exe
+ else
+- forcecopy src/smsd /usr/local/bin/smsd
++ forcecopy src/smsd %%PREFIX%%/bin/smsd
+ fi
+-delete /usr/local/bin/getsms
+-delete /usr/local/bin/putsms
+
+ echo "Installing some scripts"
+-copy scripts/pkill /usr/local/bin/pkill
+-copy scripts/sendsms /usr/local/bin/sendsms
+-copy scripts/sms2html /usr/local/bin/sms2html
+-copy scripts/sms2unicode /usr/local/bin/sms2unicode
+-copy scripts/unicode2sms /usr/local/bin/unicode2sms
++copy scripts/sendsms %%PREFIX%%/bin/sendsms
++copy scripts/sms2html %%PREFIX%%/bin/sms2html
++copy scripts/sms2xml %%PREFIX%%/bin/sms2xml
++copy scripts/sms2unicode %%PREFIX%%/bin/sms2unicode
++copy scripts/unicode2sms %%PREFIX%%/bin/unicode2sms
+
+ echo "Installing config file"
+-copy examples/smsd.conf.easy /etc/smsd.conf
++copy examples/smsd.conf.full %%PREFIX%%/etc/smsd.conf.sample
++
++echo "Installing additional examples"
++makedir %%EXAMPLESDIR%%
++copy examples/operator_logo1.sms %%EXAMPLESDIR%%/operator_logo1.sms
++copy examples/operator_logo2.sms %%EXAMPLESDIR%%/operator_logo2.sms
++copy examples/received_report.sms %%EXAMPLESDIR%%/received_report.sms
++copy examples/received_sms.sms %%EXAMPLESDIR%%/received_sms.sms
++copy examples/send_sms.sms %%EXAMPLESDIR%%/send_sms.sms
++copy examples/send_sms_unicode.sms %%EXAMPLESDIR%%/send_sms_unicode.sms
++copy examples/smsd.conf.easy %%EXAMPLESDIR%%/smsd.conf.easy
++copy examples/smsd.conf.full %%EXAMPLESDIR%%/smsd.conf.full
++copy scripts/email2sms %%EXAMPLESDIR%%/email2sms
++copy scripts/smsevent %%EXAMPLESDIR%%/smsevent
++copy scripts/sql_demo %%EXAMPLESDIR%%/sql_demo
++copy scripts/mysmsd %%EXAMPLESDIR%%/mysmsd
+
+ echo "Creating minimum spool directories"
+ makedir /var/spool
+@@ -74,15 +84,5 @@
+ makedir /var/spool/sms/outgoing
+ makedir /var/spool/sms/checked
+
+-echo "Installing start-script"
+-if [ -d /etc/init.d ]; then
+- copy scripts/sms /etc/init.d/sms
+-elif [ -d /sbin/init.d ]; then
+- copy scripts/sms /sbin/init.d/sms
+-else
+- echo " I do not know where to copy scripts/sms. Please find out yourself."
+-fi
+-
+ echo ""
+-echo "Example script files are not installed automatically."
+-echo 'Please dont forget to edit /etc/smsd.conf.'
++echo 'Please dont forget to create/edit %%PREFIX%%/etc/smsd.conf.'
diff --git a/comms/smstools/files/patch-src_smsd_cfg.c b/comms/smstools/files/patch-src_smsd_cfg.c
index d67f5c1642a5..df03fec70086 100644
--- a/comms/smstools/files/patch-src_smsd_cfg.c
+++ b/comms/smstools/files/patch-src_smsd_cfg.c
@@ -1,6 +1,6 @@
---- src/smsd_cfg.orig Sat Nov 6 16:04:24 2004
-+++ src/smsd_cfg.c Sat Nov 6 16:06:29 2004
-@@ -329,7 +329,7 @@
+--- src/smsd_cfg.c Fri Apr 21 11:25:01 2006
++++ src/smsd_cfg.c Fri Apr 21 11:27:51 2006
+@@ -387,7 +387,7 @@
printf(" -h this help\n");
printf(" -s display status monitor\n");
printf(" -V print copyright and version\n\n");
@@ -9,12 +9,12 @@
printf("Output is written to stdout, errors are written to stderr.\n\n");
exit(0);
}
-@@ -337,7 +337,7 @@
+@@ -395,7 +395,7 @@
void parsearguments(int argc,char** argv)
{
int result;
- strcpy(configfile,"/etc/smsd.conf");
+ strcpy(configfile,"%%PREFIX%%/etc/smsd.conf");
- debug=0;
printstatus=0;
-
+
+ do
diff --git a/comms/smstools/files/smsd.sh.in b/comms/smstools/files/smsd.sh.in
new file mode 100644
index 000000000000..5f499bb5bda4
--- /dev/null
+++ b/comms/smstools/files/smsd.sh.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+#
+# PROVIDE: smsd
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable smsd:
+#
+# smsd_enable="YES"
+#
+smsd_enable=${smsd_enable-"NO"}
+
+. %%RC_SUBR%%
+
+name="smsd"
+rcvar=`set_rcvar`
+load_rc_config $name
+pidfile="/var/run/smsd.pid"
+command="%%PREFIX%%/bin/smsd"
+command_args='&'
+
+# Unfortunally we need to this because as the program won't
+# exit cleanly and the terminal will be stuck forever in waitpid.
+case "$1" in
+ stop)
+ pkill smsd
+ ;;
+ *)
+ run_rc_command "$1"
+ ;;
+esac
+
diff --git a/comms/smstools/pkg-plist b/comms/smstools/pkg-plist
index 1dfb5730a371..406277b1d6fb 100644
--- a/comms/smstools/pkg-plist
+++ b/comms/smstools/pkg-plist
@@ -1,103 +1,28 @@
-@comment $FreeBSD$
-bin/email2sms
bin/sendsms
-bin/smsresend
+bin/sms2html
+bin/sms2unicode
+bin/sms2xml
bin/smsd
-bin/getsms
-bin/putsms
-bin/mysmsd
-bin/smsevent
-etc/rc.d/smsd.sh.sample
-etc/smsd.conf
+bin/unicode2sms
+etc/rc.d/smsd.sh
+etc/smsd.conf.sample
+%%EXAMPLESDIR%%/email2sms
+%%EXAMPLESDIR%%/mysmsd
+%%EXAMPLESDIR%%/operator_logo1.sms
%%EXAMPLESDIR%%/operator_logo2.sms
%%EXAMPLESDIR%%/received_report.sms
%%EXAMPLESDIR%%/received_sms.sms
%%EXAMPLESDIR%%/send_sms.sms
-%%EXAMPLESDIR%%/smsd.black
+%%EXAMPLESDIR%%/send_sms_unicode.sms
%%EXAMPLESDIR%%/smsd.conf.easy
%%EXAMPLESDIR%%/smsd.conf.full
+%%EXAMPLESDIR%%/smsevent
%%EXAMPLESDIR%%/sql_demo
-%%EXAMPLESDIR%%/smsd.conf.easy.orig
-%%EXAMPLESDIR%%/smsd.conf.full.orig
-%%EXAMPLESDIR%%/smsd.conf.full.bak
-%%EXAMPLESDIR%%/smsd.conf.easy.bak
-%%EXAMPLESDIR%%/operator_logo1.sms
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/status.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/eventhandler.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/logfile.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/modem.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/move_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/move_r.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page5.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page6.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page7.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/page8.html
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/queue.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/sms.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/statistic.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/slideshow/blacklist.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/blacklist.html
-%%PORTDOCS%%%%DOCSDIR%%/html/book.html
-%%PORTDOCS%%%%DOCSDIR%%/html/butterfly.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/compiling.html
-%%PORTDOCS%%%%DOCSDIR%%/html/configure.html
-%%PORTDOCS%%%%DOCSDIR%%/html/configure2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/contact.html
-%%PORTDOCS%%%%DOCSDIR%%/html/costs.html
-%%PORTDOCS%%%%DOCSDIR%%/html/download.html
-%%PORTDOCS%%%%DOCSDIR%%/html/email.png
-%%PORTDOCS%%%%DOCSDIR%%/html/book.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/eventhandler.html
-%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fileformat.html
-%%PORTDOCS%%%%DOCSDIR%%/html/gpl.html
-%%PORTDOCS%%%%DOCSDIR%%/html/gpl_de.html
-%%PORTDOCS%%%%DOCSDIR%%/html/gsmmodem.html
-%%PORTDOCS%%%%DOCSDIR%%/html/hardwarecomp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/history.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/key.png
-%%PORTDOCS%%%%DOCSDIR%%/html/license.html
-%%PORTDOCS%%%%DOCSDIR%%/html/links.html
-%%PORTDOCS%%%%DOCSDIR%%/html/logging.html
-%%PORTDOCS%%%%DOCSDIR%%/html/mnp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/news.html
-%%PORTDOCS%%%%DOCSDIR%%/html/public_key_stefan_frings.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/quotes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/redundancy.html
-%%PORTDOCS%%%%DOCSDIR%%/html/referenzen.html
-%%PORTDOCS%%%%DOCSDIR%%/html/run.html
-%%PORTDOCS%%%%DOCSDIR%%/html/softwarecomp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/sql.html
-%%PORTDOCS%%%%DOCSDIR%%/html/sql2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/statformat.html
-%%PORTDOCS%%%%DOCSDIR%%/html/statusmonitor.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tc35.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/thanks.html
-%%PORTDOCS%%%%DOCSDIR%%/html/twist.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/windows.html
-%%PORTDOCS%%%%DOCSDIR%%/html/thanks.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/alarmhandler.html
-%%PORTDOCS%%%%DOCSDIR%%/html/shippingdetails.html
-%%PORTDOCS%%%%DOCSDIR%%/html/book.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/bugs.html
-%%PORTDOCS%%%%DOCSDIR%%/html/compiling.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/download.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/european.html
-%%PORTDOCS%%%%DOCSDIR%%/html/hardwarecomp.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/history.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/postpaid.html
-%%PORTDOCS%%%%DOCSDIR%%/html/shippingdetails.html~
-%%PORTDOCS%%%%DOCSDIR%%/html/whypaypal.html
-%%PORTDOCS%%%%DOCSDIR%%/html/windows.html~
-%%PORTDOCS%%%%DOCSDIR%%/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/slideshow
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm share/examples/smstools
+@cwd /
+@dirrm var/spool/sms/outgoing
+@dirrm var/spool/sms/incoming
+@dirrm var/spool/sms/checked
+@dirrm var/spool/sms