aboutsummaryrefslogtreecommitdiff
path: root/comms/telldus-core
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-27 05:31:21 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-27 05:31:21 +0000
commitb273b12c27f357735415777915a9af4317682c8e (patch)
tree63c3dcbc59a9b7967bc894444cc98055fa9a78a6 /comms/telldus-core
parentfabc682a9ed22ac5d32c602979b33efd5d7da586 (diff)
downloadports-b273b12c27f357735415777915a9af4317682c8e.tar.gz
ports-b273b12c27f357735415777915a9af4317682c8e.zip
comms/telldus-core: Fix build with Clang 6
common/EventHandler_unix.cpp:83:24: error: non-constant-expression cannot be narrowed from type 'unsigned long long' to 'time_t' (aka 'int') in initializer list [-Wc++11-narrowing] timespec abstime = { now.tv_sec + (abstime_ns_large / 1000000000), abstime_ns_large % 1000000000 }; ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/telldus-core-2.1.2_5.log PR: 230882 Submitted by: tobik Approved by: Johan Ström <johan@stromnet.se> (maintainer)
Notes
Notes: svn path=/head/; revision=478176
Diffstat (limited to 'comms/telldus-core')
-rw-r--r--comms/telldus-core/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/comms/telldus-core/Makefile b/comms/telldus-core/Makefile
index 43d1c9b43225..aefe38f044f9 100644
--- a/comms/telldus-core/Makefile
+++ b/comms/telldus-core/Makefile
@@ -28,6 +28,8 @@ CMAKE_ARGS+=-DGENERATE_MAN=TRUE
CMAKE_ARGS+=-DSYSCONF_INSTALL_DIR="${PREFIX}/etc"
# Using global /var, otherwise testport complains "Warning: port uses /usr/local/var instead of /var"
CMAKE_ARGS+=-DSTATE_INSTALL_DIR="/var/telldus"
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
MAKE_JOBS_UNSAFE= yes