aboutsummaryrefslogtreecommitdiff
path: root/comms/tits
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-18 15:32:59 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-18 15:32:59 +0000
commit700291efee9ad83d41274411f663a896bc1c110a (patch)
treecdec42e238e440ecb9b76933bd617b39611722bf /comms/tits
parent58bec0c8a376761145dd8d1d691743de1a7eb6bb (diff)
downloadports-700291efee9ad83d41274411f663a896bc1c110a.tar.gz
ports-700291efee9ad83d41274411f663a896bc1c110a.zip
Add tits 1.0.2, a server which provides telnet(1) access to one or
more tty ports. Obtained from: NetBSD
Notes
Notes: svn path=/head/; revision=41648
Diffstat (limited to 'comms/tits')
-rw-r--r--comms/tits/Makefile29
-rw-r--r--comms/tits/distinfo1
-rw-r--r--comms/tits/files/patch-Makefile20
-rw-r--r--comms/tits/files/patch-dispatcher.h14
-rw-r--r--comms/tits/files/patch-tty.c23
-rw-r--r--comms/tits/pkg-comment1
-rw-r--r--comms/tits/pkg-descr8
-rw-r--r--comms/tits/pkg-plist2
8 files changed, 98 insertions, 0 deletions
diff --git a/comms/tits/Makefile b/comms/tits/Makefile
new file mode 100644
index 000000000000..8a4b5d020b1e
--- /dev/null
+++ b/comms/tits/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tits
+# Date created: 9 February 2001
+# Whom: Steve Woodford <scw@netbsd.hut.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tits
+PORTVERSION= 1.0.2
+CATEGORIES= comms
+MASTER_SITES= http://www.wee-eck.demon.co.uk/tits/
+
+MAINTAINER= ports@FreeBSD.org
+
+BINDIR= ${PREFIX}/sbin
+MANDIR= ${PREFIX}/man/man
+MAKE_ENV= BINDIR=${BINDIR} MANDIR=${MANDIR}
+
+MAN8= tits.8
+MANCOMPRESSED= yes
+
+post-patch:
+ ${MV} ${WRKSRC}/tits.8 ${WRKSRC}/tits.8.in
+ ${SED} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/tits.8.in > ${WRKSRC}/tits.8
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/tits.conf ${PREFIX}/etc/tits.conf.default
+
+.include <bsd.port.mk>
diff --git a/comms/tits/distinfo b/comms/tits/distinfo
new file mode 100644
index 000000000000..41486630822c
--- /dev/null
+++ b/comms/tits/distinfo
@@ -0,0 +1 @@
+MD5 (tits-1.0.2.tar.gz) = 7166ba3d897242d74034c2f4a37e2916
diff --git a/comms/tits/files/patch-Makefile b/comms/tits/files/patch-Makefile
new file mode 100644
index 000000000000..9a6d57db914a
--- /dev/null
+++ b/comms/tits/files/patch-Makefile
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- Makefile.orig Tue Feb 20 22:27:21 2001
++++ Makefile Wed Apr 18 18:29:23 2001
+@@ -32,12 +32,12 @@
+ WARNS= 2
+
+ PROG= tits
+-MAN= tits.8
++MAN8= tits.8
+
+ SRCS= main.c buffer.c client.c context.c listener.c telnet.c tty.c
+ SRCS+= dispatcher.c setup.c config.c server.c logger.c
+
+-CPPFLAGS+= -DLIBWRAP -DTITS_DEFAULT_CONFIG_FILE=\"${LOCALBASE}/etc/tits.conf\"
++CFLAGS+= -DLIBWRAP -DTITS_DEFAULT_CONFIG_FILE=\"${LOCALBASE}/etc/tits.conf\"
+ LDADD+= -lwrap
+ PREFIX?= /usr/local
+ BINDIR?= ${PREFIX}/sbin
diff --git a/comms/tits/files/patch-dispatcher.h b/comms/tits/files/patch-dispatcher.h
new file mode 100644
index 000000000000..cbf7fc094f04
--- /dev/null
+++ b/comms/tits/files/patch-dispatcher.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- dispatcher.h 2001/04/18 14:50:37 1.1
++++ dispatcher.h 2001/04/18 14:51:57
+@@ -43,4 +43,8 @@
+ extern void dispatcher_del_client(struct client_ctx *);
+ extern int dispatcher_mainloop(void);
+
++#ifdef __FreeBSD__
++typedef unsigned int nfds_t;
++#endif
++
+ #endif /* __dispatcher_h */
diff --git a/comms/tits/files/patch-tty.c b/comms/tits/files/patch-tty.c
new file mode 100644
index 000000000000..3d7ba33635b6
--- /dev/null
+++ b/comms/tits/files/patch-tty.c
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- tty.c 2001/04/18 14:43:52 1.1
++++ tty.c 2001/04/18 14:45:57
+@@ -32,6 +32,7 @@
+ #include <sys/types.h>
+ #include <sys/filio.h>
+ #include <sys/ioctl.h>
++#include <sys/stat.h>
+ #include <sys/types.h>
+
+ #include <ctype.h>
+@@ -216,8 +217,7 @@
+ * If this is *not* a pseudo tty, ensure DTR is asserted.
+ * Note: This relies on TIOCGFLAGS returning ENOTTY for pty(4)'s.
+ */
+- if (ioctl(cc->cc_fd, TIOCGFLAGS, &flags) == 0 && errno == ENOTTY &&
+- ioctl(cc->cc_fd, TIOCSDTR, 0) < 0) {
++ if (ioctl(cc->cc_fd, TIOCSDTR, 0) < 0 && errno != ENOTTY) {
+ (void) close(cc->cc_fd);
+ (void) free(tc->tc_to.to_device);
+ (void) free(tc);
diff --git a/comms/tits/pkg-comment b/comms/tits/pkg-comment
new file mode 100644
index 000000000000..375674579d1a
--- /dev/null
+++ b/comms/tits/pkg-comment
@@ -0,0 +1 @@
+A server which provides telnet(1) access to one or more tty ports
diff --git a/comms/tits/pkg-descr b/comms/tits/pkg-descr
new file mode 100644
index 000000000000..919f6cb9b914
--- /dev/null
+++ b/comms/tits/pkg-descr
@@ -0,0 +1,8 @@
+The tits command is a server process which provides telnet(1) access
+to one or more tty ports as specified in config-file (or
+/etc/tits.conf if no configuration file is specified on the command
+line).
+
+Any number of telnet(1) clients may connect to a single tits port.
+Each client will see exactly the same output as well as being able to
+send keystrokes simultaneously.
diff --git a/comms/tits/pkg-plist b/comms/tits/pkg-plist
new file mode 100644
index 000000000000..b9b1ac3fc88a
--- /dev/null
+++ b/comms/tits/pkg-plist
@@ -0,0 +1,2 @@
+etc/tits.conf.default
+sbin/tits