aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl/files
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-05-09 05:51:15 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-05-09 05:51:15 +0000
commit9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9 (patch)
tree73acd5ee1689cf17bfd102d62f33424151987cae /comms/trustedqsl/files
parent86836956e1907a56f17f557be17fdc3523cdef93 (diff)
downloadports-9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9.tar.gz
ports-9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9.zip
- summarize changes
- bump portrevision PR: ports/96020 Submitted by: Diane Bruce <db@db.net> (maintainer)
Notes
Notes: svn path=/head/; revision=161773
Diffstat (limited to 'comms/trustedqsl/files')
-rw-r--r--comms/trustedqsl/files/Makefile.tqsllib49
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in12
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp11
-rw-r--r--comms/trustedqsl/files/sysconfig.h.tqsllib45
4 files changed, 23 insertions, 94 deletions
diff --git a/comms/trustedqsl/files/Makefile.tqsllib b/comms/trustedqsl/files/Makefile.tqsllib
deleted file mode 100644
index 89bbe3851aaa..000000000000
--- a/comms/trustedqsl/files/Makefile.tqsllib
+++ /dev/null
@@ -1,49 +0,0 @@
-CXX = g++
-CC ?= gcc
-LIBS=-lcrypto -lexpat
-CXXFLAGS += -I. -I${LOCALBASE}/include -DHAVE_CONFIG_H
-LDFLAGS = -L. $(LIBS) -L${LOCALBASE}/lib -lstdc++
-TARGETS = gen_crq load_cert station_loc dumptqsldata converter
-ZLIB=z
-MYLIB=tqsllib
-
-OBJS= tqsllib.o openssl_cert.o adif.o xml.o\
- location.o tqslconvert.o cabrillo.o
-
-all: $(TARGETS)
-
-gen_crq: gen_crq.o lib$(MYLIB).a
- ${CXX} -o gen_crq gen_crq.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-load_cert: load_cert.o lib$(MYLIB).a
- ${CXX} -o load_cert load_cert.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-converter: converter.o lib$(MYLIB).a
- ${CXX} -o converter converter.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-station_loc: station_loc.o lib$(MYLIB).a
- ${CXX} -o station_loc station_loc.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-dumptqsldata: dumptqsldata.o lib$(MYLIB).a
- ${CXX} -o dumptqsldata dumptqsldata.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-include tqsllib.depends
-
-libtqsllib.a: $(OBJS)
- ${AR} qc libtqsllib.a ${OBJS}
-
-install:
- ${INSTALL} gen_crq ${PREFIX}/bin
- ${INSTALL} load_cert ${PREFIX}/bin
- ${INSTALL} converter ${PREFIX}/bin
- ${INSTALL} station_loc ${PREFIX}/bin
- ${INSTALL} dumptqsldata ${PREFIX}/bin
-
-clean:
- rm -f converter dumptqsldata gen_crq load_cert station_loc
- rm -f *.o *.lo *.a *.la *~ xxx.* *.a
- rm -rf .libs
-
-%.o: %.cpp
- ${CXX} ${CXXFLAGS} -c -o $@ $*.cpp
-
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in b/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
new file mode 100644
index 000000000000..cb99bde9bb20
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
@@ -0,0 +1,12 @@
+--- tqsllib-2.0/Makefile.in.orig Fri Mar 11 07:58:31 2005
++++ tqsllib-2.0/Makefile.in Tue Apr 18 15:53:02 2006
+@@ -767,8 +767,7 @@
+
+ info-am:
+
+-install-data-am: install-dataDATA install-docDATA \
+- install-includeHEADERS
++install-data-am: install-includeHEADERS
+
+ install-exec-am: install-binPROGRAMS install-exec-local \
+ install-libLIBRARIES install-libLTLIBRARIES
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp b/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
new file mode 100644
index 000000000000..b703c45c52f5
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
@@ -0,0 +1,11 @@
+--- tqsllib-2.0/openssl_cert.cpp.orig Fri Mar 11 07:47:11 2005
++++ tqsllib-2.0/openssl_cert.cpp Wed Mar 29 11:27:41 2006
+@@ -1290,6 +1290,8 @@
+ attrib->set = 1;
+ #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000
+ attrib->single = 0;
++#elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000
++ attrib->single = 0;
+ #else
+ #error "Unexpected OpenSSL version; check X509_ATTRIBUTE struct compatibility"
+ #endif
diff --git a/comms/trustedqsl/files/sysconfig.h.tqsllib b/comms/trustedqsl/files/sysconfig.h.tqsllib
deleted file mode 100644
index de7c9c9b2d01..000000000000
--- a/comms/trustedqsl/files/sysconfig.h.tqsllib
+++ /dev/null
@@ -1,45 +0,0 @@
-/* tqsllib/sysconfig.h. Generated automatically by configure. */
-/* lotwdb/sysconfig.h.in. Generated automatically from configure.in by autoheader. */
-
-/* Define to empty if the keyword does not work. */
-/* #undef const */
-
-/* Define to `int' if <sys/types.h> doesn't define. */
-/* #undef mode_t */
-
-/* Define if you have the ANSI C header files. */
-#define STDC_HEADERS 1
-
-/* Define if your <sys/time.h> declares struct tm. */
-/* #undef TM_IN_SYS_TIME */
-
-/* Defined if this is LOTW server code */
-#undef LOTW_SERVER
-
-/* Define if you have the mkdir function. */
-#define HAVE_MKDIR 1
-
-/* Define if you have the strerror function. */
-#define HAVE_STRERROR 1
-
-/* Define if you have the snprintf function. */
-#define HAVE_SNPRINTF 1
-
-/* Define if you have the <unistd.h> header file. */
-#define HAVE_UNISTD_H 1
-
-/* Define if you have the <getopt.h> header file. */
-#define HAVE_GETOPT_H
-
-/* Define if you have the crypto library (-lcrypto). */
-#define HAVE_LIBCRYPTO 1
-
-/* Define if you have the dl library (-ldl). */
-#define HAVE_LIBDL 1
-
-/* Define if you have the pcrl library (-lpcrl). */
-#undef HAVE_LIBPCRL
-
-/* Define if you have the sqlca library (-lsqlca). */
-#undef HAVE_LIBSQLCA
-