aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl/files
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-11-30 04:55:14 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-11-30 04:55:14 +0000
commitce2e81be83b11432d08a547df770d29c91ec0bf1 (patch)
tree749e8c181a909bbcc8e373447e356e3e4bcb5ec4 /comms/trustedqsl/files
parentd891bad74acf6b18d273c00ee6e92588d0b88911 (diff)
downloadports-ce2e81be83b11432d08a547df770d29c91ec0bf1.tar.gz
ports-ce2e81be83b11432d08a547df770d29c91ec0bf1.zip
Fix build for 9.x
Notes
Notes: svn path=/head/; revision=402644
Diffstat (limited to 'comms/trustedqsl/files')
-rw-r--r--comms/trustedqsl/files/patch-CMakeLists.txt2
-rw-r--r--comms/trustedqsl/files/patch-apps_CMakeLists.txt2
-rw-r--r--comms/trustedqsl/files/patch-src_xml.h16
3 files changed, 14 insertions, 6 deletions
diff --git a/comms/trustedqsl/files/patch-CMakeLists.txt b/comms/trustedqsl/files/patch-CMakeLists.txt
index a2ecacf68efa..75149782fbe1 100644
--- a/comms/trustedqsl/files/patch-CMakeLists.txt
+++ b/comms/trustedqsl/files/patch-CMakeLists.txt
@@ -5,7 +5,7 @@
option(USE_STATIC_MSVCRT "Use a static Visual C++ Runtime when building with MSVC")
+if(UNIX)
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+endif()
if(MSVC AND USE_STATIC_MSVCRT)
foreach(flag_var
diff --git a/comms/trustedqsl/files/patch-apps_CMakeLists.txt b/comms/trustedqsl/files/patch-apps_CMakeLists.txt
index 80cd35358011..a59a7bede2c5 100644
--- a/comms/trustedqsl/files/patch-apps_CMakeLists.txt
+++ b/comms/trustedqsl/files/patch-apps_CMakeLists.txt
@@ -1,4 +1,4 @@
---- apps/CMakeLists.txt.orig 2015-11-29 00:14:00 UTC
+--- apps/CMakeLists.txt.orig 2015-10-21 17:26:38 UTC
+++ apps/CMakeLists.txt
@@ -148,7 +148,11 @@ if(NOT APPLE AND NOT WIN32)
add_definitions("-DCONFDIR=\"${CMAKE_INSTALL_PREFIX}/share/TrustedQSL/\"")
diff --git a/comms/trustedqsl/files/patch-src_xml.h b/comms/trustedqsl/files/patch-src_xml.h
index e3d6e5ef4027..c68cff0257b6 100644
--- a/comms/trustedqsl/files/patch-src_xml.h
+++ b/comms/trustedqsl/files/patch-src_xml.h
@@ -1,6 +1,14 @@
--- src/xml.h.orig 2015-10-21 17:26:38 UTC
+++ src/xml.h
-@@ -28,7 +28,7 @@ namespace tqsllib {
+@@ -13,6 +13,7 @@
+
+ #include <string>
+ #include <map>
++#include <memory>
+ #include <vector>
+ #include <utility>
+ #include <expat.h>
+@@ -28,7 +29,7 @@ namespace tqsllib {
class XMLElement;
@@ -9,7 +17,7 @@
typedef map<string, string> XMLElementAttributeList;
/** Encapsulates an XML element
-@@ -62,7 +62,7 @@ class XMLElement {
+@@ -62,7 +63,7 @@ class XMLElement {
*/
pair<string, bool> getAttribute(const string& key);
/// Add an element to the list of contained subelements
@@ -18,7 +26,7 @@
XMLElementAttributeList& getAttributeList() { return _attributes; }
XMLElementList& getElementList() { return _elements; }
/// Parse an XML file and add its element tree to this element
-@@ -134,8 +134,8 @@ XMLElement::setAttribute(const string& k
+@@ -134,8 +135,8 @@ XMLElement::setAttribute(const string& k
}
inline XMLElementList::iterator
@@ -29,7 +37,7 @@
return it;
}
-@@ -158,9 +158,9 @@ inline bool
+@@ -158,9 +159,9 @@ inline bool
XMLElement::getNextElement(XMLElement& element) {
if (_iter == _elements.end())
return false;