aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl/files
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-12-13 04:11:11 +0000
committerDiane Bruce <db@FreeBSD.org>2013-12-13 04:11:11 +0000
commite84062fab9c22ba32e6c635b79b10dfba88e54d7 (patch)
treeba96de2127564cbf957d20127970cb75dfdcfa0a /comms/trustedqsl/files
parent91bf0734d91ce79f95e6afe9cac1878a4878c561 (diff)
downloadports-e84062fab9c22ba32e6c635b79b10dfba88e54d7.tar.gz
ports-e84062fab9c22ba32e6c635b79b10dfba88e54d7.zip
- Update to latest version [1]
- Fix build on 10.0 - Convert to stagedir PR: ports/184554 [1] Submitted by: shurd@sasktel.net
Notes
Notes: svn path=/head/; revision=336316
Diffstat (limited to 'comms/trustedqsl/files')
-rw-r--r--comms/trustedqsl/files/patch-apps_CMakeLists.txt15
-rw-r--r--comms/trustedqsl/files/patch-apps_tqsl.cpp20
-rw-r--r--comms/trustedqsl/files/patch-cmakemodules_FindBDB.cmake14
-rw-r--r--comms/trustedqsl/files/patch-src_tqslconvert.cpp6
-rw-r--r--comms/trustedqsl/files/patch-src_xml.h17
-rw-r--r--comms/trustedqsl/files/pkg-message3
6 files changed, 58 insertions, 17 deletions
diff --git a/comms/trustedqsl/files/patch-apps_CMakeLists.txt b/comms/trustedqsl/files/patch-apps_CMakeLists.txt
index d827fe019255..e1a30698c34b 100644
--- a/comms/trustedqsl/files/patch-apps_CMakeLists.txt
+++ b/comms/trustedqsl/files/patch-apps_CMakeLists.txt
@@ -1,13 +1,14 @@
---- apps/CMakeLists.txt.orig 2013-06-25 20:03:58.000000000 -0500
-+++ apps/CMakeLists.txt 2013-06-25 20:05:42.000000000 -0500
-@@ -101,5 +101,9 @@
+--- apps/CMakeLists.txt.orig 2013-12-06 17:42:11.000000000 -0800
++++ apps/CMakeLists.txt 2013-12-06 17:43:12.000000000 -0800
+@@ -121,6 +121,10 @@
+ add_definitions("-DCONFDIR=\"${CMAKE_INSTALL_PREFIX}/share/TrustedQSL/\"")
install(TARGETS tqsl DESTINATION bin)
- install(TARGETS tqslcert DESTINATION bin)
install(DIRECTORY help DESTINATION share/TrustedQSL)
--install(FILES trustedqsl.5 DESTINATION share/man/man5)
+-install(FILES tqsl.5 DESTINATION share/man/man5)
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ install(FILES trustedqsl.5 DESTINATION man/man5)
++ install(FILES tqsl.5 DESTINATION man/man5)
+else()
-+ install(FILES trustedqsl.5 DESTINATION share/man/man5)
++ install(FILES tqsl.5 DESTINATION share/man/man5)
+endif()
+ install(FILES icons/key48.png DESTINATION share/pixmaps RENAME TrustedQSL.png)
endif()
diff --git a/comms/trustedqsl/files/patch-apps_tqsl.cpp b/comms/trustedqsl/files/patch-apps_tqsl.cpp
new file mode 100644
index 000000000000..5b6a26e9e6e4
--- /dev/null
+++ b/comms/trustedqsl/files/patch-apps_tqsl.cpp
@@ -0,0 +1,20 @@
+--- apps/tqsl.cpp.orig 2013-12-12 15:52:46.737002435 -0500
++++ apps/tqsl.cpp 2013-12-12 15:52:12.740004212 -0500
+@@ -71,7 +71,7 @@
+ #endif
+ #include <zlib.h>
+ #include <openssl/opensslv.h> // only for version info!
+-#include <db.h> //only for version info!
++#include <db5/db.h> //only for version info!
+ #include "tqslwiz.h"
+ #include "qsodatadialog.h"
+ #include "tqslerrno.h"
+@@ -2016,7 +2016,7 @@
+ } else {
+ //compress the upload
+ string compressed;
+- size_t compressedSize=compressToBuf(compressed, (const char*)signedOutput.mb_str());
++ ssize_t compressedSize=compressToBuf(compressed, (const char*)signedOutput.mb_str());
+ //ofstream f; f.open("testzip.tq8", ios::binary); f<<compressed; f.close(); //test of compression routine
+ if (compressedSize<0) {
+ wxLogMessage(wxT("Error compressing before upload"));
diff --git a/comms/trustedqsl/files/patch-cmakemodules_FindBDB.cmake b/comms/trustedqsl/files/patch-cmakemodules_FindBDB.cmake
index 87a3f58bce52..ac70a1e23977 100644
--- a/comms/trustedqsl/files/patch-cmakemodules_FindBDB.cmake
+++ b/comms/trustedqsl/files/patch-cmakemodules_FindBDB.cmake
@@ -1,18 +1,18 @@
---- cmakemodules/FindBDB.cmake.orig 2013-06-23 17:20:25.000000000 -0700
-+++ cmakemodules/FindBDB.cmake 2013-06-23 17:24:59.000000000 -0700
-@@ -4,6 +4,7 @@
- if(APPLE) #exclude obsolete default OSX db
+--- cmakemodules/FindBDB.cmake.orig 2013-10-20 19:33:20.000000000 -0500
++++ cmakemodules/FindBDB.cmake 2013-12-07 20:44:12.000000000 -0500
+@@ -5,6 +5,7 @@
FIND_PATH(BDB_INCLUDE_DIR db.h NO_DEFAULT_PATH PATHS
+ "/usr/local/BerkeleyDB.6.0/include"
"/usr/local/BerkeleyDB.5.3/include"
+ "/usr/local/include/db5"
"${BDB_PREFIX}/include"
)
else()
-@@ -26,6 +27,7 @@
- "C:\\db-5.3.21\\build_windows\\Win32\\Static_Release\\" #vc08 adds underscore
+@@ -37,6 +38,7 @@
#OSX (and probably other unix) src build
+ "/usr/local/BerkeleyDB.6.0/lib"
"/usr/local/BerkeleyDB.5.3/lib"
+ "/usr/local/lib/db5"
"${BDB_PREFIX}/lib"
+ "${BDB_PREFIX}"
)
- MARK_AS_ADVANCED(BDB_LIBRARY)
diff --git a/comms/trustedqsl/files/patch-src_tqslconvert.cpp b/comms/trustedqsl/files/patch-src_tqslconvert.cpp
index c29ed5624807..204a8fb1bf20 100644
--- a/comms/trustedqsl/files/patch-src_tqslconvert.cpp
+++ b/comms/trustedqsl/files/patch-src_tqslconvert.cpp
@@ -1,6 +1,6 @@
---- src/tqslconvert.cpp.orig 2013-06-23 17:30:50.000000000 -0700
-+++ src/tqslconvert.cpp 2013-06-23 17:31:00.000000000 -0700
-@@ -22,7 +22,7 @@
+--- src/tqslconvert.cpp.orig 2013-10-20 19:33:20.000000000 -0500
++++ src/tqslconvert.cpp 2013-12-07 20:54:11.000000000 -0500
+@@ -23,7 +23,7 @@
#include <vector>
#include <ctype.h>
#include <set>
diff --git a/comms/trustedqsl/files/patch-src_xml.h b/comms/trustedqsl/files/patch-src_xml.h
new file mode 100644
index 000000000000..d0351a94bb16
--- /dev/null
+++ b/comms/trustedqsl/files/patch-src_xml.h
@@ -0,0 +1,17 @@
+--- src/xml.h.orig 2013-12-12 13:03:46.814700681 -0500
++++ src/xml.h 2013-12-12 13:04:09.019718129 -0500
+@@ -108,12 +108,13 @@
+ XMLElementAttributeList _attributes;
+ XMLElementList _elements;
+ std::vector<XMLElementList::iterator> _parsingStack;
+- XMLElementList::iterator _iter;
+ bool _iterByName;
+ std::string _iterName;
+ XMLElementAttributeList::iterator _aiter;
+ };
+
++static XMLElementList::iterator _iter;
++
+ inline void XMLElement::clear() {
+ _name = _text = _pretext = _iterName = "";
+ _attributes.clear();
diff --git a/comms/trustedqsl/files/pkg-message b/comms/trustedqsl/files/pkg-message
new file mode 100644
index 000000000000..3b91c7e29e88
--- /dev/null
+++ b/comms/trustedqsl/files/pkg-message
@@ -0,0 +1,3 @@
+trustedqsl is now installed. You will have to create a directory .tqsl in
+your home directory and setup a copy of %%PREFIX%%/share/TrustedQSL/config.xml
+here before this program will run correctly.