aboutsummaryrefslogtreecommitdiff
path: root/comms/unixcw/Makefile
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:26:03 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:26:03 +0000
commit114e81674c93819f439195119fd58bcc82f44b6e (patch)
tree9bf0acfd33163de27b5ddc9457015a453290264d /comms/unixcw/Makefile
parentdaff9e5beb1fc0ef39436139177aeaf8498a1698 (diff)
downloadports-114e81674c93819f439195119fd58bcc82f44b6e.tar.gz
ports-114e81674c93819f439195119fd58bcc82f44b6e.zip
Update to 3.4.0 (build system fixes)
Remove XCWCP option and prepare this to be a master port instead. Otherwise there's no way to support xcwcp using pkg without making QT a dependency of comms/cwdaemon.
Notes
Notes: svn path=/head/; revision=374590
Diffstat (limited to 'comms/unixcw/Makefile')
-rw-r--r--comms/unixcw/Makefile36
1 files changed, 13 insertions, 23 deletions
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index 470526c96134..480095822025 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -1,43 +1,33 @@
# $FreeBSD$
+# NOTE: comms/xcwcp is a sub-port of this. When making changes, ensure
+# it still works as well.
+
PORTNAME= unixcw
-PORTVERSION= 3.3.0
-PORTREVISION= 1
-CATEGORIES= comms hamradio
+PORTVERSION= 3.4.0
+CATEGORIES?= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-DISTNAME= unixcw_3.3.0.orig
+DISTNAME= unixcw_${PORTVERSION}.orig
MAINTAINER= hamradio@FreeBSD.org
-COMMENT= Libs for cw on unix
+COMMENT?= Libs for cw on unix
LICENSE= GPLv2
GNU_CONFIGURE= yes
+.ifndef CONFIGURE_ARGS
+CONFIGURE_ARGS= --disable-xcwcp
+.endif
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
--disable-alsa --disable-pulseaudio
-.if defined(WITH_XCWCP)
-USE_QT4= gui moc_build qmake_build rcc_build uic_build designer
-USE_AUTOTOOLS= autoconf
-PLIST_SUB+= XCWCP=""
-CONFIGURE_ARGS+= --enable-xcwcp
-.else
-PLIST_SUB+= XCWCP="@comment "
-CONFIGURE_ARGS+= --disable-xcwcp
-.endif
USE_LDCONFIG= yes
-USES= gmake libtool
+USES= gmake libtool pkgconfig
USE_CSTD= gnu99
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-pre-extract:
-.if !defined(WITH_XCWCP)
- @${ECHO_CMD}
- @${ECHO_CMD} "****** To build xcwcp, interrupt the build ******"
- @${ECHO_CMD} "****** now, set WITH_XCWCP and start again. ******"
- @${ECHO_CMD}
- @sleep 3
-.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcw.so.6.2.1
.include <bsd.port.mk>