aboutsummaryrefslogtreecommitdiff
path: root/comms/xastir/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-05 20:15:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-05 20:15:24 +0000
commit65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb (patch)
tree2d8c9fae32b08d7069d3c481c5f7992d1b9818b6 /comms/xastir/Makefile
parent52712e9bc86eee6edb3d0c17f8ad50e6af465176 (diff)
downloadports-65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb.tar.gz
ports-65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb.zip
Add xastir, a hamradio orientated GIS package designed to handle APRS.
APRS is Amateur Position Reporting System. It's a system for handling real time information across radio and internet links. PR: ports/68655 Submitted by: Carl Makin <carl@stagecraft.cx>
Notes
Notes: svn path=/head/; revision=112993
Diffstat (limited to 'comms/xastir/Makefile')
-rw-r--r--comms/xastir/Makefile107
1 files changed, 107 insertions, 0 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
new file mode 100644
index 000000000000..c29153fa1418
--- /dev/null
+++ b/comms/xastir/Makefile
@@ -0,0 +1,107 @@
+# New ports collection makefile for: xastir
+# Date created: 17th June 2004
+# Whom: Carl Makin <carl@stagecraft.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xastir
+PORTVERSION= 1.3.2
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xastir
+
+MAINTAINER= carl@stagecraft.cx
+COMMENT= X Amateur Station Tracking and Information Reporting
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+
+MAN1= xastir.1
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+OPTIONS= SHAPELIB "Include Shapelib support" On \
+ PCRE "Include Perl Compatible Regular Expression Support" On \
+ DBFAWK "Include DBFAWK Support" On \
+ MAGICK "Include ImageMagick Support" On \
+ CURL "Include CURL Internet Image support" On \
+ GDAL "Include GDAL Support" Off \
+ GPSMAN "Include GPSMAN Support" Off \
+ FESTIVAL "Include Festival Voice Synthesis Support" Off \
+ OPTCFLAGS "Use optimized CFLAGS (-O2 -pipe)" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FESTIVAL)
+RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival
+.else
+CONFIGURE_ARGS+= --without-festival
+.endif
+
+.if defined(WITH_GPSMAN)
+RUN_DEPENDS+= gpsman:${PORTSDIR}/astro/gpsman
+WITH_SHAPELIB= true
+.undef WITHOUT_SHAPELIB
+.else
+CONFIGURE_ARGS+= --without-gpsman
+.endif
+
+.if defined(WITHOUT_SHAPELIB)
+CONFIGURE_ARGS+= --without-shapelib
+.else
+LIB_DEPENDS+= shp.1:${PORTSDIR}/devel/shapelib
+.endif
+
+.if defined(WITHOUT_MAGICK)
+CONFIGURE_ARGS+= --without-imagemagick
+.else
+LIB_DEPENDS+= Magick:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+.if defined(WITHOUT_DBFAWK)
+CONFIGURE_ARGS+= --without-dbfawk
+WITH_PCRE= true
+.undef WITHOUT_PCRE
+.endif
+
+.if defined(WITHOUT_PCRE)
+CONFIGURE_ARGS+= --without-pcre
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+.endif
+
+.if defined(WITH_GDAL)
+LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
+.else
+CONFIGURE_ARGS+= --without-gdal
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+WITH_OPTCFLAGS= true
+.endif
+
+# OPTIMIZED_CFLAGS is too big for the OPTIONS variable to draw on the screen.
+.if defined(WITH_OPTCFLAGS)
+CFLAGS+= -O2 -pipe
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>