aboutsummaryrefslogtreecommitdiff
path: root/comms/xastir/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-07-19 14:30:23 +0000
committerSteve Wills <swills@FreeBSD.org>2019-07-19 14:30:23 +0000
commit8c0c7720eeacf3012783be6303a587477d60aa61 (patch)
treeef408f89e82a022ef0c797b623bf3f826b0da470 /comms/xastir/Makefile
parent6f0bcb485c49a59e82cf33413dc1f4ec7e22fa69 (diff)
downloadports-8c0c7720eeacf3012783be6303a587477d60aa61.tar.gz
ports-8c0c7720eeacf3012783be6303a587477d60aa61.zip
comms/xastir: put back ImageMagick/GraphicsMagick choice
While here, improve formatting PR: 239217 Submitted by: carl@stagecraft.cx (maintainer)
Notes
Notes: svn path=/head/; revision=506937
Diffstat (limited to 'comms/xastir/Makefile')
-rw-r--r--comms/xastir/Makefile51
1 files changed, 30 insertions, 21 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 494ad2f9c837..13a1ad49c066 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -4,6 +4,7 @@
PORTNAME= xastir
DISTVERSIONPREFIX= Release-
DISTVERSION= 2.1.4
+PORTREVISION= 1
CATEGORIES= comms hamradio
MAINTAINER= carl@stagecraft.cx
@@ -14,21 +15,23 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= xfontsel:x11-fonts/xfontsel
RUN_DEPENDS= wget:ftp/wget
-LIB_DEPENDS= libtiff.so:graphics/tiff \
- libpng.so:graphics/png \
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libjasper.so:graphics/jasper \
libjbig.so:graphics/jbigkit \
+ liblcms2.so:graphics/lcms2 \
+ libpng.so:graphics/png \
+ libshp.so:devel/shapelib \
+ libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
libwebpmux.so:graphics/webp \
- liblcms2.so:graphics/lcms2 \
- libfreetype.so:print/freetype2 \
- libjasper.so:graphics/jasper \
- libwmflite.so:graphics/libwmf \
- libshp.so:devel/shapelib
+ libwmflite.so:graphics/libwmf
-GNU_CONFIGURE= yes
USES= gettext gmake jpeg motif python:run shebangfix
-USE_XORG= x11 xt xext sm ice
+
+USE_XORG= ice sm x11 xext xt
USE_GNOME+= libxml2
+GNU_CONFIGURE= yes
+
SHEBANG_FILES= scripts/gpx2shape
SHEBANG_REGEX= ./scripts/.*\.(sh|pl|py)
@@ -38,27 +41,32 @@ GH_PROJECT= Xastir
SUB_FILES= pkg-message
-OPTIONS_DEFINE= DAVIS DBFAWK MAGICK CURL GEOTIFF GPSMAN FESTIVAL \
- RTREE ERRORPOP BDB
+OPTIONS_DEFINE= BDB CURL DAVIS DBFAWK ERRORPOP FESTIVAL GEOTIFF GPSMAN
+OPTIONS_RADIO= MGG
+OPTIONS_RADIO_MGG= GMAGICK IMAGICK
DAVIS_DESC= Include Davis Weatherstation Support
DBFAWK_DESC= Include DBFAWK Support
-MAGICK_DESC= Include GraphicsMagick Support
CURL_DESC= Include CURL Internet Image support
GEOTIFF_DESC= Include GeoTIFF Support
GPSMAN_DESC= Include GPSMAN Support
FESTIVAL_DESC= Include Festival Voice Synthesis Support
-RTREE_DESC= Enable spatial indexing of shapefiles
ERRORPOP_DESC= Send error popups to stderr
BDB_DESC= Tiger Map Caching using Berkeley DB
+MGG_DESC= Image library for raster map processing
+IMAGICK_DESC= ImageMagick (Version 6)
+GMAGICK_DESC= GraphicsMagick (Needs GCC to compile)
-OPTIONS_DEFAULT= DBFAWK MAGICK CURL RTREE BDB
+OPTIONS_DEFAULT= BDB CURL DBFAWK GMAGICK
DAVIS_CONFIGURE_ON= --enable-davis
-MAGICK_LIB_DEPENDS= libGraphicsMagickWand.so:graphics/GraphicsMagick
-MAGICK_CONFIGURE_WITH= graphicsmagick
-MAGICK_USES= compiler:gcc-c++11-lib
+IMAGICK_LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick6
+IMAGICK_CONFIGURE_WITH= imagemagick
+
+GMAGICK_LIB_DEPENDS= libGraphicsMagickWand.so:graphics/GraphicsMagick
+GMAGICK_CONFIGURE_WITH= graphicsmagick
+GMAGICK_USES= compiler:gcc-c++11-lib
DBFAWK_LIB_DEPENDS= libpcre.so:devel/pcre
DBFAWK_CONFIGURE_WITH= dbfawk
@@ -71,14 +79,15 @@ GPSMAN_BUILD_DEPENDS= ${LOCALBASE}/share/doc/gpsmanshp/GPSManSHP.pdf:graphics/gp
GPSMAN_IMPLIES= SHAPELIB
GPSMAN_CONFIGURE_WITH= gpsman
-FESTIVAL_BUILD_DEPENDS= festival:audio/festival
-FESTIVAL_CONFIGURE_WITH=festival
+FESTIVAL_BUILD_DEPENDS= festival:audio/festival
+FESTIVAL_CONFIGURE_WITH= festival
-RTREE_CONFIGURE_WITH= rtree
+#RTREE_CONFIGURE_WITH= rtree
ERRORPOP_CONFIGURE_WITH= errorpopups
BDB_USES= bdb
-BDB_CONFIGURE_ON= --with-bdb-incdir=${BDB_INCLUDE_DIR} --with-bdb-libdir=${BDB_LIB_DIR}
+BDB_CONFIGURE_ON= --with-bdb-incdir=${BDB_INCLUDE_DIR} \
+ --with-bdb-libdir=${BDB_LIB_DIR}
.include <bsd.port.mk>