aboutsummaryrefslogtreecommitdiff
path: root/comms/xmorse
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-17 14:53:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-17 14:53:38 +0000
commitc12182e1908405538f95c683116b7dc2a3b546c0 (patch)
tree2922e3d92f7abe2081d01f611712b41a7f07ed87 /comms/xmorse
parent2e3ed2030047d892412d4516ac6c2beda450ac6c (diff)
downloadports-c12182e1908405538f95c683116b7dc2a3b546c0.tar.gz
ports-c12182e1908405538f95c683116b7dc2a3b546c0.zip
A fully automatic Morse code teaching machine. Teaches you to receive
Morse code. It starts with a few letters and adds more when it sees that you are ready. The program won't teach you to send code. It runs in X Window. Built with the Fast Light ToolKit(fltk) and the Simple Directmedia Layer(SDL). It need to be compiled on X Window term for the reason fluid(fltk) need to. WWW: http://c2.com/morse PR: ports/118235 Submitted by: Sunry Chen <sunrychen@gmail.com>
Notes
Notes: svn path=/head/; revision=203923
Diffstat (limited to 'comms/xmorse')
-rw-r--r--comms/xmorse/Makefile29
-rw-r--r--comms/xmorse/distinfo3
-rw-r--r--comms/xmorse/files/patch-Makefile28
-rw-r--r--comms/xmorse/pkg-descr8
4 files changed, 68 insertions, 0 deletions
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
new file mode 100644
index 000000000000..f768a351b599
--- /dev/null
+++ b/comms/xmorse/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xmorse
+# Date created: 24 Novermber 2007
+# Whom: Sunry Chen <sunrychen@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmorse
+PORTVERSION= 20041125
+CATEGORIES= comms hamradio
+MASTER_SITES= http://c2.com/morse/files/SourceCode/ \
+ http://www.525183.com/freebsd/xmorse/ \
+ http://www.chinatinco.com/freebsd/xmorse/ \
+ http://525183.serverbox.org/freebsd/xmorse/
+DISTNAME= m${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sunrychen@gmail.com
+COMMENT= A fully automatic Morse code teaching machine
+
+BUILD_DEPENDS= fluid:${PORTSDIR}/x11-toolkits/fltk
+
+USE_DISPLAY= yes
+USE_SDL= sdl
+
+PLIST_FILES= bin/xmorse
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/comms/xmorse/distinfo b/comms/xmorse/distinfo
new file mode 100644
index 000000000000..c9261217794b
--- /dev/null
+++ b/comms/xmorse/distinfo
@@ -0,0 +1,3 @@
+MD5 (m20041125.tgz) = d2832b5bf8d840d0e14a831e7590a4ca
+SHA256 (m20041125.tgz) = 07c4ca001d3c3f931dce6ed7aec58d832fab81f15e3977ba0d61fcf8909e763d
+SIZE (m20041125.tgz) = 1050929
diff --git a/comms/xmorse/files/patch-Makefile b/comms/xmorse/files/patch-Makefile
new file mode 100644
index 000000000000..0ba313e35029
--- /dev/null
+++ b/comms/xmorse/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- ./Makefile.orig 2004-09-29 22:12:16.000000000 +0000
++++ ./Makefile 2007-11-24 19:55:15.000000000 +0000
+@@ -36,6 +36,25 @@
+ strip m
+ rm *.o m.cxx m.h
+
++# Regular "make" is what you want for the FreeBSD version
++
++all: m.fl Bargraph.cxx Bargraph.h Codebox.cxx Codebox.h Cw.cxx Cw.h \
++ Knob.cxx Knob.h Help.h m.fl
++ fluid -c m.fl
++ g++ -c -Os `fltk-config --cxxflags` m.cxx
++ g++ -c -Os `fltk-config --cxxflags` Bargraph.cxx
++ g++ -c -Os `fltk-config --cxxflags` Codebox.cxx
++ g++ -c -Os `fltk-config --cxxflags` Knob.cxx
++ g++ -c -Os `sdl-config --cflags` Cw.cxx
++ g++ -om m.o Bargraph.o Codebox.o Cw.o Knob.o \
++ `sdl-config --static-libs` \
++ `fltk-config --ldstaticflags`
++ strip m
++ rm *.o m.cxx m.h
++
++install: m
++ ${INSTALL} -o root -g wheel -m 0555 m ${PREFIX}/bin/xmorse
++
+ # Besemer's Python extension version
+
+ cw.so: cw.pyx Cw.cxx Cw.h
diff --git a/comms/xmorse/pkg-descr b/comms/xmorse/pkg-descr
new file mode 100644
index 000000000000..51c458084b97
--- /dev/null
+++ b/comms/xmorse/pkg-descr
@@ -0,0 +1,8 @@
+A fully automatic Morse code teaching machine. Teaches you to receive
+Morse code. It starts with a few letters and adds more when it sees that
+you are ready. The program won't teach you to send code. It runs in X Window.
+Built with the Fast Light ToolKit(fltk) and the Simple Directmedia Layer(SDL).
+
+It need to be compiled on X Window term for the reason fluid(fltk) need to.
+
+WWW: http://c2.com/morse