aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-12-29 20:29:46 +0000
committerChris Rees <crees@FreeBSD.org>2011-12-29 20:29:46 +0000
commit102b39889e4ed7a071747061467ed0ff19e2295c (patch)
tree45f90194c382c487e948ce942270065bc26ecb16 /comms
parent6bdabc70f3c50c2ed1289ebe6267183b887f53e2 (diff)
downloadports-102b39889e4ed7a071747061467ed0ff19e2295c.tar.gz
ports-102b39889e4ed7a071747061467ed0ff19e2295c.zip
This is a serial-over-lan (sol) client for Intel AMT. Includes a terminal and
a graphical (gtk) version. Also comes with a perl script to gather informations about and remotely control AMT managed computers. WWW: https://www.kraxel.org/blog/linux/amtterm/
Notes
Notes: svn path=/head/; revision=288252
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/amtterm/Makefile40
-rw-r--r--comms/amtterm/distinfo2
-rw-r--r--comms/amtterm/files/patch-redir-c30
-rw-r--r--comms/amtterm/pkg-descr5
5 files changed, 78 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index caf1c31436eb..ff3ed5bc0da5 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -5,6 +5,7 @@
SUBDIR += acfax
SUBDIR += aldo
+ SUBDIR += amtterm
SUBDIR += anyremote
SUBDIR += aprsd
SUBDIR += atslog
diff --git a/comms/amtterm/Makefile b/comms/amtterm/Makefile
new file mode 100644
index 000000000000..c637d199c655
--- /dev/null
+++ b/comms/amtterm/Makefile
@@ -0,0 +1,40 @@
+# Ports collection Makefile for: amtterm
+# Date created: 29 December 2011
+# Whom: crees
+#
+# $FreeBSD$
+#
+
+PORTNAME= amtterm
+PORTVERSION= 1.3
+CATEGORIES= comms
+MASTER_SITES= https://www.kraxel.org/releases/${PORTNAME}/
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Serial-over-lan client for Intel AMT
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+RUN_DEPENDS= p5-SOAP-Lite>=0.5:${PORTSDIR}/net/p5-SOAP-Lite
+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+MAKE_ENV+= mandir=${MANPREFIX}/man
+
+PLIST_FILES= bin/${PORTNAME} \
+ bin/amttool \
+ share/applications/gamt.desktop
+PLIST_DIRSTRY= share/applications
+MAN1= gamt.1 ${PORTNAME}.1 amttool.1
+MAN7= amt-howto.7
+MANCOMPRESSED= no
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/sbin/ldconfig -p,${LDCONFIG} -r,' \
+ ${WRKSRC}/mk/Autoconf.mk
+.for mandir in 1 7
+ @${REINPLACE_CMD} -e \
+ 's,$$(mandir)/man${mandir},${MAN${mandir}PREFIX}/man/man${mandir},' \
+ ${WRKSRC}/${MAKEFILE}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/comms/amtterm/distinfo b/comms/amtterm/distinfo
new file mode 100644
index 000000000000..d96b07654330
--- /dev/null
+++ b/comms/amtterm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (amtterm-1.3.tar.gz) = 769d02f087c7594e4a29a901580b2d39154db49ca1f3a6881598d0c595b9bc50
+SIZE (amtterm-1.3.tar.gz) = 37671
diff --git a/comms/amtterm/files/patch-redir-c b/comms/amtterm/files/patch-redir-c
new file mode 100644
index 000000000000..057ce3cf63a3
--- /dev/null
+++ b/comms/amtterm/files/patch-redir-c
@@ -0,0 +1,30 @@
+$FreeBSD$
+
+From http://people.freebsd.org/~kib/misc/amtterm.1.patch
+
+--- redir.c 2011-05-26 12:19:45.000000000 +0300
++++ redir.c 2011-12-28 22:39:15.164012594 +0200
+@@ -18,6 +18,10 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+--- tcp.c 2011-05-26 12:19:45.000000000 +0300
++++ tcp.c 2011-12-28 22:39:32.276853072 +0200
+@@ -18,6 +18,10 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
diff --git a/comms/amtterm/pkg-descr b/comms/amtterm/pkg-descr
new file mode 100644
index 000000000000..00bb1fd5bc76
--- /dev/null
+++ b/comms/amtterm/pkg-descr
@@ -0,0 +1,5 @@
+This is a serial-over-lan (sol) client for Intel AMT. Includes a terminal and
+a graphical (gtk) version. Also comes with a perl script to gather
+informations about and remotely control AMT managed computers.
+
+WWW: https://www.kraxel.org/blog/linux/amtterm/