aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2018-12-22 05:27:32 +0000
committerFukang Chen <loader@FreeBSD.org>2018-12-22 05:27:32 +0000
commit20695b64ab42354dc46c0113515721f513f5449b (patch)
tree320f2e368bcdc2aaddd47b8db29b7fa30b3ee568 /comms
parent1d725ae19663dc24dedbe6b708cbf5069d685b12 (diff)
downloadports-20695b64ab42354dc46c0113515721f513f5449b.tar.gz
ports-20695b64ab42354dc46c0113515721f513f5449b.zip
[NEW PORT]: comms/py-xmodem: XMODEM protocol implementation
Python XMODEM protocol implementation This is a literal implementation of XMODEM.TXT, XMODEM1K.TXT and XMODMCRC.TXT, support for YMODEM and ZMODEM is pending. YMODEM should be fairly easy to implement as it is a hack on top of the XMODEM protocol using sequence bytes ``0x00`` for sending file names (and some meta data). WWW: https://github.com/tehmaze/xmodem Reviewed by: koobs Approved by: koobs (mentor) Differential Revision: https://reviews.freebsd.org/D18626
Notes
Notes: svn path=/head/; revision=488066
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-xmodem/Makefile31
-rw-r--r--comms/py-xmodem/distinfo3
-rw-r--r--comms/py-xmodem/pkg-descr9
4 files changed, 44 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index f9770d2be857..8aa7b87ffadf 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -140,6 +140,7 @@
SUBDIR += py-lirc
SUBDIR += py-qt5-serialport
SUBDIR += py-serial
+ SUBDIR += py-xmodem
SUBDIR += pyla
SUBDIR += qico
SUBDIR += qpage
diff --git a/comms/py-xmodem/Makefile b/comms/py-xmodem/Makefile
new file mode 100644
index 000000000000..c3fbd6ab16dd
--- /dev/null
+++ b/comms/py-xmodem/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xmodem
+DISTVERSION= 0.4.5
+CATEGORIES= comms python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= XMODEM protocol implementation
+
+LICENSE= MIT
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR} \
+ lrz:comms/lrzsz
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= tehmaze
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|'doc'|'${DOCSDIR}'|" ${WRKSRC}/setup.py
+
+do-test:
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/comms/py-xmodem/distinfo b/comms/py-xmodem/distinfo
new file mode 100644
index 000000000000..5434cc683585
--- /dev/null
+++ b/comms/py-xmodem/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543230345
+SHA256 (tehmaze-xmodem-0.4.5_GH0.tar.gz) = 5d6d760b5afdd6b4e7c1613b93792b12360ec2f911e2333ab9eda2d49231bcf0
+SIZE (tehmaze-xmodem-0.4.5_GH0.tar.gz) = 38003
diff --git a/comms/py-xmodem/pkg-descr b/comms/py-xmodem/pkg-descr
new file mode 100644
index 000000000000..19746bcbc163
--- /dev/null
+++ b/comms/py-xmodem/pkg-descr
@@ -0,0 +1,9 @@
+Python XMODEM protocol implementation
+
+This is a literal implementation of XMODEM.TXT, XMODEM1K.TXT and
+XMODMCRC.TXT, support for YMODEM and ZMODEM is pending. YMODEM should
+be fairly easy to implement as it is a hack on top of the XMODEM
+protocol using sequence bytes ``0x00`` for sending file names (and some
+meta data).
+
+WWW: https://github.com/tehmaze/xmodem