aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2019-01-16 09:26:04 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2019-01-16 09:26:04 +0000
commit2a95f214779b0bce602d0ab9ed27378774da7c37 (patch)
treeb68134291fcb398119c1a2276983b63529048c35 /comms
parentf2f53c4aead7ca2acc5c8bee77a30162a687aad9 (diff)
downloadports-2a95f214779b0bce602d0ab9ed27378774da7c37.tar.gz
ports-2a95f214779b0bce602d0ab9ed27378774da7c37.zip
comms/ncid: update 1.6 to 1.10
Makefile - adopt the port; stage-qa; check-plist; OK - LIB_DEPENDS: add devel/pcre - DOCS: now ships doc/*.md, plus README.FreeBSD - redo install stage for extensions, modules and samples; - add comment regarding already stripped binaries. pkg-plist - reflect new installed files to pkg-plist; -reorg DOCS and LOGROTATE https://sf.net/projects/ncid/files/ncid/1.10/README.md Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D18590
Notes
Notes: svn path=/head/; revision=490459
Diffstat (limited to 'comms')
-rw-r--r--comms/ncid/Makefile48
-rw-r--r--comms/ncid/distinfo6
-rw-r--r--comms/ncid/pkg-plist131
3 files changed, 122 insertions, 63 deletions
diff --git a/comms/ncid/Makefile b/comms/ncid/Makefile
index 77d1e163d110..1d5f27a71328 100644
--- a/comms/ncid/Makefile
+++ b/comms/ncid/Makefile
@@ -2,28 +2,30 @@
# $FreeBSD$
PORTNAME= ncid
-PORTVERSION= 1.6
+PORTVERSION= 1.10
CATEGORIES= comms
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@FreeBSD.org
COMMENT= Network based Caller ID package
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/doc/GPL.md
-BUILD_DEPENDS= bash:shells/bash
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= libpcre.so:devel/pcre
RUN_DEPENDS= bash:shells/bash
USES= gmake perl5 tk shebangfix
+
SHEBANG_FILES= extensions/*.sh \
- gateway/*.pl \
- gateway/*.sh \
+ gateway/*.pl gateway/*.sh \
logrotate/*.sh \
modules/*.sh \
setup/*.sh \
- tools/*.pl
+ tools/*.pl tools/*.sh
+
ALL_TARGET= local
MAKE_ARGS= WISH=${WISH} TCLSH=${TCLSH}
INSTALL_TARGET= freebsd-install
@@ -39,8 +41,6 @@ LOGROTATE_RUN_DEPENDS= logrotate:sysutils/logrotate
WRKSRC= ${WRKDIR}/${PORTNAME}
-PORTDOCS= CHANGES Clients.md Gateways.md Log.md Tools.md ReleaseNotes.md
-
post-extract:
@cd ${WRKSRC}/FreeBSD;for i in *.rc; do \
x=`echo $$i | cut -f 1 -d .`; ${CP} $$i $$x; done
@@ -72,47 +72,47 @@ do-install:
.for d in ncidd.alias ncidd.conf ncidd.blacklist ncidd.whitelist
${INSTALL_DATA} ${WRKSRC}/server/${d} ${STAGEDIR}${ETCDIR}/${d}.sample
.endfor
-.for e in hangup-calls hangup-closed-skel hangup-message-skel hangup-skel
+.for e in hangup-calls hangup-fakenum hangup-fcc hangup-nohangup \
+hangup-closed-skel hangup-combo-skel hangup-message-skel hangup-skel
@${MKDIR} ${STAGEDIR}${PREFIX}/share/ncid/extensions
${INSTALL_SCRIPT} ${WRKSRC}/extensions/${e} ${STAGEDIR}${PREFIX}/share/ncid/extensions
.endfor
-.for f in email2ncid obi2ncid rn2ncid yac2ncid wc2ncid
+# ncid2ncid and sip2ncid are installed and stripped before this loop with ${INSTALL_PROGRAM}
+.for f in email2ncid obi2ncid rn2ncid wc2ncid xdmf2ncid yac2ncid
${INSTALL_SCRIPT} ${WRKSRC}/gateway/${f} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/gateway/${f}.conf ${STAGEDIR}${ETCDIR}/${f}.conf.sample
.endfor
${INSTALL_DATA} ${WRKSRC}/client/ncid.gif ${STAGEDIR}${PREFIX}/share/pixmaps/ncid
@${MKDIR} ${STAGEDIR}${PREFIX}/share/ncid/modules
-.for g in ncid-page ncid-samba ncid-speak ncid-mythtv ncid-kpopup ncid-skel \
-ncid-alert ncid-yac ncid-initmodem ncid-notify ncid-wakeup
+.for g in ncid-alert ncid-initmodem ncid-kpopup ncid-mysql ncid-mythtv ncid-notify ncid-page \
+ncid-samba ncid-skel ncid-speak ncid-wakeup ncid-yac
${INSTALL_SCRIPT} ${WRKSRC}/modules/${g} ${STAGEDIR}${PREFIX}/share/ncid/modules
.endfor
${INSTALL_DATA} ${WRKSRC}/server/ncidd.alias ${STAGEDIR}${ETCDIR}/ncidd.alias.sample
.for h in cidcall cidalias cidupdate wct ncidutil
${INSTALL_SCRIPT} ${WRKSRC}/tools/${h} ${STAGEDIR}${PREFIX}/bin
.endfor
-.for i in ncidd ncid2ncid obi2ncid rn2ncid sip2ncid wc2ncid yac2ncid ncid-mythtv ncid-notify \
-ncid-page ncid-samba ncid-speak ncid-yac ncid-initmodem
+.for i in ncid-initmodem ncid-mysql ncid-mythtv ncid-notify ncid-page ncid-samba ncid-speak ncid-yac \
+ncid2ncid ncidd obi2ncid rn2ncid sip2ncid wc2ncid xdmf2ncid yac2ncid
${INSTALL_DATA} ${WRKSRC}/FreeBSD/${i} ${STAGEDIR}${PREFIX}/etc/rc.d
.endfor
-.for j in NumberDisconnected.rmd CallingDeposit.rmd NotInService.rmd
+.for j in CallingDeposit.rmd CannotBeCompleted.rmd DisconnectedNotInService.rmd NotInService.rmd
@${MKDIR} ${STAGEDIR}${PREFIX}/share/ncid/recordings
${INSTALL_DATA} ${WRKSRC}/recordings/${j} ${STAGEDIR}${PREFIX}/share/ncid/recordings
.endfor
-.for k in ncid-email2ncid-setup ncid-mysql-setup
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/ncid/setup
- ${INSTALL_SCRIPT} ${WRKSRC}/setup/ncid-setup ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/setup/${k} ${STAGEDIR}${PREFIX}/share/ncid/setup
+.for k in ncid-email2ncid-setup ncid-mysql-setup ncid-setup
+ ${INSTALL_SCRIPT} ${WRKSRC}/setup/${k} ${STAGEDIR}${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/man/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/*.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/man/*.7 ${STAGEDIR}${MAN7PREFIX}/man/man7
${INSTALL_MAN} ${WRKSRC}/man/*.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+
do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
- "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/recordings
-.for l in README.recordings NumberDisconnected.pvf CallingDeposit.pvf NotInService.pvf
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/recordings
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.md ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FreeBSD/README.FreeBSD ${STAGEDIR}${DOCSDIR}
+.for l in README.recordings CallingDeposit.pvf CannotBeCompleted.pvf DisconnectedNotInService.pvf NotInService.pvf
${INSTALL_DATA} ${WRKSRC}/recordings/${l} ${STAGEDIR}${DOCSDIR}/recordings
.endfor
diff --git a/comms/ncid/distinfo b/comms/ncid/distinfo
index 569ca6a1cd8d..60346266fdf3 100644
--- a/comms/ncid/distinfo
+++ b/comms/ncid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482762108
-SHA256 (ncid-1.6-src.tar.gz) = 9e1917252cae16d82f1e4b641994447b2f57d5fef7de7f8918082913a13104f4
-SIZE (ncid-1.6-src.tar.gz) = 3170106
+TIMESTAMP = 1545043056
+SHA256 (ncid-1.10-src.tar.gz) = 4f090128eaf0e00b9fde78955f9ea17ec31fcdf8de3dfb7a16a1e0ca6b1f11c4
+SIZE (ncid-1.10-src.tar.gz) = 3650377
diff --git a/comms/ncid/pkg-plist b/comms/ncid/pkg-plist
index e6c13ea68bca..e0682691477c 100644
--- a/comms/ncid/pkg-plist
+++ b/comms/ncid/pkg-plist
@@ -3,47 +3,20 @@ bin/cidcall
bin/cidupdate
bin/email2ncid
bin/ncid
+bin/ncid-email2ncid-setup
+bin/ncid-mysql-setup
+bin/ncid-setup
bin/ncid2ncid
bin/ncidutil
-bin/ncid-setup
bin/obi2ncid
bin/rn2ncid
bin/wc2ncid
bin/wct
+bin/xdmf2ncid
bin/yac2ncid
-%%DATADIR%%/extensions/hangup-calls
-%%DATADIR%%/extensions/hangup-closed-skel
-%%DATADIR%%/extensions/hangup-message-skel
-%%DATADIR%%/extensions/hangup-skel
-%%DATADIR%%/modules/ncid-alert
-%%DATADIR%%/modules/ncid-initmodem
-%%DATADIR%%/modules/ncid-kpopup
-%%DATADIR%%/modules/ncid-mythtv
-%%DATADIR%%/modules/ncid-notify
-%%DATADIR%%/modules/ncid-page
-%%DATADIR%%/modules/ncid-samba
-%%DATADIR%%/modules/ncid-skel
-%%DATADIR%%/modules/ncid-speak
-%%DATADIR%%/modules/ncid-wakeup
-%%DATADIR%%/modules/ncid-yac
-%%DATADIR%%/recordings/CallingDeposit.rmd
-%%DATADIR%%/recordings/NotInService.rmd
-%%DATADIR%%/recordings/NumberDisconnected.rmd
-%%DATADIR%%/setup/ncid-email2ncid-setup
-%%DATADIR%%/setup/ncid-mysql-setup
-%%LOGROTATE%%%%DATADIR%%/sys/ncid-yearlog
-%%LOGROTATE%%%%DATADIR%%/sys/ncidrotate
-%%LOGROTATE%%%%ETCDIR%%/ncidrotate.conf.sample
-%%LOGROTATE%%etc/logrotate.d/ncid
-%%LOGROTATE%%man/man1/ncidrotate.1.gz
-%%LOGROTATE%%man/man5/ncidrotate.conf.5.gz
-%%PORTDOCS%%%%DOCSDIR%%/recordings/CallingDeposit.pvf
-%%PORTDOCS%%%%DOCSDIR%%/recordings/NotInService.pvf
-%%PORTDOCS%%%%DOCSDIR%%/recordings/NumberDisconnected.pvf
-%%PORTDOCS%%%%DOCSDIR%%/recordings/README.recordings
@sample %%ETCDIR%%/email2ncid.conf.sample
-@sample %%ETCDIR%%/ncid2ncid.conf.sample
@sample %%ETCDIR%%/ncid.conf.sample
+@sample %%ETCDIR%%/ncid2ncid.conf.sample
@sample %%ETCDIR%%/ncidd.alias.sample
@sample %%ETCDIR%%/ncidd.blacklist.sample
@sample %%ETCDIR%%/ncidd.conf.sample
@@ -52,8 +25,10 @@ bin/yac2ncid
@sample %%ETCDIR%%/rn2ncid.conf.sample
@sample %%ETCDIR%%/sip2ncid.conf.sample
@sample %%ETCDIR%%/wc2ncid.conf.sample
+@sample %%ETCDIR%%/xdmf2ncid.conf.sample
@sample %%ETCDIR%%/yac2ncid.conf.sample
etc/rc.d/ncid-initmodem
+etc/rc.d/ncid-mysql
etc/rc.d/ncid-mythtv
etc/rc.d/ncid-notify
etc/rc.d/ncid-page
@@ -66,14 +41,20 @@ etc/rc.d/obi2ncid
etc/rc.d/rn2ncid
etc/rc.d/sip2ncid
etc/rc.d/wc2ncid
+etc/rc.d/xdmf2ncid
etc/rc.d/yac2ncid
man/man1/cidalias.1.gz
man/man1/cidcall.1.gz
man/man1/cidupdate.1.gz
man/man1/email2ncid.1.gz
+man/man1/get-fcc-list.1.gz
man/man1/hangup-calls.1.gz
man/man1/hangup-closed-skel.1.gz
+man/man1/hangup-combo-skel.1.gz
+man/man1/hangup-fakenum.1.gz
+man/man1/hangup-fcc.1.gz
man/man1/hangup-message-skel.1.gz
+man/man1/hangup-nohangup.1.gz
man/man1/hangup-skel.1.gz
man/man1/ncid-alert.1.gz
man/man1/ncid-email2ncid-setup.1.gz
@@ -92,11 +73,13 @@ man/man1/ncid-yac.1.gz
man/man1/ncid-yearlog.1.gz
man/man1/ncid.1.gz
man/man1/ncid2ncid.1.gz
+man/man1/ncidrotate.1.gz
man/man1/ncidutil.1.gz
man/man1/obi2ncid.1.gz
man/man1/rn2ncid.1.gz
man/man1/wc2ncid.1.gz
man/man1/wct.1.gz
+man/man1/xdmf2ncid.1.gz
man/man1/yac2ncid.1.gz
man/man5/email2ncid.conf.5.gz
man/man5/ncid.conf.5.gz
@@ -105,17 +88,93 @@ man/man5/ncidd.alias.5.gz
man/man5/ncidd.blacklist.5.gz
man/man5/ncidd.conf.5.gz
man/man5/ncidd.whitelist.5.gz
+man/man5/ncidrotate.conf.5.gz
man/man5/obi2ncid.conf.5.gz
man/man5/rn2ncid.conf.5.gz
+man/man5/rotatebysize.conf.5.gz
man/man5/sip2ncid.conf.5.gz
man/man5/wc2ncid.conf.5.gz
+man/man5/xdmf2ncid.conf.5.gz
man/man5/yac2ncid.conf.5.gz
-man/man7/ncid-modules.7.gz
-man/man7/ncidgateways.7.gz
-man/man7/ncidtools.7.gz
-man/man8/ncidd.8.gz
+man/man7/ncid_extensions.7.gz
+man/man7/ncid_gateways.7.gz
+man/man7/ncid_modules.7.gz
+man/man7/ncid_recordings.7.gz
+man/man7/ncid_tools.7.gz
man/man8/ncid-mysql-setup.8.gz
+man/man8/ncidd.8.gz
man/man8/sip2ncid.8.gz
sbin/ncidd
sbin/sip2ncid
+%%PORTDOCS%%%%DOCSDIR%%/Alias.md
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTORS.md
+%%PORTDOCS%%%%DOCSDIR%%/Clients.md
+%%PORTDOCS%%%%DOCSDIR%%/Devices.md
+%%PORTDOCS%%%%DOCSDIR%%/Extensions.md
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.md
+%%PORTDOCS%%%%DOCSDIR%%/FCCData.md
+%%PORTDOCS%%%%DOCSDIR%%/GPL.md
+%%PORTDOCS%%%%DOCSDIR%%/Gateways.md
+%%PORTDOCS%%%%DOCSDIR%%/GettingStarted.md
+%%PORTDOCS%%%%DOCSDIR%%/Hangup.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-Cygwin.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-DEB.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-Fedora.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-FreeBSD.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-Mac.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-Redhat.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-Win.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.md
+%%PORTDOCS%%%%DOCSDIR%%/InstallIndex.md
+%%PORTDOCS%%%%DOCSDIR%%/Log.md
+%%PORTDOCS%%%%DOCSDIR%%/Message.md
+%%PORTDOCS%%%%DOCSDIR%%/Modems.md
+%%PORTDOCS%%%%DOCSDIR%%/Modules.md
+%%PORTDOCS%%%%DOCSDIR%%/NCID-API.md
+%%PORTDOCS%%%%DOCSDIR%%/NCID-SDK.md
+%%PORTDOCS%%%%DOCSDIR%%/NCID-UserManual.md
+%%PORTDOCS%%%%DOCSDIR%%/Obtain.md
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%%%DOCSDIR%%/ReleaseNotes.md
+%%PORTDOCS%%%%DOCSDIR%%/TODO.md
+%%PORTDOCS%%%%DOCSDIR%%/Tools.md
+%%PORTDOCS%%%%DOCSDIR%%/Use.md
+%%PORTDOCS%%%%DOCSDIR%%/UserManualIndex.md
+%%PORTDOCS%%%%DOCSDIR%%/Verbose.md
+%%PORTDOCS%%%%DOCSDIR%%/recordings/CallingDeposit.pvf
+%%PORTDOCS%%%%DOCSDIR%%/recordings/CannotBeCompleted.pvf
+%%PORTDOCS%%%%DOCSDIR%%/recordings/DisconnectedNotInService.pvf
+%%PORTDOCS%%%%DOCSDIR%%/recordings/NotInService.pvf
+%%PORTDOCS%%%%DOCSDIR%%/recordings/README.recordings
+%%DATADIR%%/extensions/hangup-calls
+%%DATADIR%%/extensions/hangup-closed-skel
+%%DATADIR%%/extensions/hangup-combo-skel
+%%DATADIR%%/extensions/hangup-fakenum
+%%DATADIR%%/extensions/hangup-fcc
+%%DATADIR%%/extensions/hangup-message-skel
+%%DATADIR%%/extensions/hangup-nohangup
+%%DATADIR%%/extensions/hangup-skel
+%%DATADIR%%/modules/ncid-alert
+%%DATADIR%%/modules/ncid-initmodem
+%%DATADIR%%/modules/ncid-kpopup
+%%DATADIR%%/modules/ncid-mysql
+%%DATADIR%%/modules/ncid-mythtv
+%%DATADIR%%/modules/ncid-notify
+%%DATADIR%%/modules/ncid-page
+%%DATADIR%%/modules/ncid-samba
+%%DATADIR%%/modules/ncid-skel
+%%DATADIR%%/modules/ncid-speak
+%%DATADIR%%/modules/ncid-wakeup
+%%DATADIR%%/modules/ncid-yac
+%%DATADIR%%/recordings/CallingDeposit.rmd
+%%DATADIR%%/recordings/CannotBeCompleted.rmd
+%%DATADIR%%/recordings/DisconnectedNotInService.rmd
+%%DATADIR%%/recordings/NotInService.rmd
share/pixmaps/ncid
+%%LOGROTATE%%%%DATADIR%%/sys/ncid-yearlog
+%%LOGROTATE%%%%DATADIR%%/sys/ncidrotate
+%%LOGROTATE%%@sample %%ETCDIR%%/ncidrotate.conf.sample
+%%LOGROTATE%%etc/logrotate.d/ncid
+%%LOGROTATE%%man/man1/ncidrotate.1.gz
+%%LOGROTATE%%man/man5/ncidrotate.conf.5.gz
+%%LOGROTATE%%man/man5/rotatebysize.conf.5.gz