aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-03-27 18:09:24 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-03-27 18:09:24 +0000
commit3209efe9b022ae6b13606058dc2b10958578afa3 (patch)
treef41ee6127c75e14d7e542eaf5d226d03ec1cb817 /comms
parenta3c8dd4a53f1e33762f334ec282c2e15563c7725 (diff)
downloadports-3209efe9b022ae6b13606058dc2b10958578afa3.tar.gz
ports-3209efe9b022ae6b13606058dc2b10958578afa3.zip
- remove invalid post-deinstall target
- add pkg-deinstall file to account for desired functionality - bump PORTREVISION PR: ports/166057 Submitted by: jgh@ Approved by: maintainer timeout (15 days) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293891
Diffstat (limited to 'comms')
-rw-r--r--comms/umcs7840/Makefile6
-rw-r--r--comms/umcs7840/files/pkg-deinstall.in5
2 files changed, 8 insertions, 3 deletions
diff --git a/comms/umcs7840/Makefile b/comms/umcs7840/Makefile
index edf94cb22205..a27131311abf 100644
--- a/comms/umcs7840/Makefile
+++ b/comms/umcs7840/Makefile
@@ -7,6 +7,7 @@
PORTNAME= umcs7840
PORTVERSION= ${MAINVERSION}.${VERSIONDATE}
+PORTREVISION= 1
CATEGORIES= comms kld
MASTER_SITES= http://lev.serebryakov.spb.ru/download/umcs7840/
PKGNAMESUFFIX= -kmod
@@ -23,6 +24,8 @@ VERSIONDATE=20101210.57
KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR}
+SUB_LIST= KMODDIR=${KMODDIR}
+SUB_FILES= pkg-deinstall
MAKE_ENV+= KMODDIR=${KMODDIR}
MANCOMPRESSED= yes
@@ -39,7 +42,4 @@ IGNORE= requires FreeBSD 8.0 or later, please try driver from vendor site
post-install:
kldxref ${KMODDIR}
-post-deinstall:
- kldxref ${KMODDIR}
-
.include <bsd.port.post.mk>
diff --git a/comms/umcs7840/files/pkg-deinstall.in b/comms/umcs7840/files/pkg-deinstall.in
new file mode 100644
index 000000000000..5de13d7c3787
--- /dev/null
+++ b/comms/umcs7840/files/pkg-deinstall.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ /usr/sbin/kldxref %%KMODDIR%%
+fi