aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
commit4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483 (patch)
tree9940a6f7cc2c390c9651e0ced0de687fa53b0764 /comms
parentcc4b09fcc1b7aa6d9ea7bf5c49c796475ca734a8 (diff)
downloadports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.tar.gz
ports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.zip
Update KDE to 4.2.1.
multimedia/phonon port has been split into phonon itself, phonon-xine and phono-gstreamer backends. After updating phonon port you have to install at least one backend. phonon-xine backend is recommended for KDE.
Notes
Notes: svn path=/head/; revision=229712
Diffstat (limited to 'comms')
-rw-r--r--comms/kremotecontrol/distinfo6
-rw-r--r--comms/kremotecontrol/files/patch-ark_plugins_libarchive-libarchivehandler.cpp20
2 files changed, 23 insertions, 3 deletions
diff --git a/comms/kremotecontrol/distinfo b/comms/kremotecontrol/distinfo
index 5bf5f73fd46e..cd8792021961 100644
--- a/comms/kremotecontrol/distinfo
+++ b/comms/kremotecontrol/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdeutils-4.2.0.tar.bz2) = f0ca24c7d3e5bb0ab55bf6b26fc6224e
-SHA256 (KDE/kdeutils-4.2.0.tar.bz2) = 1b811b5ea12641aa4003dcc97ea19570418e83a909866f78c08a358a1e1a1cfd
-SIZE (KDE/kdeutils-4.2.0.tar.bz2) = 2234345
+MD5 (KDE/kdeutils-4.2.1.tar.bz2) = ed3397244a64530c108e76d6767c07d0
+SHA256 (KDE/kdeutils-4.2.1.tar.bz2) = a8225e4a430bade4106c2bcd5c1b6f5f2cd3c6e68c2a89bfc90aabc277271d77
+SIZE (KDE/kdeutils-4.2.1.tar.bz2) = 2239659
diff --git a/comms/kremotecontrol/files/patch-ark_plugins_libarchive-libarchivehandler.cpp b/comms/kremotecontrol/files/patch-ark_plugins_libarchive-libarchivehandler.cpp
new file mode 100644
index 000000000000..6f6752537061
--- /dev/null
+++ b/comms/kremotecontrol/files/patch-ark_plugins_libarchive-libarchivehandler.cpp
@@ -0,0 +1,20 @@
+--- ../ark/plugins/libarchive/libarchivehandler.cpp.orig 2009-02-01 00:16:54.000000000 +0100
++++ ../ark/plugins/libarchive/libarchivehandler.cpp 2009-02-01 00:19:50.000000000 +0100
+@@ -567,7 +567,7 @@
+ }
+ }
+
+- ret = archive_write_finish(arch_writer);
++ archive_write_finish(arch_writer);
+
+ if (!creatingNewFile) {
+ archive_read_finish( arch_reader );
+@@ -700,7 +700,7 @@
+ archive_entry_clear( entry );
+ }
+
+- ret = archive_write_finish(arch_writer);
++ archive_write_finish(arch_writer);
+
+ archive_read_finish( arch_reader );
+