aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2011-12-19 15:55:42 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2011-12-19 15:55:42 +0000
commit4d865aab455111f6beaf2433b8c3be7e75ac7bb9 (patch)
tree5166d4bf109cb44c684f111b3e3a7ecc21f58956 /comms
parent1f1e96612d818b1c6183511feeb5ffe1b9a2da7b (diff)
downloadports-4d865aab455111f6beaf2433b8c3be7e75ac7bb9.tar.gz
ports-4d865aab455111f6beaf2433b8c3be7e75ac7bb9.zip
Add support for amd64.
PR: ports/163305 Submitted by: Howard Goldstein <hg@queue.to>
Notes
Notes: svn path=/head/; revision=287655
Diffstat (limited to 'comms')
-rw-r--r--comms/libfec/Makefile10
-rw-r--r--comms/libfec/files/patch-dotprod.c12
2 files changed, 20 insertions, 2 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index e838bab90b24..7bb09843f883 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -22,10 +22,16 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= include/fec.h lib/libfec.so lib/libfec.a
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/libfec/files/patch-dotprod.c b/comms/libfec/files/patch-dotprod.c
new file mode 100644
index 000000000000..f207d9b248a3
--- /dev/null
+++ b/comms/libfec/files/patch-dotprod.c
@@ -0,0 +1,12 @@
+*** dotprod.c 2006-10-12 21:10:53.000000000 -0400
+--- ../../foowork/fec-3.0.1/dotprod.c 2011-12-14 20:43:00.132752233 -0500
+***************
+*** 54,59 ****
+--- 54,60 ----
+ switch(Cpu_mode){
+ case PORT:
+ default:
++ return feedp_port(p);
+ #ifdef __i386__
+ case MMX:
+ case SSE: