aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2022-01-12 18:49:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2022-01-12 18:50:22 +0000
commit72811e6606a8b4b3a1bebd0867e2a20a1c2e60f9 (patch)
tree8bda571b069a95b3ccfe4c03b16d42212d2cf3b0 /comms
parent8d0e3b1638e848770e19bca6b9f30c5142640a2f (diff)
downloadports-72811e6606a8b4b3a1bebd0867e2a20a1c2e60f9.tar.gz
ports-72811e6606a8b4b3a1bebd0867e2a20a1c2e60f9.zip
comms/minicom: update to 2.8
- Switch to new upstream and update to the latest version - Assign maintainership to submitter PR: 260967 Submitted by: Dustin Marquess
Diffstat (limited to 'comms')
-rw-r--r--comms/minicom/Makefile11
-rw-r--r--comms/minicom/distinfo6
-rw-r--r--comms/minicom/files/patch-minicom.h30
-rw-r--r--comms/minicom/files/patch-src-script.c12
-rw-r--r--comms/minicom/files/patch-src-updown.c11
-rw-r--r--comms/minicom/files/patch-src-window.c8
-rw-r--r--comms/minicom/files/patch-sysdep1.c55
-rw-r--r--comms/minicom/pkg-descr2
-rw-r--r--comms/minicom/pkg-plist2
9 files changed, 19 insertions, 118 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index bdad5694308b..222bdf4d0212 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -1,12 +1,10 @@
# Created by: obrien@cs.ucdavis.edu
PORTNAME= minicom
-PORTVERSION= 2.7.1
-PORTREVISION= 2
+PORTVERSION= 2.8
CATEGORIES= comms
-MASTER_SITES= https://fossies.org/linux/misc/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jailbird@fdf.net
COMMENT= MS-DOS Telix serial communication program "workalike"
LICENSE= GPLv2+
@@ -23,6 +21,11 @@ CONFIGURE_ARGS= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom
LIBS+= ${ICONV_LIB} -lncurses
+USE_GITLAB= yes
+GL_SITE= https://salsa.debian.org/
+GL_ACCOUNT= minicom-team
+GL_COMMIT= 1fb24b4f8e22e5580da9e8d453d8e5c3a18aed6c
+
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_USES= gettext
diff --git a/comms/minicom/distinfo b/comms/minicom/distinfo
index 8a742f5e8433..0d4d8d75230c 100644
--- a/comms/minicom/distinfo
+++ b/comms/minicom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494356851
-SHA256 (minicom-2.7.1.tar.gz) = 532f836b7a677eb0cb1dca8d70302b73729c3d30df26d58368d712e5cca041f1
-SIZE (minicom-2.7.1.tar.gz) = 875939
+TIMESTAMP = 1609523155
+SHA256 (minicom-team-minicom-1fb24b4f8e22e5580da9e8d453d8e5c3a18aed6c_GL0.tar.gz) = adbc036bb1b1a54d4e6cc05d904feac46cd2238c87bf2944e5ea1d4415e4e30c
+SIZE (minicom-team-minicom-1fb24b4f8e22e5580da9e8d453d8e5c3a18aed6c_GL0.tar.gz) = 949296
diff --git a/comms/minicom/files/patch-minicom.h b/comms/minicom/files/patch-minicom.h
deleted file mode 100644
index a2d397e30469..000000000000
--- a/comms/minicom/files/patch-minicom.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/minicom.h.orig 2020-08-20 23:32:58.277841000 +0700
-+++ src/minicom.h 2020-08-20 23:49:18.458829000 +0700
-@@ -110,13 +110,13 @@
-
- EXTERN char *dial_name; /* System we're conneced to */
- EXTERN char *dial_number; /* Number we've dialed. */
--EXTERN char *dial_user; /* Our username there */
--EXTERN char *dial_pass; /* Our password */
-+extern char *dial_user; /* Our username there */
-+extern char *dial_pass; /* Our password */
-
- #ifdef USE_SOCKET
--EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
--EXTERN int portfd_is_connected; /* 1 if the socket is connected */
--EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
-+extern int portfd_is_socket; /* File descriptor is a unix socket */
-+extern int portfd_is_connected; /* 1 if the socket is connected */
-+extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
- #define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
- ? -1 : portfd)
- #else
-@@ -142,7 +142,7 @@
- EXTERN int st_attr; /* Status Bar attributes. */
-
- /* jl 04.09.97 conversion tables */
--EXTERN unsigned char vt_outmap[256], vt_inmap[256];
-+extern unsigned char vt_outmap[256], vt_inmap[256];
-
- /* MARK updated 02/17/95 - history buffer */
- EXTERN int num_hist_lines; /* History buffer size */
diff --git a/comms/minicom/files/patch-src-script.c b/comms/minicom/files/patch-src-script.c
index 2af8b806b973..bb3292ba14c5 100644
--- a/comms/minicom/files/patch-src-script.c
+++ b/comms/minicom/files/patch-src-script.c
@@ -1,14 +1,6 @@
---- src/script.c.orig 2013-10-29 11:07:42 UTC
+--- src/script.c.orig 2022-01-06 04:57:01 UTC
+++ src/script.c
-@@ -32,6 +32,7 @@
- #include <config.h>
- #endif
-
-+#include <sys/wait.h>
- #include <stdarg.h>
-
- #include "port.h"
-@@ -76,7 +77,7 @@ struct env {
+@@ -77,7 +77,7 @@ struct env {
struct env *curenv; /* Execution environment */
int gtimeout = 120; /* Global Timeout */
int etimeout = 0; /* Timeout in expect routine */
diff --git a/comms/minicom/files/patch-src-updown.c b/comms/minicom/files/patch-src-updown.c
deleted file mode 100644
index 48db9ee508d1..000000000000
--- a/comms/minicom/files/patch-src-updown.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/updown.c.orig 2013-12-08 10:25:06 UTC
-+++ src/updown.c
-@@ -298,7 +298,7 @@ void updown(int what, int nr)
- do_log("%s", cmdline); /* jl 22.06.97 */
-
- if (P_PFULL(g) == 'N') {
-- win = mc_wopen(10, 7, 70, 13, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
-+ win = mc_wopen(5, 5, 74, 11, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
- snprintf(title, sizeof(title), _("%.30s %s - Press CTRL-C to quit"), P_PNAME(g),
- what == 'U' ? _("upload") : _("download"));
- mc_wtitle(win, TMID, title);
diff --git a/comms/minicom/files/patch-src-window.c b/comms/minicom/files/patch-src-window.c
index 8eefb31cd206..be411e2cb4ba 100644
--- a/comms/minicom/files/patch-src-window.c
+++ b/comms/minicom/files/patch-src-window.c
@@ -1,4 +1,4 @@
---- src/window.c.orig 2010-12-12 13:56:25 UTC
+--- src/window.c.orig 2021-01-01 17:45:55 UTC
+++ src/window.c
@@ -66,6 +66,7 @@ static const char *CE, *Al, *Dl, *AL, *DL;
static const char *CS, *SF, *SR, *VB, *BL;
@@ -8,7 +8,7 @@
static const char *CR, *NL;
#ifdef ST_LINE
static const char *TS, *FS, *DS;
-@@ -335,8 +336,8 @@ static void _gotoxy(int x, int y)
+@@ -320,8 +321,8 @@ static void _gotoxy(int x, int y)
else if (NL != NULL && x == 0 && x == curx && y == cury + 1)
outstr(NL);
#endif
@@ -19,7 +19,7 @@
else
outstr(tgoto(CM, x, y));
curx = x;
-@@ -2000,7 +2001,7 @@ int win_init(int fg, int bg, int attr)
+@@ -1950,7 +1951,7 @@ int win_init(int fg, int bg, int attr)
CL = tgetstr("cl", &_tptr);
IC = tgetstr("ic", &_tptr);
DC = tgetstr("dc", &_tptr);
@@ -28,7 +28,7 @@
CR = tgetstr("cr", &_tptr);
NL = tgetstr("nl", &_tptr);
AC = tgetstr("ac", &_tptr);
-@@ -2059,11 +2060,11 @@ int win_init(int fg, int bg, int attr)
+@@ -2009,11 +2010,11 @@ int win_init(int fg, int bg, int attr)
_has_am = tgetflag("am");
_mv_standout = tgetflag("ms");
if (tgetflag("bs")) {
diff --git a/comms/minicom/files/patch-sysdep1.c b/comms/minicom/files/patch-sysdep1.c
deleted file mode 100644
index ba4569d8d915..000000000000
--- a/comms/minicom/files/patch-sysdep1.c
+++ /dev/null
@@ -1,55 +0,0 @@
---- src/sysdep1.c.orig 2009-12-12 15:47:47 UTC
-+++ src/sysdep1.c
-@@ -65,13 +65,13 @@ static void m_setrts(int fd)
- if (portfd_is_socket)
- return;
- #endif
--#if defined(TIOCM_RTS) && defined(TIOCMODG)
-+#if defined(TIOCM_RTS) && defined(TIOCMGET)
- {
- int mcs=0;
-
-- ioctl(fd, TIOCMODG, &mcs);
-+ ioctl(fd, TIOCMGET, &mcs);
- mcs |= TIOCM_RTS;
-- ioctl(fd, TIOCMODS, &mcs);
-+ ioctl(fd, TIOCMSET, &mcs);
- }
- #endif
- }
-@@ -180,11 +180,11 @@ int m_getdcd(int fd)
- return portfd_is_connected;
- }
- #endif
--#ifdef TIOCMODG
-+#ifdef TIOCMODGET
- {
- int mcs = 0;
-
-- if (ioctl(fd, TIOCMODG, &mcs) < 0)
-+ if (ioctl(fd, TIOCMODGET, &mcs) < 0)
- return -1;
- return mcs & TIOCM_CAR ? 1 : 0;
- }
-@@ -227,8 +227,8 @@ void m_savestate(int fd)
- ioctl(fd, TIOCLGET, &lsw);
- # endif
- #endif
--#ifdef TIOCMODG
-- ioctl(fd, TIOCMODG, &m_word);
-+#ifdef TIOCMGET
-+ ioctl(fd, TIOCMGET, &m_word);
- #endif
- }
-
-@@ -252,8 +252,8 @@ void m_restorestate(int fd)
- ioctl(fd, TIOCLSET, &lsw);
- # endif
- #endif
--#ifdef TIOCMODS
-- ioctl(fd, TIOCMODS, &m_word);
-+#ifdef TIOCMSET
-+ ioctl(fd, TIOCMSET, &m_word);
- #endif
- }
-
diff --git a/comms/minicom/pkg-descr b/comms/minicom/pkg-descr
index 383eb9509590..7b9049388ed8 100644
--- a/comms/minicom/pkg-descr
+++ b/comms/minicom/pkg-descr
@@ -3,4 +3,4 @@ well-known MS-DOS Telix program. It has ANSI color, dialing directory,
dial-a-list, script language, file up/download support, screen capture,
scroll-back, etc.
-WWW: http://alioth.debian.org/projects/minicom/
+WWW: https://salsa.debian.org/minicom-team/minicom/
diff --git a/comms/minicom/pkg-plist b/comms/minicom/pkg-plist
index fe6ec9070ea5..bfaceb782211 100644
--- a/comms/minicom/pkg-plist
+++ b/comms/minicom/pkg-plist
@@ -22,8 +22,10 @@ man/man1/xminicom.1.gz
%%NLS%%share/locale/pt_BR/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/ru/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/rw/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/sv/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/vi/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/minicom.mo
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog