aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /comms
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Notes
Notes: svn path=/head/; revision=238781
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile2
-rw-r--r--comms/ghfaxviewer/Makefile2
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/gsmlib/Makefile2
-rw-r--r--comms/hamlib/Makefile2
-rw-r--r--comms/kallers/Makefile2
-rw-r--r--comms/klog/Makefile2
-rw-r--r--comms/kmobiletools/Makefile2
-rw-r--r--comms/kpsk/Makefile2
-rw-r--r--comms/ktrack/Makefile2
-rw-r--r--comms/libsyncml/Makefile2
-rw-r--r--comms/libticables/Makefile2
-rw-r--r--comms/libticables2/Makefile2
-rw-r--r--comms/libticalcs2/Makefile2
-rw-r--r--comms/lirc/Makefile2
-rw-r--r--comms/spandsp-devel/Makefile2
-rw-r--r--comms/spandsp-devel5/Makefile2
-rw-r--r--comms/spandsp/Makefile2
-rw-r--r--comms/tilp2/Makefile2
-rw-r--r--comms/tlf/Makefile2
-rw-r--r--comms/wsjt/Makefile2
-rw-r--r--comms/xwota/Makefile2
22 files changed, 22 insertions, 22 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index ef120a0ce312..0d5cee1f0ac3 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262 automake:110 libtool:15
+USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib"
USE_GMAKE= yes
diff --git a/comms/ghfaxviewer/Makefile b/comms/ghfaxviewer/Makefile
index ab38b6aba2d1..28f56cd85862 100644
--- a/comms/ghfaxviewer/Makefile
+++ b/comms/ghfaxviewer/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gconf gnomeprint
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index ed306c164a95..4a43d07d3671 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -31,7 +31,7 @@ USE_PYTHON= 2.4+
USE_WX= 2.6+
WX_COMPS= wx wx:build wx:run python:build python:run
USE_PERL5= yes
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 8c294ac3eb93..a59dd5619e75 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library to access GSM mobile phones through GSM modems
USE_GNOME= gnometarget lthack
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index c8bd262ade8d..0336c0847914 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= pkgconfig gnomehack libxml2
USE_PERL5= yes
USE_TCL= yes
USE_PYTHON= yes
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-perl-binding --with-python=${PYTHON_CMD} \
diff --git a/comms/kallers/Makefile b/comms/kallers/Makefile
index 1c371ece7414..0a2de5cfaa8e 100644
--- a/comms/kallers/Makefile
+++ b/comms/kallers/Makefile
@@ -17,7 +17,7 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
@${REINPLACE_CMD} -e 's|@CXXFLAGS@|@CXXFLAGS@ -fPIC|' \
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
index 4ae5dd66135b..5cc38b2da6e6 100644
--- a/comms/klog/Makefile
+++ b/comms/klog/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= hamlib.2:${PORTSDIR}/comms/hamlib
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:15:env
+USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:22:env
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/comms/kmobiletools/Makefile b/comms/kmobiletools/Makefile
index 372c8a24dec9..ba946418405d 100644
--- a/comms/kmobiletools/Makefile
+++ b/comms/kmobiletools/Makefile
@@ -18,7 +18,7 @@ COMMENT= Control mobile phones with your PC
USE_KDELIBS_VER=3
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/comms/kpsk/Makefile b/comms/kpsk/Makefile
index 4e93fbc98f90..7ce848cf853b 100644
--- a/comms/kpsk/Makefile
+++ b/comms/kpsk/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-D_POSIX_C_SOURCE -I${LOCALBASE}/include" \
USER_LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-debug=full
diff --git a/comms/ktrack/Makefile b/comms/ktrack/Makefile
index e1b5349eb6b9..dace400550bb 100644
--- a/comms/ktrack/Makefile
+++ b/comms/ktrack/Makefile
@@ -26,7 +26,7 @@ USE_KDEBASE_VER=3
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GETTEXT= yes
post-patch:
diff --git a/comms/libsyncml/Makefile b/comms/libsyncml/Makefile
index ee316bcdd3d0..64aade612f7e 100644
--- a/comms/libsyncml/Makefile
+++ b/comms/libsyncml/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= wbxml2:${PORTSDIR}/textproc/wbxml2 \
openobex:${PORTSDIR}/comms/openobex \
soup-2.2.8:${PORTSDIR}/devel/libsoup22
-USE_AUTOTOOLS= autoheader:262 automake:110 libtool:15
+USE_AUTOTOOLS= autoheader:262 automake:110 libtool:22
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= glib20 libxml2
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index 78a40cb6c708..0b1622f16360 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -18,7 +18,7 @@ COMMENT= TI calculator link cables library
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index d032f3ce2644..7fae9e2f53ee 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -18,7 +18,7 @@ COMMENT= TI calculator link cables library
LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack pkgconfig
USE_LDCONFIG= yes
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index 72d7c941632e..f4aa3d804cf5 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= ticables2.1:${PORTSDIR}/comms/libticables2 \
ticonv.3:${PORTSDIR}/converters/libticonv \
tifiles2.5:${PORTSDIR}/devel/libtifiles2
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack pkgconfig
USE_LDCONFIG= yes
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 917ab9b1057e..98ba142d266e 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lirc
MAINTAINER= doconnor@gsoft.com.au
COMMENT= Linux Infared Remote Control
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GMAKE= yes
USE_XORG= x11
diff --git a/comms/spandsp-devel/Makefile b/comms/spandsp-devel/Makefile
index f4fb4e3c3b2d..23d38bdbf4af 100644
--- a/comms/spandsp-devel/Makefile
+++ b/comms/spandsp-devel/Makefile
@@ -20,7 +20,7 @@ COMMENT= A DSP library and software FAX machine
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/spandsp-${DISTVERSION:C/pre.*//}
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/comms/spandsp-devel5/Makefile b/comms/spandsp-devel5/Makefile
index edcb2ea1d13f..581b39e1f145 100644
--- a/comms/spandsp-devel5/Makefile
+++ b/comms/spandsp-devel5/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
LATEST_LINK= ${PORTNAME}5
WRKSRC= ${WRKDIR}/spandsp-0.0.5
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index cfe5086a59ff..fb42e0c4bf76 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index c7f453858d87..e4b8fac35e02 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= ticables2.1:${PORTSDIR}/comms/libticables2 \
ticalcs2.7:${PORTSDIR}/comms/libticalcs2 \
ticonv.3:${PORTSDIR}/converters/libticonv
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_GNOME= gtk20 libglade2
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index f17116571ff4..a55d59d6dd11 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio curses based logging program
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOTOOLS= autoconf:262 libtool:15 aclocal:19 automake:19
+USE_AUTOTOOLS= autoconf:262 libtool:22 aclocal:19 automake:19
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib"
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 2f951a5892b9..c0fdbd969990 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --with-portaudio-include-dir=${LOCALBASE}/include/portaudio2 \
--with-portaudio-lib-dir=${LOCALBASE}/lib/portaudio2
USE_GMAKE= yes
USE_PYTHON= 2.4+
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
diff --git a/comms/xwota/Makefile b/comms/xwota/Makefile
index 32b3cbfe6a78..2518cfa26b80 100644
--- a/comms/xwota/Makefile
+++ b/comms/xwota/Makefile
@@ -19,7 +19,7 @@ COMMENT= X version of who is on the air
USE_GNOME= gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-install:
.if !defined(NOPORTDOCS)