aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-08-17 21:04:58 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-08-17 21:04:58 +0000
commit78e978fe35877cc23e72974e3c88f70ea7e98de7 (patch)
treeba4eec943def4dc114b2c83426ccae59784c2bd8 /comms
parent9f8867cf6243cfba9f19d08f3dd2c7c65c68e08d (diff)
downloadports-78e978fe35877cc23e72974e3c88f70ea7e98de7.tar.gz
ports-78e978fe35877cc23e72974e3c88f70ea7e98de7.zip
Fix minicom build for WITHOUT_NLS (force libiconv dependency and linking)
Reported by: Gordon Shumway PR: ports/159739
Notes
Notes: svn path=/head/; revision=279926
Diffstat (limited to 'comms')
-rw-r--r--comms/minicom/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 6deff9a547ef..4f4f3000e3c0 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -16,22 +16,25 @@ COMMENT= An MS-DOS Telix serial communication program "workalike"
RUN_DEPENDS= lrz:${PORTSDIR}/comms/lrzsz
+USE_ICONV= yes
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock \
--enable-dfl-port=${MINICOM_DEFAULT_PORT} \
- CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+MAKE_ARGS+= LIBS+="-liconv -lcurses"
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1