aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-04-05 20:37:03 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-04-05 20:37:03 +0000
commit7d440b5f3b8e1a9d3c45beb791304446992ca71b (patch)
tree919e0d350de2ba92614d67cbcb82b700d2b67352 /comms
parente42a337bd9eefe2e8a0fd9341f1bd75f3f42b807 (diff)
downloadports-7d440b5f3b8e1a9d3c45beb791304446992ca71b.tar.gz
ports-7d440b5f3b8e1a9d3c45beb791304446992ca71b.zip
SMS::SMS77 consists of a perl interface and a script to send SMS
via the german provider SMS77.de WWW: http://www.w3r3wolf.de/blog/2007/09/19/smssms77-version-001.html Submitted by: Frank Steinborn <steinex AT nognu.de>
Notes
Notes: svn path=/head/; revision=252269
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-SMS-SMS77/Makefile25
-rw-r--r--comms/p5-SMS-SMS77/distinfo3
-rw-r--r--comms/p5-SMS-SMS77/pkg-descr4
-rw-r--r--comms/p5-SMS-SMS77/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 2293f1181cad..4ce6d050ce37 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -102,6 +102,7 @@
SUBDIR += p5-SMS-Send-TW-Socket2Air
SUBDIR += p5-SMS-Send-TW-chtsns
SUBDIR += p5-SMS-Send-TW-emome
+ SUBDIR += p5-SMS-SMS77
SUBDIR += picocom
SUBDIR += pr
SUBDIR += predict
diff --git a/comms/p5-SMS-SMS77/Makefile b/comms/p5-SMS-SMS77/Makefile
new file mode 100644
index 000000000000..b62696b14adb
--- /dev/null
+++ b/comms/p5-SMS-SMS77/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-SMS-SMS77
+# Date created: 2010-02-04
+# Whom: Frank Steinborn <steinex@nognu.de>
+#
+# $FreeBSD$
+
+PORTNAME= SMS-SMS77
+PORTVERSION= 0.01
+CATEGORIES= comms net perl5
+MASTER_SITES= http://www.w3r3wolf.de/files/sms77/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Perl interface and script to send SMS via SMS77.de
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+MAN1= sms77send.1
+MAN3= SMS::SMS77::Message.3 \
+ SMS::SMS77.3
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/comms/p5-SMS-SMS77/distinfo b/comms/p5-SMS-SMS77/distinfo
new file mode 100644
index 000000000000..1e002d9a1627
--- /dev/null
+++ b/comms/p5-SMS-SMS77/distinfo
@@ -0,0 +1,3 @@
+MD5 (SMS-SMS77-0.01.tar.gz) = e53af7a5aaf7b9dc79c360136265d942
+SHA256 (SMS-SMS77-0.01.tar.gz) = bb436e7cb5ae3490730443c3d3060ff320fb90be781c6ccf4cd9996a74b06814
+SIZE (SMS-SMS77-0.01.tar.gz) = 4181
diff --git a/comms/p5-SMS-SMS77/pkg-descr b/comms/p5-SMS-SMS77/pkg-descr
new file mode 100644
index 000000000000..f4ff37a607aa
--- /dev/null
+++ b/comms/p5-SMS-SMS77/pkg-descr
@@ -0,0 +1,4 @@
+SMS::SMS77 consists of a perl interface and a script to send SMS
+via the german provider SMS77.de
+
+WWW: http://www.w3r3wolf.de/blog/2007/09/19/smssms77-version-001.html
diff --git a/comms/p5-SMS-SMS77/pkg-plist b/comms/p5-SMS-SMS77/pkg-plist
new file mode 100644
index 000000000000..19374cb565c1
--- /dev/null
+++ b/comms/p5-SMS-SMS77/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/SMS/SMS77.pm
+%%SITE_PERL%%/SMS/SMS77/Message.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/SMS77/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/SMS77
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS
+@dirrmtry %%SITE_PERL%%/SMS/SMS77
+@dirrmtry %%SITE_PERL%%/SMS
+bin/sms77send