aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-01-13 10:48:07 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-01-13 10:48:07 +0000
commitaddfa4977307adfc0e31f7afac2a8e44fa8ee27c (patch)
tree8722887fbee0c9b9074c17835956d99016b8a677 /comms
parent6f326a7f9a684a88d587a01d49a1af6a2a5da1a2 (diff)
downloadports-addfa4977307adfc0e31f7afac2a8e44fa8ee27c.tar.gz
ports-addfa4977307adfc0e31f7afac2a8e44fa8ee27c.zip
- Fix build with Clang.
Notes
Notes: svn path=/head/; revision=289097
Diffstat (limited to 'comms')
-rw-r--r--comms/libimobiledevice/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 2202386ed4d1..639eb5ade556 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -22,12 +22,13 @@ LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls \
plist.1:${PORTSDIR}/devel/libplist \
usbmuxd.1:${PORTSDIR}/comms/usbmuxd
-USE_BZIP2= yes
USE_GNOME= glib20
+USE_BZIP2= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USE_CSTD= gnu89
MAKE_JOBS_SAFE= yes
-CFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
PORTDOCS= AUTHORS NEWS README