aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 18:41:15 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 18:41:15 +0000
commitbbc8c4d740872dbe971f6164448e5ba893cb166f (patch)
treec756810defa7862a81134a13cec391bfef55e24e /comms
parent7eb500363752ce8dd82189f56d621b11450e92f9 (diff)
downloadports-bbc8c4d740872dbe971f6164448e5ba893cb166f.tar.gz
ports-bbc8c4d740872dbe971f6164448e5ba893cb166f.zip
Convert a bunch of USE_BZIP2 to USES=tar:bzip2
Approved by: portmgr (not really, but touches unstaged ports)
Notes
Notes: svn path=/head/; revision=363371
Diffstat (limited to 'comms')
-rw-r--r--comms/gammu-devel/Makefile3
-rw-r--r--comms/gtkmmorse/Makefile3
-rw-r--r--comms/hamfax/Makefile3
-rw-r--r--comms/libfec/Makefile3
-rw-r--r--comms/libimobiledevice/Makefile3
-rw-r--r--comms/usbmuxd/Makefile3
-rw-r--r--comms/wsjt/Makefile3
7 files changed, 7 insertions, 14 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index e80c64d080f4..0e778f568a1d 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -19,10 +19,9 @@ CONFLICTS= gammu-[1-9]* gammu-python-[1-9]*
CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
-USES= cmake gettext pkgconfig
+USES= cmake gettext pkgconfig tar:bzip2
USE_PYTHON= yes
USE_GNOME= glib20
-USE_BZIP2= yes
USE_LDCONFIG= yes
PORTDOCS= *
diff --git a/comms/gtkmmorse/Makefile b/comms/gtkmmorse/Makefile
index cd14270dc715..1a019d8abd8f 100644
--- a/comms/gtkmmorse/Makefile
+++ b/comms/gtkmmorse/Makefile
@@ -14,9 +14,8 @@ LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= pkgconfig tar:bzip2
PLIST_FILES= bin/gtkmmorse \
man/man1/gtkmmorse.1.gz
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
index 5923b4dc69bf..8cd281c493de 100644
--- a/comms/hamfax/Makefile
+++ b/comms/hamfax/Makefile
@@ -16,7 +16,6 @@ USE_QT4= gui moc_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-USES= gmake pkgconfig
-USE_BZIP2= yes
+USES= gmake pkgconfig tar:bzip2
.include <bsd.port.mk>
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index dea6ce6984de..3974f3526185 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -15,8 +15,7 @@ COMMENT= Several forward error correction (FEC) decoders
MAKEFILE= makefile
GNU_CONFIGURE= yes
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= include/fec.h \
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 17575e2a2484..4b399ec74af7 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,8 +13,7 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= openssl_LIBS=-lssl
CFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index 6748b312bb18..af4a3675f06f 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -10,8 +10,7 @@ COMMENT= Daemon for multiplexing connections over USB to iPhone/iPod Touch
LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist
-USE_BZIP2= yes
-USES= cmake pkgconfig
+USES= cmake pkgconfig tar:bzip2
USE_LDCONFIG= yes
PORTDOCS= AUTHORS README README.devel
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index fd2598a52c04..97f2b6b19807 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -22,8 +22,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy \
${PYNUMPY}
ALL_TARGET= build
-USES= fortran gmake
-USE_BZIP2= yes
+USES= fortran gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gfortran --prefix=${LOCALBASE} \
--with-portaudio-include-dir=${LOCALBASE}/include/portaudio2 \