aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-25 07:03:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-25 07:03:39 +0000
commitd5151ddfa625070f25ceb0d53b3b9f1ea688f872 (patch)
treeb23ce769f17f2022ae8fc4653b25e2f58b11fe1c /comms
parent32ee6cc3b0c8f43f498121a0668a4de8e8f74e3d (diff)
downloadports-d5151ddfa625070f25ceb0d53b3b9f1ea688f872.tar.gz
ports-d5151ddfa625070f25ceb0d53b3b9f1ea688f872.zip
- Add p5-Nexmo-SMS 0.03
Nexmo::SMS is a perl module which allow you to send SMS via http://www.nexmo.com/ WWW: http://search.cpan.org/dist/Nexmo-SMS/ PR: ports/162865 Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> Feature safe: yes
Notes
Notes: svn path=/head/; revision=286393
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-Nexmo-SMS/Makefile34
-rw-r--r--comms/p5-Nexmo-SMS/distinfo2
-rw-r--r--comms/p5-Nexmo-SMS/pkg-descr4
-rw-r--r--comms/p5-Nexmo-SMS/pkg-plist14
5 files changed, 55 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index bc5e19969775..b77a6b3f9aa7 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -91,6 +91,7 @@
SUBDIR += p5-Device-Modem
SUBDIR += p5-Device-SerialPort
SUBDIR += p5-Fax-Hylafax-Client
+ SUBDIR += p5-Nexmo-SMS
SUBDIR += p5-SMS-SMS77
SUBDIR += p5-SMS-Send
SUBDIR += p5-SMS-Send-DeviceGsm
diff --git a/comms/p5-Nexmo-SMS/Makefile b/comms/p5-Nexmo-SMS/Makefile
new file mode 100644
index 000000000000..0f1dc60d1dcd
--- /dev/null
+++ b/comms/p5-Nexmo-SMS/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Nexmo-SMS
+# Date created: 2011-11-25
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nexmo-SMS
+PORTVERSION= 0.03
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RENEEB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= Send SMS via http://www.nexmo.com/ API
+
+BUILD_DEPENDS= p5-HTTP-Message>=5.836:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-JSON-PP>=2.26000:${PORTSDIR}/converters/p5-JSON-PP \
+ p5-libwww>=5.835:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Nexmo::SMS.3 \
+ Nexmo::SMS::BinaryMessage.3 \
+ Nexmo::SMS::GetBalance.3 \
+ Nexmo::SMS::MockLWP.3 \
+ Nexmo::SMS::Response.3 \
+ Nexmo::SMS::Response::Message.3 \
+ Nexmo::SMS::TextMessage.3 \
+ Nexmo::SMS::WAPPushMessage.3
+
+.include <bsd.port.mk>
diff --git a/comms/p5-Nexmo-SMS/distinfo b/comms/p5-Nexmo-SMS/distinfo
new file mode 100644
index 000000000000..9055c9de936c
--- /dev/null
+++ b/comms/p5-Nexmo-SMS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Nexmo-SMS-0.03.tar.gz) = 0d34fd04de1a016861193aac8495aa215e16a7f9f8ca5a4e41bfc13cd82a496a
+SIZE (Nexmo-SMS-0.03.tar.gz) = 12519
diff --git a/comms/p5-Nexmo-SMS/pkg-descr b/comms/p5-Nexmo-SMS/pkg-descr
new file mode 100644
index 000000000000..f35e9029710e
--- /dev/null
+++ b/comms/p5-Nexmo-SMS/pkg-descr
@@ -0,0 +1,4 @@
+Nexmo::SMS is a perl module which allow you to send SMS via
+http://www.nexmo.com/
+
+WWW: http://search.cpan.org/dist/Nexmo-SMS/
diff --git a/comms/p5-Nexmo-SMS/pkg-plist b/comms/p5-Nexmo-SMS/pkg-plist
new file mode 100644
index 000000000000..5c0d66ada29c
--- /dev/null
+++ b/comms/p5-Nexmo-SMS/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Nexmo/SMS.pm
+%%SITE_PERL%%/Nexmo/SMS/BinaryMessage.pm
+%%SITE_PERL%%/Nexmo/SMS/GetBalance.pm
+%%SITE_PERL%%/Nexmo/SMS/MockLWP.pm
+%%SITE_PERL%%/Nexmo/SMS/Response.pm
+%%SITE_PERL%%/Nexmo/SMS/Response/Message.pm
+%%SITE_PERL%%/Nexmo/SMS/TextMessage.pm
+%%SITE_PERL%%/Nexmo/SMS/WAPPushMessage.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nexmo/SMS/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nexmo/SMS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nexmo
+@dirrm %%SITE_PERL%%/Nexmo/SMS/Response
+@dirrm %%SITE_PERL%%/Nexmo/SMS
+@dirrmtry %%SITE_PERL%%/Nexmo