aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2011-05-23 14:17:17 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2011-05-23 14:17:17 +0000
commitd990afe83bedade08378c977e2c05f22b19efb1e (patch)
treefd623ceec6365baec231dc8a2f5ae95100747207 /comms
parent78f59cb9b4fe48e379745004db34ef4b7fd4d2b8 (diff)
downloadports-d990afe83bedade08378c977e2c05f22b19efb1e.tar.gz
ports-d990afe83bedade08378c977e2c05f22b19efb1e.zip
1. Incorporate a patch from the development repository to fix an error:
----- Scanning dependencies of target sqlreply > Building C object contrib/sqlreply/CMakeFiles/sqlreply.dir/c/michal.o > /usr/ports/comms/gammu/work/gammu-1.29.0/contrib/sqlreply/c/michal.c:16:25: error: mysql/mysql.h: No such file or directory ----- The error occures only if a mysql port/package is installed. 2. Bump PORTREVISION. Pointed out by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> (via freebsd-ports@)
Notes
Notes: svn path=/head/; revision=274516
Diffstat (limited to 'comms')
-rw-r--r--comms/gammu/Makefile2
-rw-r--r--comms/gammu/files/patch-contrib_sqlreply_c_Makefile27
2 files changed, 28 insertions, 1 deletions
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index e14732069a4c..52abf71d95a6 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gammu
PORTVERSION= 1.29.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= http://dl.cihar.com/gammu/releases/ \
http://dl.cihar.com.nyud.net/gammu/releases/
diff --git a/comms/gammu/files/patch-contrib_sqlreply_c_Makefile b/comms/gammu/files/patch-contrib_sqlreply_c_Makefile
new file mode 100644
index 000000000000..02317ebfb744
--- /dev/null
+++ b/comms/gammu/files/patch-contrib_sqlreply_c_Makefile
@@ -0,0 +1,27 @@
+From 35fb0da26e6d38ba9f5b5d357abc920dd3c2b752 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Michal=20=C4=8Ciha=C5=99?= <mcihar@novell.com>
+Date: Wed, 11 May 2011 10:16:27 +0200
+Subject: [PATCH] Fix include for MySQL (bug #1447).
+
+---
+ contrib/sqlreply/c/michal.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/contrib/sqlreply/c/michal.c b/contrib/sqlreply/c/michal.c
+index d8541d1..192f9f0 100644
+--- contrib/sqlreply/c/michal.c
++++ contrib/sqlreply/c/michal.c
+@@ -13,8 +13,8 @@
+ #else
+ #include <stdio.h>
+ #include <time.h>
+-#include <mysql/mysql.h>
+-#include <mysql/mysqld_error.h>
++#include <mysql.h>
++#include <mysqld_error.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+ #endif
+--
+1.6.1
+