aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-04-29 07:04:49 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-04-29 07:04:49 +0000
commitf4ea425a5bb8c4c7f08da85f1ed7e25fc336ef3b (patch)
treea250be14ec578716868f89e869870c2db145cc8d /comms
parent835419af27f75f7b862b561ff106cf904dd39147 (diff)
downloadports-f4ea425a5bb8c4c7f08da85f1ed7e25fc336ef3b.tar.gz
ports-f4ea425a5bb8c4c7f08da85f1ed7e25fc336ef3b.zip
Provide more descriptive error messages for ports failing on powerpc64.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=439736
Diffstat (limited to 'comms')
-rw-r--r--comms/telldus-core/Makefile2
-rw-r--r--comms/uartlirc/Makefile9
2 files changed, 3 insertions, 8 deletions
diff --git a/comms/telldus-core/Makefile b/comms/telldus-core/Makefile
index 8c9a26926e2d..299c20bca7bf 100644
--- a/comms/telldus-core/Makefile
+++ b/comms/telldus-core/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libftdi.so:devel/libftdi \
libconfuse.so:devel/libconfuse \
libargp.so:devel/argp-standalone
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: error: strlen was not declared in this scope
BROKEN_sparc64= Does not build
USES= cmake compiler:c++11-lang iconv:wchar_t
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
index fbc7fae6e3f9..2c722336d37f 100644
--- a/comms/uartlirc/Makefile
+++ b/comms/uartlirc/Makefile
@@ -13,7 +13,8 @@ EXTRACT_SUFX= .shar
MAINTAINER= ports@FreeBSD.org
COMMENT= Driver for "homebrew" serial LIRC receivers
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: error: uart.h: No such file or directory
+BROKEN_sparc64= Does not build
USES= kmod
@@ -26,12 +27,6 @@ PLIST_FILES+= ${KMODDIR}/${PORTNAME}.ko
CFLAGS+= ${DEBUG_FLAGS}
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on powerpc or sparc64
-.endif
-
do-install:
${INSTALL} ${WRKSRC}/${PORTNAME}.ko ${STAGEDIR}${KMODDIR}