aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-21 00:16:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-21 00:16:53 +0000
commitf891b45043b1818d4abcc9d92d020629745a6c53 (patch)
treee0bf72f2c9bdeaf7cde14119ee72e23dc3dfbbe4 /comms
parent2ef6f0aac6ddea2e5b2b66c12eac583f5c11b76f (diff)
downloadports-f891b45043b1818d4abcc9d92d020629745a6c53.tar.gz
ports-f891b45043b1818d4abcc9d92d020629745a6c53.zip
comms/xcwcp: Fix build with GCC-based architectures
Also reorder USExx and other lines. PR: 234222 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=487933
Diffstat (limited to 'comms')
-rw-r--r--comms/xcwcp/Makefile8
-rw-r--r--comms/xcwcp/files/patch-src_xcwcp_receiver.h12
2 files changed, 16 insertions, 4 deletions
diff --git a/comms/xcwcp/Makefile b/comms/xcwcp/Makefile
index c80dbb713994..023b7737780c 100644
--- a/comms/xcwcp/Makefile
+++ b/comms/xcwcp/Makefile
@@ -11,10 +11,8 @@ LIB_DEPENDS= libcw.so:comms/unixcw
MASTERDIR= ${.CURDIR}/../unixcw
-PLIST= ${.CURDIR}/pkg-plist
-USE_QT= buildtools gui widgets qmake_build
-USES= gettext qt:5
-# Qt from 5.7.0 on requires c++11.
+USES= compiler:c++11-lang gettext qt:5
+USE_QT= gui widgets buildtools_build qmake_build
USE_CXXSTD= c++11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-xcwcp
@@ -23,6 +21,8 @@ PLIST_FILES= bin/xcwcp \
man/man1/xcwcp.1.gz
LDFLAGS+= -L${LOCALBASE}/lib -lintl
+PLIST= ${.CURDIR}/pkg-plist
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xcwcp/xcwcp ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/src/xcwcp/xcwcp.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/comms/xcwcp/files/patch-src_xcwcp_receiver.h b/comms/xcwcp/files/patch-src_xcwcp_receiver.h
new file mode 100644
index 000000000000..0d173afd0f5b
--- /dev/null
+++ b/comms/xcwcp/files/patch-src_xcwcp_receiver.h
@@ -0,0 +1,12 @@
+--- src/xcwcp/receiver.h.orig 2018-12-20 17:18:13.332583000 +0100
++++ src/xcwcp/receiver.h 2018-12-20 17:18:39.100884000 +0100
+@@ -21,6 +21,9 @@
+
+ #include <QMouseEvent>
+ #include <QKeyEvent>
++#ifdef __FreeBSD__
++#include <sys/time.h>
++#endif
+
+
+